summaryrefslogtreecommitdiff
path: root/games-fps/quake4-bin
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /games-fps/quake4-bin
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'games-fps/quake4-bin')
-rw-r--r--games-fps/quake4-bin/Manifest3
-rw-r--r--games-fps/quake4-bin/metadata.xml25
-rw-r--r--games-fps/quake4-bin/quake4-bin-1.4.2-r2.ebuild133
3 files changed, 161 insertions, 0 deletions
diff --git a/games-fps/quake4-bin/Manifest b/games-fps/quake4-bin/Manifest
new file mode 100644
index 000000000000..02bd8299ed75
--- /dev/null
+++ b/games-fps/quake4-bin/Manifest
@@ -0,0 +1,3 @@
+DIST quake4-linux-1.4.2.x86.run 287552973 BLAKE2B 93c507f17c91168108545e581baf3a7ab7e75a8c7b8a89772292191b87a81ccf6fbd331592e3442a1781df5b71f357c00bb955244a609c48c51d3d4b8c815c6c SHA512 a6a390a8f46c7e696fe865d0688c9a95eb0d9e32ad62ecb796dcc03618994ec065e8c74358518221cb6c8771d2414ed7e144c77a1a8ecd4ae9ce6406459c5f36
+EBUILD quake4-bin-1.4.2-r2.ebuild 3429 BLAKE2B 148a5141c9424fa9d3f6bdbd20e0782cf985eb8329154e2e5248e5f48065e799130daa59a75417a8a54783d9c5881e8237a6a2f17d5d83baad941d8a161b76d0 SHA512 20c98d4f1cb9226e333ab8d5194b35edef3560aa656eb7d45eac0a7cd6926bfc70877bf01b605f7d5e8e4053f19053d2875d5d362309d9563d4f1cf18af6f837
+MISC metadata.xml 1137 BLAKE2B e7787584e4ccd9af82c56f186188e21df5b5c13783685d3b65227e27ccf32e8a860ec065f7a4edb506e2dca604d88d43f5af0ba0e89ee9accc6233d3bfdd0891 SHA512 1ede51f4fcebc6a451ab4790e5d26fd07f464461d15b31c065eb02a77bdc114ba4ec35fb0ca380d980c416007e4671532b053477709fd7d28210b64423132d31
diff --git a/games-fps/quake4-bin/metadata.xml b/games-fps/quake4-bin/metadata.xml
new file mode 100644
index 000000000000..068a2588cec4
--- /dev/null
+++ b/games-fps/quake4-bin/metadata.xml
@@ -0,0 +1,25 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="project">
+ <email>games@gentoo.org</email>
+ <name>Gentoo Games Project</name>
+</maintainer>
+<longdescription>
+In a desparate war for Earth's survival against and unrelenting alient enemy,
+the only way to defeat them is to become one of them.
+
+Earth is under seige by the Strogg, a barbaric alien race moving through the
+universe consuming, recycling and annihilating any civilization in their path.
+In a deperate attempt to survive, an armada of Earth's finest warriors is sent
+to take the battle to the Strogg home planet.
+
+You are Matthow Kane, an elite member of Rhino Squad and Eath's valiant invasion
+force. Fight alone, with your squad, or in hover tanks and mechanized walkers
+as you engage in a heroic mission the the heart of the Strogg war machine.
+
+Quake 4 is the fourth installment of the extremely popular and successful Quake
+series by id software. This game is commercial software, and requires the data
+from a retail copy of the game to play.
+</longdescription>
+</pkgmetadata>
diff --git a/games-fps/quake4-bin/quake4-bin-1.4.2-r2.ebuild b/games-fps/quake4-bin/quake4-bin-1.4.2-r2.ebuild
new file mode 100644
index 000000000000..9fcbebba8bf3
--- /dev/null
+++ b/games-fps/quake4-bin/quake4-bin-1.4.2-r2.ebuild
@@ -0,0 +1,133 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+inherit eutils unpacker games
+
+DESCRIPTION="Sequel to Quake 2, an id Software 3D first-person shooter"
+HOMEPAGE="http://www.quake4game.com/"
+SRC_URI="mirror://idsoftware/quake4/linux/quake4-linux-${PV}.x86.run"
+
+LICENSE="QUAKE4"
+SLOT="0"
+KEYWORDS="-* ~amd64 ~x86"
+IUSE="cdinstall dedicated l10n_cs l10n_fr l10n_it l10n_pl l10n_ru"
+RESTRICT="strip"
+
+RDEPEND="sys-libs/glibc
+ amd64? ( sys-libs/glibc[multilib] )
+ sys-libs/zlib[abi_x86_32(-)]
+ dedicated? ( app-misc/screen )
+ !dedicated? (
+ || (
+ virtual/opengl[abi_x86_32(-)]
+ x11-drivers/nvidia-drivers
+ )
+ >=x11-libs/libX11-1.6.2[abi_x86_32(-)]
+ >=x11-libs/libXext-1.3.2[abi_x86_32(-)]
+ >=media-libs/libsdl-1.2.15-r4[X,opengl,sound,abi_x86_32(-)]
+ )
+ cdinstall? ( games-fps/quake4-data )"
+
+S=${WORKDIR}
+dir=${GAMES_PREFIX_OPT}/quake4
+Ddir=${D}/${dir}
+
+QA_TEXTRELS="${dir:1}/pb/pbag.so
+ ${dir:1}/pb/pbags.so
+ ${dir:1}/pb/pbcl.so
+ ${dir:1}/pb/pbcls.so
+ ${dir:1}/pb/pbsv.so
+ ${dir:1}/libSDL-1.2.id.so.0"
+QA_EXECSTACK="${dir:1}/quake4.x86
+ ${dir:1}/quake4smp.x86
+ ${dir:1}/q4ded.x86
+ ${dir:1}/libSDL-1.2.id.so.0"
+
+zpaklang() {
+ if ! use l10n_${1} ; then
+ einfo "Removing ${2} zpak files"
+ rm -f q4base/zpak_${2}*
+ fi
+}
+
+src_unpack() {
+ unpack_makeself ${A}
+
+ mv q4icon.bmp quake4.bmp || die
+
+ # Am including the Spanish files because Spanish is the default language
+ #zpaklang es spanish
+ zpaklang cs czech
+ zpaklang fr french
+ zpaklang it italian
+ zpaklang pl polish
+ zpaklang ru russian
+
+ # Rename the .off files, so they will be used
+ cd q4base
+ if [[ ! -z $(ls *.off 2> /dev/null) ]] ; then
+ local f
+ for f in *.off ; do
+ einfo "Renaming ${f}"
+ mv "${f}" "${f%.off}" || die "mv ${f}"
+ done
+ fi
+}
+
+src_install() {
+ insinto "${dir}"
+ doins CHANGES* License.txt sdl.patch.1.2.10 us/version.info
+ doins -r pb q4mp
+ dodoc README*
+
+ insinto "${dir}"/q4base
+ doins q4base/* us/q4base/* || die "doins q4base"
+ games_make_wrapper quake4-ded ./q4ded.x86 "${dir}" "${dir}"
+
+ exeinto "${dir}"
+ doexe openurl.sh bin/Linux/x86/q4ded.x86
+
+ if ! use dedicated ; then
+ doexe bin/Linux/x86/{quake4{,smp}.x86,*.id.so.?}
+ doicon quake4.bmp || die "doicon"
+ games_make_wrapper quake4 "./quake4.x86" "${dir}" "${dir}"
+ games_make_wrapper quake4-smp ./quake4smp.x86 "${dir}" "${dir}"
+ icon_path="quake4"
+ if [ -e "${FILESDIR}"/quake4.png ]
+ then
+ doicon "${FILESDIR}"/quake4.png || die "copying icon"
+ elif [ -e "${DISTDIR}"/quake4.png ]
+ then
+ doicon "${DISTDIR}"/quake4.png || die "copying icon"
+ else
+ icon_path=/usr/share/pixmaps/quake4.bmp
+ fi
+ make_desktop_entry quake4 "Quake IV" ${icon_path}
+ make_desktop_entry quake4-smp "Quake IV (SMP)" ${icon_path}
+ fi
+
+ prepgamesdirs
+}
+
+pkg_postinst() {
+ games_pkg_postinst
+
+ if ! use cdinstall ; then
+ elog "You need to copy pak001.pk4 through pak012.pk4, along with"
+ elog "zpak*.pk4 from either your installation media or your hard drive"
+ elog "to ${dir}/q4base before running the game."
+ echo
+ fi
+ if ! use dedicated ; then
+ elog "To play the game, run: quake4"
+ elog
+ # The default language is Spanish!
+ elog "To reset the language from Spanish to English, run:"
+ elog " sed -i 's:spanish:english:' ~/.quake4/q4base/Quake4Config.cfg"
+ elog
+ elog "Saved games from previous Quake 4 versions might not be compatible."
+ echo
+ fi
+ elog "To start the dedicated server, run: quake4-ded"
+}