summaryrefslogtreecommitdiff
path: root/games-fps/quake3-alternatefire
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /games-fps/quake3-alternatefire
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'games-fps/quake3-alternatefire')
-rw-r--r--games-fps/quake3-alternatefire/Manifest4
-rw-r--r--games-fps/quake3-alternatefire/files/server.cfg109
-rw-r--r--games-fps/quake3-alternatefire/metadata.xml8
-rw-r--r--games-fps/quake3-alternatefire/quake3-alternatefire-2.0-r1.ebuild17
4 files changed, 138 insertions, 0 deletions
diff --git a/games-fps/quake3-alternatefire/Manifest b/games-fps/quake3-alternatefire/Manifest
new file mode 100644
index 000000000000..1d2b7dba7b1c
--- /dev/null
+++ b/games-fps/quake3-alternatefire/Manifest
@@ -0,0 +1,4 @@
+AUX server.cfg 3645 BLAKE2B 0653366f94bb7f00194f7dcd3afdd7826dc35bea50d897f185fc9b052d6bceef3420c80a701e6a9af8c90373ea94d46068bae3fd5e7f3870dc240d2dd5c5cd77 SHA512 a7b4d64adad075ba7ee7af3461ef36216fd374d852267ba712882549d44c137f7638ac100c31081528e6b384865cba6fcdeeccdb22bb0133bcac869e60c30e6f
+DIST alternatefire-2.0.zip 2015159 BLAKE2B 7e291c88d479dacf3bf7e7141faf10cd401ab660f2363818af0458a142484dd27e744a7a8fc9c99246a0938ca7e5cddbfa58cd7410189788d8daf4180eebf498 SHA512 178c5470037e711c58cb09854d7e607166253a6f613c29f23fbbcd46cdff8786dfd53770dfc9d518d75d9a3e42b0745bfaa742a09bad0493dbd335d1bb3fcbf2
+EBUILD quake3-alternatefire-2.0-r1.ebuild 450 BLAKE2B c8f5458b09d55559c6b40c2122243798b43c8f68d36e3f40c44a6475e107176da2c2704552fdcfc822397b4f1849db42d2a6f5b8e21292c89ce95ff86da371fe SHA512 6a1639946e6e0df8183844780bddc641a87cb9d9d980382f3f7c4b785cfdc3b36ad9a1e916adbbe6e74ec6de406c5c248692a7975685bc758f9976440f6405bd
+MISC metadata.xml 249 BLAKE2B 7113a758d7abc93accec998a8843d8ef51ca8b72d72e659e224d5cec2a1a6a63e6c0605958091532ac6e51fa0d501ca4fd9f3f4a9e55baeb31519a02971b465f SHA512 895577c3a805c40581da03057b94e3f28f05f23012bf350c1e3575847d1a0fe40bb044a46f909012a200d991a400f6389358a60e9c2b5bef0da01fb26f846118
diff --git a/games-fps/quake3-alternatefire/files/server.cfg b/games-fps/quake3-alternatefire/files/server.cfg
new file mode 100644
index 000000000000..0ee5c8a202e3
--- /dev/null
+++ b/games-fps/quake3-alternatefire/files/server.cfg
@@ -0,0 +1,109 @@
+// Sample .cfg file for the Alternate Fire mod
+// ==================================================================
+
+// It's set up for CTF, since that's my favorite game type :)
+// (besides, the lightning web is just awesome in CTF).
+
+// ---- General setup ----
+
+seta sv_pure 1
+seta sv_hostname "Gentoo - Alternate Fire"
+seta sv_maxclients 10
+seta sv_floodprotect 0
+seta g_motd "Welcome to AlternateFire"
+seta g_allowVote 1
+
+// Kick 'em after 3 minutes if they go inactive
+seta g_inactivity 180
+
+// Yes, they do need the z-alternatefire-0xx.pk3
+// Make sure it's in the right place ("alternatefire", not "baseq3")
+// (If you're running this on Linux, put it in ~/.q3a/alternatefire
+// or it won't upload)
+seta sv_allowDownload 1
+// Also, make sure you remove the old .pk3 when you upgrade!
+
+// ---- Bots ----
+
+seta bot_enable 1
+// This is per-team in team games
+seta bot_minplayers 4
+
+// ---- Game parameters ----
+
+// 0 - Free For All, 1 - Tournament,
+// 3 - Team Deathmatch, 4 - Capture the Flag
+seta g_gametype 4
+seta capturelimit 8
+seta timelimit 20
+seta g_friendlyFire 0
+
+// ---- Extra-special new stuff ----
+
+// Uncomment this if you want no falling damage
+//g_fallingDamage 0
+
+// Uncomment this if you want self damage to only damage armor
+// Set it to 0 to disable self damage altogether (default: 2)
+//g_selfDamage 1
+
+// Uncomment this if you like to play CTF the "old" way
+// (the player only has to touch his flag to return it)
+//g_returnFlag 0
+
+// Uncomment this if you want a mad, mad, mad game of
+// multi-flag CTF (everyone can have their own flag!)
+//g_multiFlag 1
+
+// Uncomment this if you want an offhand grapple
+// Your players will need to bind +button6 to something,
+// or set up their grapples in SETUP->CONTROLS->SHOOT
+// WARNING: The grappling hook IS NOT client-side predicted,
+// which means it's awful for anybody with a ping over 100
+//g_offhandGrapple 1
+
+// ---- Chat/Name Filter ----
+
+// ** PLEASE READ THE README BEFORE ENABLING THESE OPTIONS **
+
+// Uncomment this to force every client's chat filter on
+// They can override this in the GAME OPTIONS menu - which
+// means that setting this really just makes the chat filter
+// opt-out
+//g_forceChatFilter 1
+
+// Uncomment this to force every client's name filter and
+// kick players with dirty names
+//g_forceNameFilter 1
+
+// ** Be careful with the next two - the chat filter may
+// act differently than you think. Read the README. **
+
+// Use this to add words for chat filtering (separate words
+// with spaces, use an underscore ("_") in place of a space
+// if you need to filter phrases)
+//g_filteredWords
+
+// Use this to filter additional names - same format as above
+//g_filteredNames "bin_laden terrorist"
+
+// ---- Map rotation ----
+
+// An id/threewave CTF map rotation
+// Even if you don't use this rotation, I suggest using "d1"
+// as the command for the first map, since players can vote
+// to reset the map rotation. That action will set nextmap
+// to "vstr d1".
+set d1 "map q3ctf1; set nextmap vstr d2"
+set d2 "map q3wctf2; set nextmap vstr d3"
+set d3 "map q3ctf4; set nextmap vstr d4"
+set d4 "map q3wctf1; set nextmap vstr d5"
+set d5 "map q3ctf2; set nextmap vstr d6"
+set d6 "map q3wctf3; set nextmap vstr d7"
+set d7 "map q3ctf3; set nextmap vstr d1"
+vstr d1
+
+// If you want to change the game type (and other things) per map, do stuff like this:
+//set d1 "set g_gametype 0; set fraglimit 20; map q3dm17; set nextmap vstr d2"
+//set d2 "set g_gametype 1; set fraglimit 15; set timelimit 10; map q3tourney3; set nextmap vstr d1"
+//vstr d1
diff --git a/games-fps/quake3-alternatefire/metadata.xml b/games-fps/quake3-alternatefire/metadata.xml
new file mode 100644
index 000000000000..78274e0fa550
--- /dev/null
+++ b/games-fps/quake3-alternatefire/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="project">
+ <email>games@gentoo.org</email>
+ <name>Gentoo Games Project</name>
+</maintainer>
+</pkgmetadata>
diff --git a/games-fps/quake3-alternatefire/quake3-alternatefire-2.0-r1.ebuild b/games-fps/quake3-alternatefire/quake3-alternatefire-2.0-r1.ebuild
new file mode 100644
index 000000000000..d0d7066df6a7
--- /dev/null
+++ b/games-fps/quake3-alternatefire/quake3-alternatefire-2.0-r1.ebuild
@@ -0,0 +1,17 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+MOD_DESC="adds unique new secondary attacks to weapons"
+MOD_NAME="Alternate Fire"
+MOD_DIR="alternatefire"
+
+inherit games games-mods
+
+HOMEPAGE="https://wiki.gentoo.org/wiki/No_homepage"
+SRC_URI="mirror://quakeunity/modifications/alternatefire/alternatefire-${PV}.zip"
+
+LICENSE="freedist"
+
+KEYWORDS="~amd64 ~x86"
+IUSE="dedicated opengl"