summaryrefslogtreecommitdiff
path: root/games-fps/freedoom/freedoom-0.10.1-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /games-fps/freedoom/freedoom-0.10.1-r1.ebuild
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'games-fps/freedoom/freedoom-0.10.1-r1.ebuild')
-rw-r--r--games-fps/freedoom/freedoom-0.10.1-r1.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/games-fps/freedoom/freedoom-0.10.1-r1.ebuild b/games-fps/freedoom/freedoom-0.10.1-r1.ebuild
new file mode 100644
index 000000000000..357def0066df
--- /dev/null
+++ b/games-fps/freedoom/freedoom-0.10.1-r1.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit readme.gentoo-r1
+
+DESCRIPTION="Freedoom - Open Source Doom resources"
+HOMEPAGE="http://www.nongnu.org/freedoom/"
+SRC_URI="https://github.com/freedoom/freedoom/releases/download/v${PV}/freedoom-${PV}.zip
+ https://github.com/freedoom/freedoom/releases/download/v${PV}/freedm-${PV}.zip"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE=""
+
+DEPEND="app-arch/unzip"
+RDEPEND=""
+
+S="${WORKDIR}"
+
+DISABLE_AUTOFORMATTING="yes"
+DOC_CONTENTS="
+A Doom engine is required to play the wad
+but games-fps/doomsday doesn't count since it doesn't
+have the necessary features.
+To play freedoom with Doom engines which do not support
+subdirectories, create symlinks by running the following:
+(Be careful of overwriting existing wads.)
+
+# cd /usr/share/doom-data
+# ln -sn freedoom/*.wad .
+"
+
+src_install() {
+ insinto /usr/share/doom-data/${PN}
+ doins */*.wad
+ dodoc "${P}"/CREDITS
+ HTMLDOCS="${P}/README.html" einstalldocs
+ readme.gentoo_create_doc
+}
+
+pkg_postinst() {
+ readme.gentoo_print_elog
+}