summaryrefslogtreecommitdiff
path: root/games-fps/etqw-data
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /games-fps/etqw-data
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'games-fps/etqw-data')
-rw-r--r--games-fps/etqw-data/Manifest2
-rw-r--r--games-fps/etqw-data/etqw-data-1.0.ebuild65
-rw-r--r--games-fps/etqw-data/metadata.xml8
3 files changed, 75 insertions, 0 deletions
diff --git a/games-fps/etqw-data/Manifest b/games-fps/etqw-data/Manifest
new file mode 100644
index 000000000000..7c6214fe2f0c
--- /dev/null
+++ b/games-fps/etqw-data/Manifest
@@ -0,0 +1,2 @@
+EBUILD etqw-data-1.0.ebuild 1301 BLAKE2B d8d4e6fb5ccb3df9e3f336c16a87cceba197236e8bc91b3fdfffc4c184a553cb2b95be9801af42b6d0248816279efaf3aba51f2efce0d1d392c9ba6a690848ff SHA512 f17c60fc3705f86d052082d1806e7a3f1e9450469bbbe4c4b4d72e7f4fb357361cfa46cd596be6cca54bcc4e618b4aa09e35c9509f981b65d11362ca00687147
+MISC metadata.xml 252 BLAKE2B 1b951d2e730631865ae5f379b19ed9de2c8adf2f2786da3f75d0871d967374198ddd9106433f388bdc7050c37063fb28cda4320ae7bdc9a03854838693d9f952 SHA512 90798aff93ec7e3881b882e7b10bb1680e8cb7d82b0ef4280e562ab0c9e8a2daba8afe57333dc64697322267a4b651c00ee9b4fdeb56278ff70c073da7b91638
diff --git a/games-fps/etqw-data/etqw-data-1.0.ebuild b/games-fps/etqw-data/etqw-data-1.0.ebuild
new file mode 100644
index 000000000000..048efa9cd245
--- /dev/null
+++ b/games-fps/etqw-data/etqw-data-1.0.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=0
+
+inherit eutils cdrom games
+
+DESCRIPTION="Enemy Territory: Quake Wars data files"
+HOMEPAGE="http://zerowing.idsoftware.com/linux/etqw/"
+SRC_URI=""
+
+LICENSE="ETQW"
+SLOT="0"
+KEYWORDS="-* ~amd64 ~x86"
+IUSE="videos"
+
+S=${WORKDIR}
+
+src_install() {
+ local dir=${GAMES_PREFIX_OPT}/etqw
+
+ cdrom_get_cds Setup/Data/base/DEU:Setup/Data/base/POL:Setup/Data/base
+
+ cd "${CDROM_ROOT}"/Setup/Data/base
+ insinto "${dir}"/base
+ doins pak00{0..4}.pk4 || die "doins pak failed"
+ doins -r megatextures || die "doins megatextures failed"
+
+ case ${CDROM_SET} in
+ 0)
+ doins \
+ zpak_english000.pk4 \
+ DEU/zpak_german000.pk4 \
+ ESP/zpak_spanish000.pk4 \
+ FRA/zpak_french000.pk4 \
+ || die "doins zpak failed"
+ ;;
+ 1)
+ doins \
+ POL/zpak_polish000.pk4 \
+ RUS/zpak_russian000.pk4 \
+ || die "doins zpak failed"
+ ;;
+ 2)
+ doins zpak_english000.pk4 || die "doins zpak failed"
+ ;;
+ esac
+
+ if use videos ; then
+ case ${CDROM_SET} in
+ 0|2)
+ doins -r video || die "doins video failed"
+ ;;
+ esac
+ fi
+
+ prepgamesdirs
+}
+
+pkg_postinst() {
+ games_pkg_postinst
+
+ elog "This is just the data portion of the game. You will need to install"
+ elog "games-fps/etqw-bin to play it."
+}
diff --git a/games-fps/etqw-data/metadata.xml b/games-fps/etqw-data/metadata.xml
new file mode 100644
index 000000000000..3c186688e265
--- /dev/null
+++ b/games-fps/etqw-data/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="project">
+ <email>games@gentoo.org</email>
+ <name>Gentoo Games Project</name>
+ </maintainer>
+</pkgmetadata>