summaryrefslogtreecommitdiff
path: root/games-fps/etqw-data/etqw-data-1.0-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-06-30 17:36:28 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-06-30 17:36:28 +0100
commit7014a5a3ea0feffab9701fdd6b64cc7667a985af (patch)
treef2cbbaa8bb9209cd15208721103228336149b799 /games-fps/etqw-data/etqw-data-1.0-r1.ebuild
parent7a86906b67693cc65671d3e1476835d3a7e13092 (diff)
gentoo resync : 30.06.2019
Diffstat (limited to 'games-fps/etqw-data/etqw-data-1.0-r1.ebuild')
-rw-r--r--games-fps/etqw-data/etqw-data-1.0-r1.ebuild53
1 files changed, 53 insertions, 0 deletions
diff --git a/games-fps/etqw-data/etqw-data-1.0-r1.ebuild b/games-fps/etqw-data/etqw-data-1.0-r1.ebuild
new file mode 100644
index 000000000000..6f5806dd98a1
--- /dev/null
+++ b/games-fps/etqw-data/etqw-data-1.0-r1.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit cdrom
+
+DESCRIPTION="Enemy Territory: Quake Wars data files"
+HOMEPAGE="http://zerowing.idsoftware.com/linux/etqw/ETQWFrontPage/"
+SRC_URI=""
+
+LICENSE="ETQW"
+SLOT="0"
+KEYWORDS="-* ~amd64 ~x86"
+IUSE="videos"
+
+S="${WORKDIR}"
+
+src_install() {
+ local dir=/opt/etqw
+
+ cdrom_get_cds Setup/Data/base/DEU:Setup/Data/base/POL:Setup/Data/base
+
+ cd "${CDROM_ROOT}"/Setup/Data/base
+ insinto "${dir}"/base
+ doins pak00{0..4}.pk4
+ doins -r megatextures
+
+ case ${CDROM_SET} in
+ 0)
+ doins \
+ zpak_english000.pk4 \
+ DEU/zpak_german000.pk4 \
+ ESP/zpak_spanish000.pk4 \
+ FRA/zpak_french000.pk4
+ ;;
+ 1)
+ doins \
+ POL/zpak_polish000.pk4 \
+ RUS/zpak_russian000.pk4
+ ;;
+ 2)
+ doins zpak_english000.pk4
+ ;;
+ esac
+
+ if use videos ; then
+ case ${CDROM_SET} in
+ 0|2)
+ doins -r video
+ ;;
+ esac
+ fi
+}