summaryrefslogtreecommitdiff
path: root/games-fps/etqw-bin
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /games-fps/etqw-bin
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'games-fps/etqw-bin')
-rw-r--r--games-fps/etqw-bin/Manifest3
-rw-r--r--games-fps/etqw-bin/etqw-bin-1.5-r1.ebuild71
-rw-r--r--games-fps/etqw-bin/metadata.xml8
3 files changed, 82 insertions, 0 deletions
diff --git a/games-fps/etqw-bin/Manifest b/games-fps/etqw-bin/Manifest
new file mode 100644
index 000000000000..0dacdbad9fb4
--- /dev/null
+++ b/games-fps/etqw-bin/Manifest
@@ -0,0 +1,3 @@
+DIST ETQW-client-1.5-full.x86.run 556383725 BLAKE2B 8fcaa8518c7c452a4fe593a00beea0f5a6d5849c72b03d4a443fffde8540ea53b7bf0376d90b2f2ed4e3a736628f8871e009a49b938344516b2db0495cf1e826 SHA512 32bb3d7ef47790ac6b790a5a5d61592c3504d034372254102985e58dee25b5d200e507330226bf8458c628154c246b2abcb08bf550fa044189c4c8de813af0c2
+EBUILD etqw-bin-1.5-r1.ebuild 2012 BLAKE2B 688f996448189c1525475aea0534e09b69d09f7da0b3626c38fbf251afe61ceefb16e925abc81eba5fab7d4e498484d83f81a0314a6267ab0757b1343f9630ed SHA512 6314fd268f98d28fce833aa8c3cba5be60ad8d50372a810cfbf3f29bf04903569ca82016b2ff8e7bd063a123c90b09442287afce1fac20c036f94f73562f54a6
+MISC metadata.xml 252 BLAKE2B 1b951d2e730631865ae5f379b19ed9de2c8adf2f2786da3f75d0871d967374198ddd9106433f388bdc7050c37063fb28cda4320ae7bdc9a03854838693d9f952 SHA512 90798aff93ec7e3881b882e7b10bb1680e8cb7d82b0ef4280e562ab0c9e8a2daba8afe57333dc64697322267a4b651c00ee9b4fdeb56278ff70c073da7b91638
diff --git a/games-fps/etqw-bin/etqw-bin-1.5-r1.ebuild b/games-fps/etqw-bin/etqw-bin-1.5-r1.ebuild
new file mode 100644
index 000000000000..8270e50c21ee
--- /dev/null
+++ b/games-fps/etqw-bin/etqw-bin-1.5-r1.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+inherit eutils games
+
+DESCRIPTION="Enemy Territory: Quake Wars"
+HOMEPAGE="http://zerowing.idsoftware.com/linux/etqw/"
+SRC_URI="ftp://ftp.i3d.net/Games/Enemy%20Territory%20Quake%20Wars/Patches/ETQW-client-${PV}-full.x86.run"
+
+LICENSE="ETQW"
+SLOT="0"
+KEYWORDS="-* ~amd64 ~x86"
+IUSE="cdinstall"
+RESTRICT="strip"
+
+DEPEND="app-arch/unzip"
+RDEPEND="sys-libs/glibc
+ amd64? ( sys-libs/glibc[multilib] )
+ >=sys-libs/zlib-1.2.8-r1[abi_x86_32(-)]
+ >=virtual/jpeg-62:62[abi_x86_32(-)]
+ >=media-libs/libsdl-1.2.15-r4[video,sound,opengl,abi_x86_32(-)]
+ >=media-libs/alsa-lib-1.0.27.2[abi_x86_32(-)]
+ >=x11-libs/libX11-1.6.2[abi_x86_32(-)]
+ >=x11-libs/libXext-1.3.2[abi_x86_32(-)]
+ cdinstall? ( games-fps/etqw-data )"
+
+S=${WORKDIR}/data
+dir=${GAMES_PREFIX_OPT}/etqw
+
+QA_PREBUILT="${dir:1}/*.x86
+ ${dir:1}/*.so*"
+
+src_unpack() {
+ tail -c +194885 "${DISTDIR}"/${A} > ${A}.zip
+ unpack ./${A}.zip
+ rm -f ${A}.zip
+}
+
+src_install() {
+ insinto "${dir}"
+ doins -r base pb *.png
+ dodoc *.txt
+
+ exeinto "${dir}"
+ doexe etqw{,ded,-rthread}.x86 openurl.sh libCgx86.so libSDL*.id.so*
+
+ newicon etqw_icon.png etqw.png
+ games_make_wrapper etqw ./etqw.x86 "${dir}" "${dir}"
+ make_desktop_entry etqw "Enemy Territory: Quake Wars" etqw
+
+ games_make_wrapper etqw-dedicated ./etqwded.x86 "${dir}" "${dir}"
+ make_desktop_entry etqw-dedicated "Enemy Territory: Quake Wars (dedicated server)" etqw
+
+ games_make_wrapper etqw-rthread ./etqw-rthread.x86 "${dir}" "${dir}"
+ make_desktop_entry etqw-rthread "Enemy Territory: Quake Wars (SMP)" etqw
+
+ prepgamesdirs
+}
+
+pkg_postinst() {
+ games_pkg_postinst
+
+ if ! use cdinstall ; then
+ elog "You need to copy pak00*.pk4, zpak_*.pk4 and the megatextures"
+ elog "directory to ${dir}/base before running the game."
+ fi
+ elog "To change the game language from English, add"
+ elog "seta sys_lang \"your_language\" to your autoexec.cfg file."
+ elog "Menu fonts may not show up until you do so."
+}
diff --git a/games-fps/etqw-bin/metadata.xml b/games-fps/etqw-bin/metadata.xml
new file mode 100644
index 000000000000..3c186688e265
--- /dev/null
+++ b/games-fps/etqw-bin/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="project">
+ <email>games@gentoo.org</email>
+ <name>Gentoo Games Project</name>
+ </maintainer>
+</pkgmetadata>