summaryrefslogtreecommitdiff
path: root/games-fps/doomsday
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /games-fps/doomsday
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'games-fps/doomsday')
-rw-r--r--games-fps/doomsday/Manifest3
-rw-r--r--games-fps/doomsday/doomsday-2.0.3.ebuild77
-rw-r--r--games-fps/doomsday/metadata.xml21
3 files changed, 101 insertions, 0 deletions
diff --git a/games-fps/doomsday/Manifest b/games-fps/doomsday/Manifest
new file mode 100644
index 000000000000..5678892783a9
--- /dev/null
+++ b/games-fps/doomsday/Manifest
@@ -0,0 +1,3 @@
+DIST doomsday-2.0.3.tar.gz 18060670 BLAKE2B e01545f5d719310a78f01de77249a72f9c3c61a1d295ee0827475439b63653f613660bdc033c1651180cc390469c89120d262c15c6e22cece52600e2889e1437 SHA512 4f8e737df9e004cf3ac3cf16b84ffce0c85e2180af552bac41a224595c7f6932397c39f7d3e9fa522e1ae62828cb87f564a5fa411e742eb07bbee96f14c3ee7c
+EBUILD doomsday-2.0.3.ebuild 1752 BLAKE2B b65b8da028703868366192847f12b26e22a3f5b4a4a88a7d17f2b0d9378ecbdb21a3e5f1561c90e8465b4ce7403190d89afdc1da3a5e500b2f681be8dbf9a3b1 SHA512 d954a9b61ee050ec9f30e376aee0e79be62ab6ff254db77dbd1f855c6d79e5ca104e1d47aef3418911f2ba963296d8da5f6ee486e43df1bc50dbbbaf48753b58
+MISC metadata.xml 956 BLAKE2B 762c3c0aa85b8d59cdc333f381e4028c7708d113017c84d7dad4ae2659f7c9c875ec410c04b29baccfb9df267f6a081a2cd5321068a328cfe95d2861d0108c7d SHA512 2efbdb770fec0865b8f6a2b6a1ceab526842f2ff70eb9317048d3595b19ed43ba7a67857d7e698081e28463c9a925630030674992d267e6ec5a37efe67c39cfa
diff --git a/games-fps/doomsday/doomsday-2.0.3.ebuild b/games-fps/doomsday/doomsday-2.0.3.ebuild
new file mode 100644
index 000000000000..c50b22ad60ee
--- /dev/null
+++ b/games-fps/doomsday/doomsday-2.0.3.ebuild
@@ -0,0 +1,77 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 )
+
+inherit python-r1 readme.gentoo-r1 cmake-utils
+
+DESCRIPTION="A modern gaming engine for Doom, Heretic, and Hexen"
+HOMEPAGE="http://www.dengine.net"
+SRC_URI="https://downloads.sourceforge.net/project/deng/Doomsday%20Engine/${PV}/${P}.tar.gz"
+
+LICENSE="GPL-3+ LGPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+IUSE="fluidsynth openal +doom demo freedoom heretic hexen tools fmod"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}
+ demo? ( doom ) freedoom? ( doom )
+"
+
+RDEPEND="
+ dev-qt/qtnetwork:5
+ dev-qt/qtopengl:5
+ dev-qt/qtwidgets:5
+ dev-qt/qtx11extras:5
+ dev-qt/qtgui:5[-gles2]
+ dev-qt/qtcore:5
+ net-misc/curl
+ sys-libs/zlib
+ media-libs/assimp
+ fmod? ( media-libs/fmod )
+ fluidsynth? ( media-sound/fluidsynth )
+ openal? ( media-libs/openal )
+ tools? ( sys-libs/ncurses:0 )
+"
+DEPEND="${RDEPEND}
+ ${PYTHON_DEPS}
+ virtual/pkgconfig
+"
+PDEPEND="
+ demo? ( games-fps/doom-data )
+ freedoom? ( games-fps/freedoom )
+"
+
+S="${WORKDIR}/${P}/${PN}"
+
+DISABLE_AUTOFORMATTING="yes"
+DOC_CONTENTS="
+You need to copy Doom, Doom 2, Chex Quest, Heretic, Hexen, HexenDD,
+and Doom64 wads to a folder of your choice. Then configure in game
+engine where that folder is. This is different than old versions,
+which had centralized launchers for each game, and required the
+files to be in a specific place
+"
+
+internal_src_configure() {
+ export QT_SELECT=qt5
+ local mycmakeargs=(
+ -DPYTHON_EXECUTABLE="${PYTHON}"
+ -DDENG_ASSIMP_EMBEDDED=off
+ )
+ cmake-utils_src_configure
+}
+
+src_configure() {
+ python_foreach_impl internal_src_configure
+}
+
+src_install() {
+ cmake-utils_src_install
+ readme.gentoo_create_doc
+}
+
+pkg_postinst() {
+ readme.gentoo_print_elog
+}
diff --git a/games-fps/doomsday/metadata.xml b/games-fps/doomsday/metadata.xml
new file mode 100644
index 000000000000..851017e48a82
--- /dev/null
+++ b/games-fps/doomsday/metadata.xml
@@ -0,0 +1,21 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>games@gentoo.org</email>
+ <name>Gentoo Games Project</name>
+ </maintainer>
+ <use>
+ <flag name="demo">Install launcher dor doom1.wad from <pkg>games-fps/doom-data</pkg></flag>
+ <flag name="doom">Install launcher for jdoom game</flag>
+ <flag name="fluidsynth">Build the FluidSynth sound driver</flag>
+ <flag name="fmod">Enable support for fmod music and sound effects lib</flag>
+ <flag name="freedoom">Install launcher for doom1.wad from <pkg>games-fps/freedoom</pkg></flag>
+ <flag name="heretic">Install launcher for jheretic game</flag>
+ <flag name="hexen">Install launcher for jhexen game</flag>
+ <flag name="tools">Build additional tools such as doomsday-shell, md2tool and texc</flag>
+ </use>
+ <upstream>
+ <remote-id type="sourceforge">deng</remote-id>
+ </upstream>
+</pkgmetadata>