summaryrefslogtreecommitdiff
path: root/games-fps/doom3
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /games-fps/doom3
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'games-fps/doom3')
-rw-r--r--games-fps/doom3/Manifest4
-rw-r--r--games-fps/doom3/doom3-1.3.1304-r1.ebuild99
-rw-r--r--games-fps/doom3/metadata.xml20
3 files changed, 123 insertions, 0 deletions
diff --git a/games-fps/doom3/Manifest b/games-fps/doom3/Manifest
new file mode 100644
index 000000000000..d1c91a6f2603
--- /dev/null
+++ b/games-fps/doom3/Manifest
@@ -0,0 +1,4 @@
+DIST doom3-linux-1.3.1.1304.x86.run 21145838 BLAKE2B ac69b20193b188556143ff57464f81c088dc008abfda98ff49d8a2d802fa06ff383e6bcde4a8a056066e8cd663a07fa01f4f171e30ec5fe9185fd975a13efb60 SHA512 f2a42478d84a6242a7982d1acd726b746596b7a13147acbd920d618223d6f52ab4c49aa7d7f07067674da2881372a181396a0bdd476e3956fb702c76eebb0d02
+DIST doom3.png 6502 BLAKE2B e467e622bb8955024aaf13dc97e0facc7f83aa344007172890d1982f39d35a643c859663fbdc60424332fe1b4b57711b7ce75fcdda8c77b4b2e8e6b71e9431e2 SHA512 9a2b3831babbf3fa0d354e1a4a779c972676edbcc0b287de9b9f3eb830e0a00d557ba9645fbf0e58e07d5705efb0ef2b7ab96cd92493e2a0afc30c8842c0043b
+EBUILD doom3-1.3.1304-r1.ebuild 2468 BLAKE2B e5d8c74d8ca00b94b73d89c5a49d36269e6bf275a8d13b44ff692dea545549e922e860f58c34259b6bceef1d789dcce0fffd20d7c32c50dc5c813413267ad47a SHA512 ad05556e1bdc829156ad8d21807dbc3df276e75f082a8f477f24bda8918dcf0c0705493fbbae3e3a8a687a1f73d5b515504b7ac9b71360c3c3af990a9149a9ca
+MISC metadata.xml 891 BLAKE2B 0b944b27943005ae45f7adcf1c5106b104f8c6d96adfe656cfed97c640793bfa5bd93799d8387393b7277bd9eaffbd5d4236755e705475836e2c13646ddffc53 SHA512 6652538b02d91c4fcb4ae39e6abdbfa66339481a4dc33c177cb9b5fca1787025b0819fcccd89de53fbc851b12db3d1b77f4d0c2baa03766f74e79458d463bdcd
diff --git a/games-fps/doom3/doom3-1.3.1304-r1.ebuild b/games-fps/doom3/doom3-1.3.1304-r1.ebuild
new file mode 100644
index 000000000000..04242157ec3f
--- /dev/null
+++ b/games-fps/doom3/doom3-1.3.1304-r1.ebuild
@@ -0,0 +1,99 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+inherit eutils unpacker games
+
+MY_PV="1.3.1.1304"
+
+DESCRIPTION="3rd installment of the classic iD 3D first-person shooter"
+HOMEPAGE="http://www.doom3.com/"
+SRC_URI="mirror://idsoftware/doom3/linux/doom3-linux-${MY_PV}.x86.run
+ http://zerowing.idsoftware.com/linux/${PN}.png"
+
+LICENSE="DOOM3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="cdinstall dedicated roe"
+RESTRICT="strip"
+
+DEPEND="app-arch/bzip2
+ app-arch/tar"
+RDEPEND="sys-libs/glibc
+ amd64? ( sys-libs/glibc[multilib] )
+ !dedicated? (
+ >=virtual/opengl-7.0-r1[abi_x86_32(-)]
+ >=x11-libs/libX11-1.6.2[abi_x86_32(-)]
+ >=x11-libs/libXext-1.3.2[abi_x86_32(-)]
+ >=media-libs/alsa-lib-1.0.27.2[abi_x86_32(-)]
+ )
+ cdinstall? (
+ >=games-fps/doom3-data-1.1.1282-r1
+ roe? ( games-fps/doom3-roe ) )"
+
+S=${WORKDIR}
+dir=${GAMES_PREFIX_OPT}/${PN}
+
+QA_TEXTRELS="${dir:1}/pb/pbcl.so
+ ${dir:1}/pb/pbcls.so
+ ${dir:1}/pb/pbag.so
+ ${dir:1}/pb/pbsv.so
+ ${dir:1}/pb/pbags.so"
+
+QA_EXECSTACK="${dir:1}/doom.x86
+ ${dir:1}/doomded.x86"
+
+pkg_pretend() {
+ if use dedicated; then
+ ewarn "${CATEGORY}/${PN}[dedicated] will only install the dedicated game server"
+ fi
+}
+
+src_unpack() {
+ unpack_makeself ${PN}-linux-${MY_PV}.x86.run
+}
+
+src_install() {
+ insinto "${dir}"
+ doins License.txt CHANGES README version.info ${PN}.png
+ doins -r base d3xp pb
+
+ exeinto "${dir}"
+ doexe openurl.sh bin/Linux/x86/doomded.x86
+ if ! use dedicated; then
+ doexe bin/Linux/x86/doom.x86
+
+ games_make_wrapper ${PN} ./doom.x86 "${dir}" "${dir}"
+ doicon "${DISTDIR}"/${PN}.png || die "doicon"
+ make_desktop_entry ${PN} "Doom III"
+ fi
+ games_make_wrapper ${PN}-ded ./doomded.x86 "${dir}" "${dir}"
+
+ prepgamesdirs
+}
+
+pkg_postinst() {
+ games_pkg_postinst
+
+ if ! use cdinstall; then
+ elog "You need to copy pak000.pk4, pak001.pk4, pak002.pk4, pak003.pk4, and"
+ elog "pak004.pk4 from either your installation media or your hard drive to"
+ elog "${dir}/base before running the game,"
+ elog "or 'emerge games-fps/doom3-data' to install from CD."
+ if use roe ; then
+ echo
+ elog "To use the Resurrection of Evil expansion pack, you also need to copy"
+ elog "pak000.pk4 to ${dir}/d3xp from the RoE CD before running the game,"
+ elog "or 'emerge doom3-roe' to install from CD."
+ fi
+ fi
+
+ if ! use dedicated; then
+ echo
+ elog "To play the game, run:"
+ elog " doom3"
+ fi
+ echo
+ elog "To start the dedicated server, run:"
+ elog " doom3-ded"
+}
diff --git a/games-fps/doom3/metadata.xml b/games-fps/doom3/metadata.xml
new file mode 100644
index 000000000000..23889c3beb20
--- /dev/null
+++ b/games-fps/doom3/metadata.xml
@@ -0,0 +1,20 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>games@gentoo.org</email>
+ <name>Gentoo Games Project</name>
+ </maintainer>
+ <longdescription>
+Science has unlocked the gates to the unknown, and now only one man stands
+between Hell and Earth. A sci-fi horror masterpiece, DOOM 3 is like nothing you
+have experienced. Dramatic storyline, pulse-pounding action, incredible
+graphics, and revolutionary technology combine to draw you into the most
+frightening and gripping first person gaming experience ever created. For more
+information, checkout http://www.doom3.com
+</longdescription>
+ <use>
+ <flag name="dedicated">install only as a dedicated game server</flag>
+ <flag name="roe">Adds support for the Resurrection of Evil expansion</flag>
+ </use>
+</pkgmetadata>