summaryrefslogtreecommitdiff
path: root/games-fps/doom3-cdoom/doom3-cdoom-1.3.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /games-fps/doom3-cdoom/doom3-cdoom-1.3.1.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'games-fps/doom3-cdoom/doom3-cdoom-1.3.1.ebuild')
-rw-r--r--games-fps/doom3-cdoom/doom3-cdoom-1.3.1.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/games-fps/doom3-cdoom/doom3-cdoom-1.3.1.ebuild b/games-fps/doom3-cdoom/doom3-cdoom-1.3.1.ebuild
new file mode 100644
index 000000000000..fa3ecba51d47
--- /dev/null
+++ b/games-fps/doom3-cdoom/doom3-cdoom-1.3.1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+MOD_DESC="Doom 1 conversion for Doom 3"
+MOD_NAME="Classic Doom"
+MOD_DIR="cdoom"
+MOD_ICON="cdoom.ico"
+
+inherit games games-mods
+
+HOMEPAGE="http://www.moddb.com/mods/classic-doom-3"
+SRC_URI="classic_doom_3_${PV//.}.zip"
+
+LICENSE="GameFront"
+KEYWORDS="amd64 x86"
+IUSE="dedicated opengl"
+RESTRICT="fetch bindist"
+
+pkg_nofetch() {
+ elog "Please download ${SRC_URI} from:"
+ elog "http://www.filefront.com/8748743"
+ elog "and move it to ${DISTDIR}"
+}
+
+src_prepare() {
+ cd ${MOD_DIR} || die
+ rm -f *.{bat,url} cdoom_{dll,mac}.pk4
+}