summaryrefslogtreecommitdiff
path: root/games-fps/alephone/alephone-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-09-21 05:25:18 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-09-21 05:25:18 +0100
commit53612ae086ce9e171633a17392eb88c008650b8e (patch)
treea2e37763510dc22fd2812a219109ac748e56ee04 /games-fps/alephone/alephone-9999.ebuild
parent3f9a144d38a57497a44a583d11a6e3dfbe8319d5 (diff)
gentoo auto-resync : 21:09:2022 - 05:25:18
Diffstat (limited to 'games-fps/alephone/alephone-9999.ebuild')
-rw-r--r--games-fps/alephone/alephone-9999.ebuild90
1 files changed, 0 insertions, 90 deletions
diff --git a/games-fps/alephone/alephone-9999.ebuild b/games-fps/alephone/alephone-9999.ebuild
deleted file mode 100644
index 9bddbbc0d931..000000000000
--- a/games-fps/alephone/alephone-9999.ebuild
+++ /dev/null
@@ -1,90 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit autotools optfeature prefix xdg
-
-DESCRIPTION="An enhanced version of the game engine from the classic Mac game, Marathon"
-HOMEPAGE="http://source.bungie.org/"
-if [[ ${PV} = 9999* ]]; then
- inherit git-r3
- EGIT_REPO_URI="https://github.com/Aleph-One-Marathon/alephone/"
- EGIT_SUBMODULES=() # Upstream includes game data as submodules, we only want the engine
-else
- SRC_URI="https://github.com/Aleph-One-Marathon/alephone/archive/refs/tags/release-${PV}.tar.gz"
- S="${WORKDIR}/${PN}-release-${PV}"
- KEYWORDS="~amd64"
-fi
-
-LICENSE="GPL-3+ BitstreamVera OFL-1.1"
-SLOT="0"
-
-IUSE="alsa curl speex upnp"
-
-# ffmpeg covers most audio/video use cases and the package doesn't configure with alternatives enabled (media-libs/smpeg)
-# When resolved upstream, !ffmpeg ( media-libs/libmad media-libs/libsndfile media-libs/libvorbis media-libs/smpeg )
-# with an appropriate REQUIRED_USE may be added.
-# See https://github.com/Aleph-One-Marathon/alephone/issues/85
-RDEPEND="
- dev-libs/boost:=
- dev-libs/zziplib:=
- media-libs/libpng
- media-libs/libsdl2
- media-libs/sdl2-image[png]
- media-libs/sdl2-net
- media-libs/sdl2-ttf
- media-video/ffmpeg:=[mp3,vorbis]
- sys-libs/zlib
- virtual/opengl
- virtual/glu
- alsa? ( media-libs/alsa-lib )
- curl? ( net-misc/curl )
- speex? ( media-libs/speex )
- upnp? ( net-libs/miniupnpc )
-"
-
-DEPEND="
- ${RDEPEND}
-"
-
-BDEPEND="
- virtual/pkgconfig
-"
-
-src_prepare() {
- default
- eautoreconf
-}
-
-src_configure() {
- econf \
- --enable-lua \
- --enable-opengl \
- --with-ffmpeg \
- --without-mad \
- --without-smpeg \
- --without-sndfile \
- --without-vorbis \
- $(use_with alsa) \
- $(use_with curl) \
- $(use_with speex) \
- $(use_with upnp miniupnpc)
-}
-
-src_install() {
- default
- prefixify_ro "${FILESDIR}"/${PN}.sh
- dobin "${T}"/${PN}.sh
- doman docs/${PN}.6
- docinto html/
- dodoc docs/*.html
-}
-
-pkg_postinst() {
- xdg_pkg_postinst
- optfeature_header "Install game data:"
- optfeature "Marathon data files" games-fps/alephone-marathon
- optfeature "Marathon 2 Durandal data files" games-fps/alephone-durandal
- optfeature "Marathon: Infinity data files" games-fps/alephone-infinity
-}