summaryrefslogtreecommitdiff
path: root/games-fps/alephone-infinity
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-08-30 04:47:47 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-08-30 04:47:47 +0100
commit048bd060badd229e3bb596029874760a86d27060 (patch)
tree255c77a2abedb5474cd77d0b3cac24551de7771d /games-fps/alephone-infinity
parent8993ea73a9714d22178ba6ada8c04be83cd71ec7 (diff)
gentoo auto-resync : 30:08:2022 - 04:47:47
Diffstat (limited to 'games-fps/alephone-infinity')
-rw-r--r--games-fps/alephone-infinity/Manifest3
-rw-r--r--games-fps/alephone-infinity/alephone-infinity-20220115.ebuild37
-rw-r--r--games-fps/alephone-infinity/metadata.xml16
3 files changed, 56 insertions, 0 deletions
diff --git a/games-fps/alephone-infinity/Manifest b/games-fps/alephone-infinity/Manifest
new file mode 100644
index 000000000000..4f75eeaa9361
--- /dev/null
+++ b/games-fps/alephone-infinity/Manifest
@@ -0,0 +1,3 @@
+DIST MarathonInfinity-20220115-Data.zip 32203483 BLAKE2B c00e1ff6b4fc053e9df7f15711a73fd46f8e978714a7755137d1d9228a11715f5f3f161af17c1bd9d8bb9b6aaa4ae8292f5d007223c0c14b9a37a5f3e466675c SHA512 b37865f9f8e7ec14995e3ef5df8c3b3a8badc12fc1dc2388beaad90863e40f4fc589a08482e11a9ab21b7b1659c2248a340083ae0d0166689a4377a07d3c03ae
+EBUILD alephone-infinity-20220115.ebuild 900 BLAKE2B 610cecae473bb5216da717ff7f052f4ffdee1507ce9601836bc2ac4489839725eddb443ecf325bcea284913cfcebcd05dc01743b6baf8c6ece0a652f71cc5da9 SHA512 ff056ce38f86babfcd10b7d9261f6b3f834e902ed352e93d2002e1919bc0b07756c61469a7d79ce96a428d7e89e8868b3e585da22fceef2f5356d66793f8e0fc
+MISC metadata.xml 510 BLAKE2B 585a78c69b8ffff8640baa9eb39fe66a3115cc004da917eeb37573b1ae816e399a63ed5f043d547bcd7e59499c670e5063da56356e00c78cc22df039f11d8a09 SHA512 95337185f46c35a2f8022a1acc00bbebc8174472bcda28dae1a58acd2c314081a0451ef9a6a348390ac908eb249ede97721cf43b21f8ff1984e74f1ea63a6f5e
diff --git a/games-fps/alephone-infinity/alephone-infinity-20220115.ebuild b/games-fps/alephone-infinity/alephone-infinity-20220115.ebuild
new file mode 100644
index 000000000000..2b0f0b0b8319
--- /dev/null
+++ b/games-fps/alephone-infinity/alephone-infinity-20220115.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit desktop
+
+DESCRIPTION="Aleph One - Marathon Infinity"
+HOMEPAGE="http://marathon.sourceforge.net/"
+SRC_URI="https://github.com/Aleph-One-Marathon/alephone/releases/download/release-${PV}/MarathonInfinity-${PV}-Data.zip"
+S="${WORKDIR}/Marathon Infinity"
+
+LICENSE="bungie-marathon"
+SLOT="0"
+KEYWORDS="~amd64"
+RESTRICT="mirror"
+
+RDEPEND="games-fps/alephone"
+BDEPEND="app-arch/unzip"
+
+MY_NAME="infinity"
+MY_DIR="/usr/share/alephone-${MY_NAME}"
+
+src_install() {
+ insinto "${MY_DIR}"
+ doins -r *
+
+ make_desktop_entry "alephone.sh ${MY_NAME}" "${DESCRIPTION}"
+
+ # Make sure the extra dirs exist in case the user wants to add some data
+ keepdir "${MY_DIR}"/{Scripts,"Physics Models",Textures,Themes}
+}
+
+pkg_postinst() {
+ elog "To play this scenario, run:"
+ elog "alephone.sh ${MY_NAME}"
+}
diff --git a/games-fps/alephone-infinity/metadata.xml b/games-fps/alephone-infinity/metadata.xml
new file mode 100644
index 000000000000..2a5f1108e681
--- /dev/null
+++ b/games-fps/alephone-infinity/metadata.xml
@@ -0,0 +1,16 @@
+<?xml version='1.0' encoding='UTF-8'?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>games@gentoo.org</email>
+ <name>Gentoo Games Project</name>
+ </maintainer>
+ <maintainer type="person">
+ <email>Matt.Jolly@footclan.ninja</email>
+ <name>Matt Jolly</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">Aleph-One-Marathon/alephone</remote-id>
+ <remote-id type="sourceforge">marathon</remote-id>
+ </upstream>
+</pkgmetadata>