summaryrefslogtreecommitdiff
path: root/games-engines
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-11-24 16:33:11 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-11-24 16:33:11 +0000
commitfaddeff65d652bda3291eba255955adb17f1aa19 (patch)
tree4352e6d85ce48c7c8d96159fad4d3dd90602a70a /games-engines
parent0e7b1da874d923b9f006e0000023f5fa528140a8 (diff)
gentoo auto-resync : 24:11:2023 - 16:33:11
Diffstat (limited to 'games-engines')
-rw-r--r--games-engines/Manifest.gzbin3554 -> 3554 bytes
-rw-r--r--games-engines/odamex/Manifest1
-rw-r--r--games-engines/odamex/odamex-10.4.0-r1.ebuild91
-rw-r--r--games-engines/scummvm-tools/Manifest7
-rw-r--r--games-engines/scummvm-tools/files/scummvm-tools-2.7.0-endianess.patch27
-rw-r--r--games-engines/scummvm-tools/metadata.xml3
-rw-r--r--games-engines/scummvm-tools/scummvm-tools-2.7.0_p1.ebuild81
7 files changed, 209 insertions, 1 deletions
diff --git a/games-engines/Manifest.gz b/games-engines/Manifest.gz
index 9cfe25d48255..5248b041b100 100644
--- a/games-engines/Manifest.gz
+++ b/games-engines/Manifest.gz
Binary files differ
diff --git a/games-engines/odamex/Manifest b/games-engines/odamex/Manifest
index f0ce4b1310a6..f1932488abfd 100644
--- a/games-engines/odamex/Manifest
+++ b/games-engines/odamex/Manifest
@@ -1,4 +1,5 @@
AUX odamex-10.3.0-unbundle-fltk.patch 3556 BLAKE2B 8aa1fd752c465a89566edab409c2df03ce1bae7a3ae1fdf3749fbce90cef81d1315f1f677f3090d676ad514df957a043cfd02c497d03673c248d55b02ee89768 SHA512 3facbcb43f0bc516e85c6030d66fc03c2c0b11d25ed30bac1947cbffd1f3123e173c46e02b198215dc5b4aac7fccbf1bfe9aeaf54db6c0d159d7bd6d3abd3797
DIST odamex-src-10.4.0.tar.gz 24233204 BLAKE2B 377f14db15a367db3e84267a1483d5e138291fcefe53c2d522d2767ddd4a804df7ab31726d8818497c1eed93e6f0658fa4f855b6f4b0610f378a4ef3aab180b6 SHA512 12c114181aaf50e8c1f8c04d6e252f422fe887b5dc0be21974f5c1ac6645e1988091af638eb68fb9667ec4c7c2bdd5bb49981546644c33e90c80a9baefe2c930
+EBUILD odamex-10.4.0-r1.ebuild 2282 BLAKE2B f9fa08e428e31fa400a258ded6413343fa9c54cab60d4899123c00e2a505dd036483182557ac5b853f6aca3804f9fe65ebd4c61a5287319ca3cfeb2537f1c7cc SHA512 029b559631cfd50442b23e8274cc437946ac60b29fe9aff50e59651cad80b1d51414340b73da44201bbbe2eed8ec5ec8530e9ecd1ab293aa8296a7cbe8ccdaaa
EBUILD odamex-10.4.0.ebuild 2182 BLAKE2B 81af80e1d38971828369a1b67ace9761809205d0145862781542bfbbd4b615074d663e0c35fa2e5d567f6b67416a0775bca24cd27a41a47c45ca298fb2008555 SHA512 795b9e65dbaaac5dedb5bf39f0ee5022f724f47b52bef3999cdb78da069734c7915a7489a884e239f6c233c77a6541eecfb74bd027c7919edf8100c867953cb6
MISC metadata.xml 1438 BLAKE2B 2cd891e631cb9ee0182c30d9aa8a9e69089f32fb12b44f8e4a62372e40db8f89a9701411dcb3bb86937d50e035452359cb95d2bbd5b4a74d2057cb77872196ad SHA512 72f2858c111b40de8ba9da3b5d52f673ce0847fd4036e1582dc9ce56432b3e08a61ef650fc253072789a6d00167c8312158d8be374dbbfbdd5473ab75cb447af
diff --git a/games-engines/odamex/odamex-10.4.0-r1.ebuild b/games-engines/odamex/odamex-10.4.0-r1.ebuild
new file mode 100644
index 000000000000..cf946901e853
--- /dev/null
+++ b/games-engines/odamex/odamex-10.4.0-r1.ebuild
@@ -0,0 +1,91 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+WX_GTK_VER="3.2-gtk3"
+inherit cmake desktop prefix wxwidgets xdg
+
+DESCRIPTION="Online multiplayer free software engine for DOOM"
+HOMEPAGE="https://odamex.net/"
+SRC_URI="https://github.com/${PN}/${PN}/releases/download/${PV}/${PN}-src-${PV}.tar.gz"
+
+LICENSE="GPL-2+ MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+IUSE="+client hidpi master +odalaunch portmidi server upnp X"
+REQUIRED_USE="|| ( client master server )"
+
+# protobuf is still bundled. Unfortunately an old version is required for C++98
+# compatibility. We could use C++11, but upstream is concerned about using a
+# completely different protobuf version on a multiplayer-focused engine.
+
+RDEPEND="
+ client? (
+ media-libs/libpng:0=
+ media-libs/libsdl2[joystick,sound,video]
+ media-libs/sdl2-mixer
+ net-misc/curl
+ !hidpi? ( x11-libs/fltk:1 )
+ portmidi? ( media-libs/portmidi )
+ X? ( x11-libs/libX11 )
+ )
+ odalaunch? ( x11-libs/wxGTK:${WX_GTK_VER}[X] )
+ server? (
+ dev-libs/jsoncpp:=
+ upnp? ( net-libs/miniupnpc:= )
+ )"
+DEPEND="${RDEPEND}"
+BDEPEND="games-util/deutex"
+
+S="${WORKDIR}/${PN}-src-${PV}"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-10.3.0-unbundle-fltk.patch
+)
+
+src_prepare() {
+ rm -r libraries/miniupnp || die
+ hprefixify common/d_main.cpp
+
+ use odalaunch && setup-wxwidgets
+
+ cmake_src_prepare
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DUSE_INTERNAL_FLTK=$(usex hidpi)
+ -DUSE_INTERNAL_JSONCPP=0
+ -DUSE_INTERNAL_LIBS=0
+ -DUSE_INTERNAL_MINIUPNP=0
+ -DBUILD_CLIENT=$(usex client)
+ -DBUILD_LAUNCHER=$(usex odalaunch)
+ -DBUILD_MASTER=$(usex master)
+ -DBUILD_SERVER=$(usex server)
+ -DBUILD_OR_FAIL=1
+ -DENABLE_PORTMIDI=$(usex portmidi)
+ -DUSE_MINIUPNP=$(usex upnp)
+ )
+ use client && mycmakeargs+=(-DCMAKE_DISABLE_FIND_PACKAGE_X11=$(usex !X))
+
+ cmake_src_configure
+}
+
+src_install() {
+ if use client ; then
+ for size in 96 128 256 512; do
+ newicon -s ${size} "${S}/media/icon_${PN}_${size}.png" "${PN}.png"
+ done
+ make_desktop_entry "${PN}" "Odamex"
+
+ if use odalaunch ; then
+ for size in 96 128 256 512; do
+ newicon -s ${size} "${S}/media/icon_odalaunch_${size}.png" "odalaunch.png"
+ done
+ make_desktop_entry odalaunch "Odamex Launcher" odalaunch
+ fi
+ fi
+
+ cmake_src_install
+}
diff --git a/games-engines/scummvm-tools/Manifest b/games-engines/scummvm-tools/Manifest
index 66cb3107c4c1..cd94f8e7e4c7 100644
--- a/games-engines/scummvm-tools/Manifest
+++ b/games-engines/scummvm-tools/Manifest
@@ -1,5 +1,10 @@
AUX scummvm-tools-1.8.0-binprefix.patch 539 BLAKE2B 8c3ebc7202e209552fe2521e445a8a1dd025bfa872bd78cc31f05c01b2d559f619f3f1f15dd9f26a66d192410fc5404a5b0afee636cd33603112535500d07459 SHA512 4d2f06dcc3092dd5abab218b68c83dfc2353810b56e3a1d41fab1c7eb20b008ed2e54af486c4c4f2ecbd383ef0afa6f333ed90c694ed3b1733393a6f2ef6fbe3
AUX scummvm-tools-2.2.0-strings.patch 559 BLAKE2B 44d3c40cd57293cc589a19b7e73f737e84cbbc88ece32e8b078dbf3ada0b4a9d8cafa0a96ad2c2020803da61172ae3f8dfadc66842cb773b2192091a71a3eeb7 SHA512 60e53a68acbab3ee983471f604a691eb66344f2f4a6a30a57d268c52d00cac05083606ec062f043bcf511edb32c27fce69d95c5a17229e94dd16af98806ac701
+AUX scummvm-tools-2.7.0-endianess.patch 1811 BLAKE2B 78d852504e38ba61ea4cc4c979506931c2f6fc485ca0ac608c77dab5cc179a412784f81e0922cb3685777249bb86195a334e3e1c6113f2e719c4fc37e20e2229 SHA512 81413bea78af4c95b68cc623f91a563aabfc93850b2f8ba724214a7d6f90e36e6df6383a8818ff5c1f20e46c6424dcd4051957ad7b4d4a17c015d81eb374178e
DIST scummvm-tools-2.2.0.tar.xz 712048 BLAKE2B bb5307ee25476c9b4042fa0704f8b9bbfc4a57c09670bc699c83b9d5ebb0a7b9cda55f7267aafa6ae57e3ce53993740a1523616e39cf0a2c0c7249b23208372e SHA512 97d23a94772809b6fe6dcfc4d1bde9e1a12c124cb49b0a465456adbbd56358a1612b9797abb9577dc350e1150fb4a70d4b7451e794c436c8e91692b4a83deb89
+DIST scummvm-tools-2.7.0.tar.xz 1286572 BLAKE2B bcb58267a9c04849ab3145f2d5a657b9e1ec6c2bb9e59bbf47ae6aae842385e70d0417f92ca4018786cf91f8c607a5fe1246f846dc496318b01ec51bd059358b SHA512 0f6541f86814a089b10969e8e0cc8c985ac4d3b5f15daf91869a9b9cc748d7b6c668ffd428c1f0726ff9a1fb5cc7b496098481778cbf41203a7eb3077a189ce7
+DIST scummvm-tools_2.7.0-1.debian.tar.xz 10212 BLAKE2B 9805222166f30d1535642958ac74984968dd19bfa3b7a159b61509215fd29d370a9393d0a25e4dfd041ee83feb9fffb55f5f705d76ac03de95d925718166c263 SHA512 f7234e58312f7979b9f87940020d9815429a24be6083e8ed61ef14c342c83edfb00f2f9d130e2a18b34099c3a20df3093556b017f28a40a1f8d8037ad8d99bed
+DIST scummvm-tools_512.png 56989 BLAKE2B 8173b580a542d78a4dcb859f8ba008af8f5dcd707c6213a3fc961dc5f8bbe02f3e67beafbaceff8ffb75a26d0a1c441642a103c1607b7c776b6da6c803545a47 SHA512 94d0cd2ccb7ac7ea1ca20ba208908ac05e064470f260e3347aec2aa457f1cf281c6bc88056e14001a1f93422f9cdfb732c53262d8067a4c487a57396b510fd7f
EBUILD scummvm-tools-2.2.0-r1.ebuild 1354 BLAKE2B ded211f8bf10e151b868dd7085f3b1bba3620b0439b866355ad0407d0b3025bbfa0781ad09dab10caf4e4de54b173921048e2db63f85587169351731a4f83534 SHA512 57105b4312324cf77d90e714a7b11d75209f7c319fef12a3fcbc447896e7fa285ab95418d8a9b40aa1b3af49b8a4aa7bb4ac597002f55d1eedff3b611de920c5
-MISC metadata.xml 331 BLAKE2B 1c013d6bff1e0df9cf8fe372a2a4278d79ecf60099ad85cbcfc35533cceae2311b33c24aaaa54fd9e66d7615655519382c19d0355d6bd8ceeed10f2fda3a0b32 SHA512 12db2a1072a9831ca8d5b60a09056ce644baf84fd048ca0e0c1831f098bdb2e9f3575ef14d8ffff68d43326e3544d866f6d31aff2e6cb5d051c4c6406e04f6d3
+EBUILD scummvm-tools-2.7.0_p1.ebuild 1903 BLAKE2B e8d75521676d51956782fc739a5c1bd7c70df6950eb2b9ab96a79adb78e9c4c0c24f5b01a715aec46736c98750fd9c1f9cd8b3e22d649bb5e4c0175b86d367b8 SHA512 526bb5a25cf3d89a138b388701422e7f49715ea418bb8e727a67f36a87bcd56ef3f968fe3fc4515d57ddb83cfd5867123c509c651c867c89de247cdd2b41afbf
+MISC metadata.xml 438 BLAKE2B f066a8163b876d4046f62ce8d40d00de386800b255208ae987bb0291770f1977d1df1b62e800e0a22abf735bbb8b043a43280d8fb3b92475609e5f2d1bd8ebae SHA512 19add2d688494acdccc4475d917098c4e96b17da0ceba2996a53be2bf5866ee3fba5527be21b1fc5fa2f92ed777ca615d9f49945ef2cfdd2e26165ed68674e3d
diff --git a/games-engines/scummvm-tools/files/scummvm-tools-2.7.0-endianess.patch b/games-engines/scummvm-tools/files/scummvm-tools-2.7.0-endianess.patch
new file mode 100644
index 000000000000..6752914d2c2b
--- /dev/null
+++ b/games-engines/scummvm-tools/files/scummvm-tools-2.7.0-endianess.patch
@@ -0,0 +1,27 @@
+# https://src.fedoraproject.org/rpms/scummvm-tools/raw/rawhide/f/configure.patch
+diff -uNr scummvm-tools-2.5.0.old/configure scummvm-tools-2.5.0/configure
+--- scummvm-tools-2.5.0.old/configure 2021-10-01 13:59:48.000000000 +0200
++++ scummvm-tools-2.5.0/configure 2021-12-14 23:01:39.604582839 +0100
+@@ -1047,15 +1047,15 @@
+ #
+ echo_n "Checking endianness... "
+ cat > tmp_endianness_check.cpp << EOF
+-unsigned short ascii_mm[] = { 0x4249, 0x4765, 0x6E44, 0x6961, 0x6E53, 0x7953, 0 };
+-unsigned short ascii_ii[] = { 0x694C, 0x5454, 0x656C, 0x6E45, 0x6944, 0x6E61, 0 };
+-void _ascii() { char* s = (char*) ascii_mm; s = (char*) ascii_ii; }
+-unsigned short ebcdic_ii[] = { 0x89D3, 0xE3E3, 0x8593, 0x95C5, 0x89C4, 0x9581, 0 };
+-unsigned short ebcdic_mm[] = { 0xC2C9, 0xC785, 0x95C4, 0x8981, 0x95E2, 0xA8E2, 0 };
+-void _ebcdic() { char* s = (char*) ebcdic_mm; s = (char*) ebcdic_ii; }
++__attribute__ ((used)) unsigned short ascii_mm[] = { 0x4249, 0x4765, 0x6E44, 0x6961, 0x6E53, 0x7953, 0 };
++__attribute__ ((used)) unsigned short ascii_ii[] = { 0x694C, 0x5454, 0x656C, 0x6E45, 0x6944, 0x6E61, 0 };
++__attribute__ ((used)) void _ascii() { char* s = (char*) ascii_mm; s = (char*) ascii_ii; }
++__attribute__ ((used)) unsigned short ebcdic_ii[] = { 0x89D3, 0xE3E3, 0x8593, 0x95C5, 0x89C4, 0x9581, 0 };
++__attribute__ ((used)) unsigned short ebcdic_mm[] = { 0xC2C9, 0xC785, 0x95C4, 0x8981, 0x95E2, 0xA8E2, 0 };
++__attribute__ ((used)) void _ebcdic() { char* s = (char*) ebcdic_mm; s = (char*) ebcdic_ii; }
+ int main() { _ascii (); _ebcdic (); return 0; }
+ EOF
+-$CXX $CXXFLAGS -c -o $TMPO.o tmp_endianness_check.cpp
++$CXX $CXXFLAGS -ffat-lto-objects -c -o $TMPO.o tmp_endianness_check.cpp
+ if $_strings $TMPO.o | grep BIGenDianSyS >/dev/null; then
+ _endian=big
+ elif $_strings $TMPO.o | grep LiTTleEnDian >/dev/null; then
diff --git a/games-engines/scummvm-tools/metadata.xml b/games-engines/scummvm-tools/metadata.xml
index e6b8e4e911e0..798292735601 100644
--- a/games-engines/scummvm-tools/metadata.xml
+++ b/games-engines/scummvm-tools/metadata.xml
@@ -8,4 +8,7 @@
<upstream>
<remote-id type="sourceforge">scummvm</remote-id>
</upstream>
+ <use>
+ <flag name="tremor">Enable tremor, a fixed-point version of the Ogg Vorbis decoder</flag>
+ </use>
</pkgmetadata>
diff --git a/games-engines/scummvm-tools/scummvm-tools-2.7.0_p1.ebuild b/games-engines/scummvm-tools/scummvm-tools-2.7.0_p1.ebuild
new file mode 100644
index 000000000000..d06380eb0491
--- /dev/null
+++ b/games-engines/scummvm-tools/scummvm-tools-2.7.0_p1.ebuild
@@ -0,0 +1,81 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+WX_GTK_VER="3.2-gtk3"
+
+inherit desktop toolchain-funcs wxwidgets xdg
+
+DESCRIPTION="Utilities for the SCUMM game engine"
+HOMEPAGE="https://www.scummvm.org/"
+SRC_URI="https://www.scummvm.org/frs/scummvm-tools/${PV/_p*}/${P/_p*}.tar.xz
+ mirror://debian/pool/main/${PN:0:1}/${PN}/${PN}_${PV/_p*}-${PV/*_p}.debian.tar.xz
+ https://dev.gentoo.org/~pacho/${PN}/${PN}_512.png"
+S="${WORKDIR}/${P/_p*}"
+
+LICENSE="GPL-3+ LGPL-2+ MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE="flac iconv mad png tremor vorbis"
+
+RDEPEND="
+ dev-libs/boost:=
+ sys-libs/zlib
+ x11-libs/wxGTK:${WX_GTK_VER}
+ flac? ( media-libs/flac:= )
+ iconv? (
+ virtual/libiconv
+ media-libs/freetype:2 )
+ mad? ( media-libs/libmad )
+ png? ( media-libs/libpng:= )
+ tremor? ( media-libs/tremor )
+ vorbis? ( media-libs/libvorbis )
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ virtual/pkgconfig
+"
+
+PATCHES=(
+ # Endianess patch synced with Fedora
+ "${FILESDIR}/${PN}-2.7.0-endianess.patch"
+)
+
+src_prepare() {
+ default
+
+ # Debian patches
+ for p in $(<"${WORKDIR}"/debian/patches/series) ; do
+ eapply -p1 "${WORKDIR}/debian/patches/${p}"
+ done
+}
+
+src_configure() {
+ setup-wxwidgets
+ tc-export CXX STRINGS
+
+ # Not an autoconf script
+ ./configure \
+ --enable-verbose-build \
+ --mandir="${EPREFIX}/usr/share/man" \
+ --prefix="${EPREFIX}/usr" \
+ $(use_enable flac) \
+ $(use_enable iconv) \
+ $(use_enable iconv freetype2) \
+ $(use_enable mad) \
+ $(use_enable png) \
+ $(use_enable tremor) \
+ $(use_enable vorbis) || die
+}
+
+src_install() {
+ default
+ cd "${ED}"/usr/bin || die
+ for i in $(ls * | grep -v scummvm-tools) ; do
+ mv ${i} ${PN}-${i} || die
+ done
+
+ make_desktop_entry ${PN} "ScummVM Tools" ${PN} "Game;AdventureGame;"
+ newicon -s 128 "${S}"/gui/media/scummvmtools_128.png ${PN}.png
+ newicon -s 512 "${DISTDIR}"/${PN}_512.png ${PN}.png
+}