summaryrefslogtreecommitdiff
path: root/games-engines/openxcom/openxcom-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-03-03 10:28:17 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-03-03 10:28:17 +0000
commitd99093fb4bb5652015c06274d64083daa2439e4f (patch)
treecf61513204d97974179580065e85df5c8009087c /games-engines/openxcom/openxcom-9999.ebuild
parent463397cf1e064185110fe57c568d73f99a06f5d1 (diff)
gentoo resync : 03.03.2021
Diffstat (limited to 'games-engines/openxcom/openxcom-9999.ebuild')
-rw-r--r--games-engines/openxcom/openxcom-9999.ebuild52
1 files changed, 30 insertions, 22 deletions
diff --git a/games-engines/openxcom/openxcom-9999.ebuild b/games-engines/openxcom/openxcom-9999.ebuild
index 7726841e5584..511bec55bed0 100644
--- a/games-engines/openxcom/openxcom-9999.ebuild
+++ b/games-engines/openxcom/openxcom-9999.ebuild
@@ -1,59 +1,67 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
-inherit cmake-utils gnome2-utils git-r3
+EAPI=7
-DESCRIPTION="An open-source reimplementation of the popular UFO: Enemy Unknown"
+inherit cmake xdg-utils
+
+DESCRIPTION="Open-source reimplementation of the popular UFO: Enemy Unknown"
HOMEPAGE="https://openxcom.org/"
-EGIT_REPO_URI="https://github.com/SupSuper/OpenXcom.git"
+
+if [[ ${PV} == *9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/SupSuper/OpenXcom.git"
+else
+ COMMIT="ea9ac466221f8b4f8974d2db1c42dc4ad6126564"
+ SRC_URI="https://github.com/SupSuper/OpenXcom/archive/${COMMIT}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm64 ~x86"
+ S="${WORKDIR}/OpenXcom-${COMMIT}"
+fi
LICENSE="GPL-3+ CC-BY-SA-4.0"
SLOT="0"
-KEYWORDS=""
IUSE="doc"
-RDEPEND=">=dev-cpp/yaml-cpp-0.5.1
+RDEPEND="
+ >=dev-cpp/yaml-cpp-0.5.1
media-libs/libsdl[opengl,video]
media-libs/sdl-gfx
media-libs/sdl-image[png]
media-libs/sdl-mixer[flac,mikmod,vorbis]"
-DEPEND="${RDEPEND}
- doc? ( app-doc/doxygen )"
+DEPEND="${RDEPEND}"
+BDEPEND="doc? ( app-doc/doxygen )"
DOCS=( README.md )
+PATCHES=( "${FILESDIR}/${P}-mandir.patch" ) # TODO: GNUInstallDirs
+
src_compile() {
- use doc && cmake-utils_src_compile doxygen
- cmake-utils_src_compile
+ cmake_src_compile
+ use doc && cmake_build doxygen
}
src_install() {
- cmake-utils_src_install
- use doc && dodoc -r "${CMAKE_BUILD_DIR}"/docs/html/*
-}
-
-pkg_preinst() {
- gnome2_icon_savelist
+ use doc && local HTML_DOCS=( "${BUILD_DIR}"/docs/html/. )
+ cmake_src_install
}
pkg_postinst() {
- gnome2_icon_cache_update
- echo
+ xdg_icon_cache_update
+
elog "In order to play you need copy GEODATA, GEOGRAPH, MAPS, ROUTES, SOUND,"
elog "TERRAIN, UFOGRAPH, UFOINTRO, UNITS folders from original X-COM game to"
elog "/usr/share/${PN}/UFO"
- echo
+ elog
elog "If you want to play the TFTD mod, you need to copy ANIMS, FLOP_INT,"
elog "GEODATA, GEOGRAPH, MAPS, ROUTES, SOUND, TERRAIN, UFOGRAPH, UNITS folders"
elog "from the original Terror from the Deep game to"
elog "/usr/share/${PN}/TFTD"
- echo
+ elog
elog "If you need or want text in some language other than english, download:"
elog "https://openxcom.org/translations/latest.zip and uncompress it in"
elog "/usr/share/${PN}/common/Language"
}
pkg_postrm() {
- gnome2_icon_cache_update
+ xdg_icon_cache_update
}