summaryrefslogtreecommitdiff
path: root/games-engines/openmw
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-04-19 14:14:48 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-04-19 14:14:48 +0100
commit5cfef3c94cd7e82136c69a0322f5ba21f7e64632 (patch)
tree8f255dfacbacb657e3ac3654d01c1e11e651c066 /games-engines/openmw
parent8aebb228036d5e2863b7eaa6e319ab41c1669269 (diff)
gentoo resync : 19.04.2018
Diffstat (limited to 'games-engines/openmw')
-rw-r--r--games-engines/openmw/Manifest3
-rw-r--r--games-engines/openmw/files/openmw-0.43.0-qt-5.11b3.patch81
-rw-r--r--games-engines/openmw/openmw-0.43.0-r1.ebuild2
3 files changed, 85 insertions, 1 deletions
diff --git a/games-engines/openmw/Manifest b/games-engines/openmw/Manifest
index 9f445627ab86..9bc9c7baf7b9 100644
--- a/games-engines/openmw/Manifest
+++ b/games-engines/openmw/Manifest
@@ -1,3 +1,4 @@
+AUX openmw-0.43.0-qt-5.11b3.patch 2842 BLAKE2B 29bf75b29144c6a9eadb316998b16bf2b2e492624d70d7a2a3578b67ec3446b2359642dc13c242131c803f3e300af3d0f0dad09f19f9462f2b42beccc0d84c87 SHA512 1cc4bc7c9fdaadf829ab8526d9fbd72a0058628293b133e701bd187f80ed234e7951d4cc2ec07fdcb521d685ff1471ef27b78b5db77156bbecc2165b653f7897
DIST openmw-0.43.0.tar.gz 5023421 BLAKE2B c99e3a23b22b642dea9e8f2d9414e00aa6a05c4331a9715882465781caca60cd857675d87079bafc3596783e257213bec9d6f1f4e78a3d795e973fb1d895811e SHA512 e902dd2274c05838bb1171f07d7a673fc7b85d1290a9e01c8ab89f1c279bd236332ecdc0f2b7944ec7209a0e6022ff472639b5724bf26904e3a2d338c7be401a
-EBUILD openmw-0.43.0-r1.ebuild 3243 BLAKE2B 8c322e26b7460ac5d231efe02a1331fb9dd76c2d837e4907bc0dfc365a4ef7a1cea740f9e2df3867c845bdccb41773b47dc1513423cc714920056f4d746cb81f SHA512 e6846d2e492a72b45ddc9c92e2f3d5f17066346724a43fed0d027ffab74cac660ad4b32fabd85c06330f6ebc0217571b486d6e63685b48c92fc4b7e97d46cabb
+EBUILD openmw-0.43.0-r1.ebuild 3291 BLAKE2B e35859cbdca3aea7d6ac5cead05681d090c9164905958c92ad5c7c9a046e3eb345b7fe03b68b123650d2f2ec239ffd50be57acfa794a145b831c17a49b1b1dd9 SHA512 bc8393f838424342ff29fea1b4bdfbfe5082edcbadc256a9771cfaf2139464d1e97ac7bdb57de61e8dd15edd61c97e3af10a7b649bd163a44daceeea8ae197f0
MISC metadata.xml 1044 BLAKE2B 132bf7783f4cdac33cfb9bffac4e8a0baf7380f8bb91b262c087ebab4848e6fc97dbac258d600836f1d447536077f063d0dc0ca7348179a61310806f5862ecfe SHA512 c47622fc66013a7c61b1f865619a77707b296b051df54bd75048073b6b5875d97fb300d490a5aba923cc369566ffb5f3dbab16451d1bf48f5f91de18ee7c2116
diff --git a/games-engines/openmw/files/openmw-0.43.0-qt-5.11b3.patch b/games-engines/openmw/files/openmw-0.43.0-qt-5.11b3.patch
new file mode 100644
index 000000000000..85b290e660ba
--- /dev/null
+++ b/games-engines/openmw/files/openmw-0.43.0-qt-5.11b3.patch
@@ -0,0 +1,81 @@
+From 2c9d46a60bd8d35f132cb106e5255d590b13640b Mon Sep 17 00:00:00 2001
+From: Andreas Sturmlechner <asturm@gentoo.org>
+Date: Tue, 17 Apr 2018 23:03:56 +0200
+Subject: [PATCH] Fix build with Qt 5.11_beta3 (dropping qt5_use_modules)
+
+---
+ apps/launcher/CMakeLists.txt | 2 +-
+ apps/opencs/CMakeLists.txt | 2 +-
+ apps/wizard/CMakeLists.txt | 2 +-
+ components/CMakeLists.txt | 2 +-
+ extern/osgQt/CMakeLists.txt | 2 +-
+ 5 files changed, 5 insertions(+), 5 deletions(-)
+
+diff --git a/apps/launcher/CMakeLists.txt b/apps/launcher/CMakeLists.txt
+index aec8c2533..99e7b4daa 100644
+--- a/apps/launcher/CMakeLists.txt
++++ b/apps/launcher/CMakeLists.txt
+@@ -106,7 +106,7 @@ if (DESIRED_QT_VERSION MATCHES 4)
+ target_link_libraries(openmw-launcher ${QT_QTMAIN_LIBRARY})
+ endif(WIN32)
+ else()
+- qt5_use_modules(openmw-launcher Widgets Core)
++ target_link_libraries(openmw-launcher Qt5::Widgets Qt5::Core)
+ endif()
+
+ if (BUILD_WITH_CODE_COVERAGE)
+diff --git a/apps/opencs/CMakeLists.txt b/apps/opencs/CMakeLists.txt
+index b9279bf91..f07b518a9 100644
+--- a/apps/opencs/CMakeLists.txt
++++ b/apps/opencs/CMakeLists.txt
+@@ -246,7 +246,7 @@ if (DESIRED_QT_VERSION MATCHES 4)
+ target_link_libraries(openmw-cs ${QT_QTMAIN_LIBRARY})
+ endif()
+ else()
+- qt5_use_modules(openmw-cs Widgets Core Network OpenGL)
++ target_link_libraries(openmw-cs Qt5::Widgets Qt5::Core Qt5::Network Qt5::OpenGL)
+ endif()
+
+ if (WIN32)
+diff --git a/apps/wizard/CMakeLists.txt b/apps/wizard/CMakeLists.txt
+index 5f7338e52..8d97bbcbf 100644
+--- a/apps/wizard/CMakeLists.txt
++++ b/apps/wizard/CMakeLists.txt
+@@ -118,7 +118,7 @@ if (DESIRED_QT_VERSION MATCHES 4)
+ target_link_libraries(openmw-wizard ${QT_QTMAIN_LIBRARY})
+ endif()
+ else()
+- qt5_use_modules(openmw-wizard Widgets Core)
++ target_link_libraries(openmw-wizard Qt5::Widgets Qt5::Core)
+ endif()
+
+ if (OPENMW_USE_UNSHIELD)
+diff --git a/components/CMakeLists.txt b/components/CMakeLists.txt
+index 8256f1443..ecb844a9b 100644
+--- a/components/CMakeLists.txt
++++ b/components/CMakeLists.txt
+@@ -216,7 +216,7 @@ if (USE_QT)
+ ${QT_QTCORE_LIBRARY}
+ ${QT_QTGUI_LIBRARY})
+ else()
+- qt5_use_modules(components Widgets Core)
++ target_link_libraries(components Qt5::Widgets Qt5::Core)
+ endif()
+ endif()
+
+diff --git a/extern/osgQt/CMakeLists.txt b/extern/osgQt/CMakeLists.txt
+index 3bd08a390..78a4e6034 100644
+--- a/extern/osgQt/CMakeLists.txt
++++ b/extern/osgQt/CMakeLists.txt
+@@ -12,7 +12,7 @@ if (DESIRED_QT_VERSION MATCHES 4)
+ include(${QT_USE_FILE})
+ target_link_libraries(${OSGQT_LIBRARY} ${QT_QTCORE_LIBRARY} ${QT_QTOPENGL_LIBRARY})
+ else()
+- qt5_use_modules(${OSGQT_LIBRARY} Core OpenGL)
++ target_link_libraries(${OSGQT_LIBRARY} Qt5::Core Qt5::OpenGL)
+ endif()
+
+ link_directories(${CMAKE_CURRENT_BINARY_DIR})
+--
+2.17.0
+
diff --git a/games-engines/openmw/openmw-0.43.0-r1.ebuild b/games-engines/openmw/openmw-0.43.0-r1.ebuild
index b514d7557040..0efb2c196763 100644
--- a/games-engines/openmw/openmw-0.43.0-r1.ebuild
+++ b/games-engines/openmw/openmw-0.43.0-r1.ebuild
@@ -44,6 +44,8 @@ DEPEND="${RDEPEND}
S="${WORKDIR}/${PN}-${P}"
+PATCHES=( "${FILESDIR}/${P}-qt-5.11b3.patch" )
+
src_prepare() {
cmake-utils_src_prepare