summaryrefslogtreecommitdiff
path: root/games-engines/love/love-0.7.2-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /games-engines/love/love-0.7.2-r1.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'games-engines/love/love-0.7.2-r1.ebuild')
-rw-r--r--games-engines/love/love-0.7.2-r1.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/games-engines/love/love-0.7.2-r1.ebuild b/games-engines/love/love-0.7.2-r1.ebuild
new file mode 100644
index 000000000000..114a60337252
--- /dev/null
+++ b/games-engines/love/love-0.7.2-r1.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+inherit eutils games
+
+DESCRIPTION="A framework for 2D games in Lua"
+HOMEPAGE="http://love2d.org/"
+SRC_URI="https://www.bitbucket.org/rude/${PN}/downloads/${P}-linux-src.tar.gz"
+
+LICENSE="ZLIB"
+SLOT="0.7"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+RDEPEND="dev-games/physfs
+ dev-lang/lua[deprecated]
+ media-libs/devil[mng,png,tiff]
+ media-libs/freetype
+ media-libs/libmodplug
+ media-libs/libsdl[joystick,opengl]
+ media-libs/libvorbis
+ media-libs/openal
+ media-sound/mpg123
+ virtual/opengl"
+DEPEND="${RDEPEND}
+ media-libs/libmng
+ media-libs/tiff"
+
+S=${WORKDIR}/${PN}-HEAD
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-0.8.0-freetype2.patch
+}
+
+src_install() {
+ DOCS="readme.txt changes.txt" \
+ default
+ if [[ "${SLOT}" != "0" ]]; then
+ mv "${ED}${GAMES_BINDIR}"/${PN} \
+ "${ED}${GAMES_BINDIR}"/${PN}-${SLOT} || die
+ fi
+}