summaryrefslogtreecommitdiff
path: root/games-engines/gargoyle
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /games-engines/gargoyle
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'games-engines/gargoyle')
-rw-r--r--games-engines/gargoyle/Manifest4
-rw-r--r--games-engines/gargoyle/files/gargoyle-2011.1-desktopfile.patch31
-rw-r--r--games-engines/gargoyle/gargoyle-2011.1-r1.ebuild118
-rw-r--r--games-engines/gargoyle/metadata.xml11
4 files changed, 164 insertions, 0 deletions
diff --git a/games-engines/gargoyle/Manifest b/games-engines/gargoyle/Manifest
new file mode 100644
index 000000000000..44fcb1627a6a
--- /dev/null
+++ b/games-engines/gargoyle/Manifest
@@ -0,0 +1,4 @@
+AUX gargoyle-2011.1-desktopfile.patch 1265 BLAKE2B 1fcbc1eded032ef11ef357e03c614067b18c21a268b4a3bebe4516a0ed196660292b311c9769d66853ffbbf2535808d014991bd42155919b913965223a4523dc SHA512 ed31bc711b52b5d231f130956d7d07cb9080747e6d53c85b379aa413582f8e4ffe825298bc86180ec7d1eadff5e6bffc6e49b3ff7a2607f612dcf81a6c1af22e
+DIST gargoyle-2011.1-sources.zip 11291660 BLAKE2B aac47c41bd02e772c4717dfdeae8678105f72704641ea3df39105d412afe61734cc43f863b9556e38ea34287259df9f4d72ae93b3092d0372434b9f59f99483d SHA512 65159580cf3494944f841c44320135580557258e37ad5523ae3ea30555c19834a2793231a8e42c217e5c1d055d50ed6a20d372d6302e880a2818bc4ea59b226f
+EBUILD gargoyle-2011.1-r1.ebuild 3017 BLAKE2B 12371e41ca78403ba1452da2a2c5dbac287912b8dbcd7afe524984b8442bb4cf5701f3073f27a64c5adadccfebfaaef9e543b883026b4eae4b185cc151eac6b7 SHA512 0daa2b0ef761c935d0e7d47fd42060ebf5db4331634bba8e1812a619d8fb31cdb0f2aec197cf7d30e1bff357ccd60888ac5107c7e9644f8ddeed9520a9b1ac9e
+MISC metadata.xml 329 BLAKE2B cc77f8750b5385687d311159b8edbf296284013812d4be5fe0076468c02758dcac19c77b5e6f38c4fbdac51f1c69b34cfd39d5d19235d18ec80076ceba98e2b3 SHA512 f6b913db889e2434a76d61526ff2cf3f719322991bb26891ac0383fcb8f11cf69cfc895a7cddd35074c2dee9a5ceac0fd8c0172542401d302ec39e9cac180b2c
diff --git a/games-engines/gargoyle/files/gargoyle-2011.1-desktopfile.patch b/games-engines/gargoyle/files/gargoyle-2011.1-desktopfile.patch
new file mode 100644
index 000000000000..6b66328da016
--- /dev/null
+++ b/games-engines/gargoyle/files/gargoyle-2011.1-desktopfile.patch
@@ -0,0 +1,31 @@
+From: Julian Ospald <hasufell@gentoo.org>
+Date: Tue Aug 21 19:06:54 UTC 2012
+Subject: desktop file
+
+fix QA issues:
+
+# desktop-file-validate /usr/share/applications/gargoyle.desktop
+/usr/share/applications/gargoyle.desktop: error: file contains at least one line ending with a carriage return, while lines should only be separated by a line feed character. First such line is: "[Desktop Entry]"
+/usr/share/applications/gargoyle.desktop: error: (will be fatal in the future): value "gargoyle-house.png" for key "Icon" in group "Desktop Entry" is an icon name with an extension, but there should be no extension as described in the Icon Theme Specification if the value is not an absolute path
+
+--- garglk/gargoyle.desktop
++++ garglk/gargoyle.desktop
+@@ -1,9 +1,9 @@
+-[Desktop Entry]
+-Version=1.0
+-Type=Application
+-Name=Gargoyle
+-GenericName=Interactive Fiction interpreter
+-Comment=Interactive Fiction multi-interpreter that supports all major IF formats
+-Icon=gargoyle-house.png
+-Exec=gargoyle
+-Categories=Game;
++[Desktop Entry]
++Version=1.0
++Type=Application
++Name=Gargoyle
++GenericName=Interactive Fiction interpreter
++Comment=Interactive Fiction multi-interpreter that supports all major IF formats
++Icon=gargoyle-house
++Exec=gargoyle
++Categories=Game;
diff --git a/games-engines/gargoyle/gargoyle-2011.1-r1.ebuild b/games-engines/gargoyle/gargoyle-2011.1-r1.ebuild
new file mode 100644
index 000000000000..82e11b237828
--- /dev/null
+++ b/games-engines/gargoyle/gargoyle-2011.1-r1.ebuild
@@ -0,0 +1,118 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+# Regarding licenses: libgarglk is licensed under the GPLv2. Bundled
+# interpreters are licensed under GPLv2, BSD or MIT license, except:
+# - glulxe: custom license, see "terps/glulxle/README"
+# - hugo: custom license, see "licenses/HUGO License.txt"
+# Since we don't compile or install any of the bundled fonts, their licenses
+# don't apply. (Fonts are installed through dependencies instead.)
+
+EAPI=6
+inherit eutils flag-o-matic gnome2-utils multilib multiprocessing toolchain-funcs
+
+DESCRIPTION="An Interactive Fiction (IF) player supporting all major formats"
+HOMEPAGE="http://ccxvii.net/gargoyle/"
+SRC_URI="https://garglk.googlecode.com/files/${P}-sources.zip"
+
+LICENSE="BSD GPL-2 MIT Hugo Glulxe"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="
+ media-fonts/libertine
+ media-fonts/liberation-fonts
+ media-libs/freetype:2
+ media-libs/libpng:0
+ media-libs/sdl-mixer
+ media-libs/sdl-sound[modplug,mp3,vorbis]
+ sys-libs/zlib
+ virtual/jpeg:0
+ x11-libs/gtk+:2"
+DEPEND="${RDEPEND}
+ app-arch/unzip
+ dev-util/ftjam
+ virtual/pkgconfig"
+
+S=${WORKDIR}
+
+src_prepare() {
+ # Substitute custom CFLAGS/LDFLAGS.
+ sed -i -e \
+ "/^\s*OPTIM = / {
+ s/ \(-O.*\)\? ;/ ;/
+ a LINKFLAGS = ${LDFLAGS} ;
+ a SHRLINKFLAGS = ${LDFLAGS} ;
+ }" Jamrules || die
+
+ # Don't link against libraries used indirectly through SDL_sound.
+ sed -i -e "/GARGLKLIBS/s/-lsmpeg -lvorbisfile//g" Jamrules || die
+
+ # Convert garglk.ini to UNIX format.
+ edos2unix garglk/garglk.ini
+
+ epatch "${FILESDIR}"/${P}-desktopfile.patch
+ append-cflags -std=gnu89 # build with gcc5 (bug #573378)
+ append-cxxflags -std=gnu++11 # code assumes C++11 semantics (bug #642996)
+ default
+}
+
+src_compile() {
+ # build system messes up flags and toolchain completely
+ # append flags to compiler commands to have consistent behavior
+ jam \
+ -sAR="$(tc-getAR) cru" \
+ -sCC="$(tc-getCC) ${CFLAGS}" \
+ -sCCFLAGS="" \
+ -sC++="$(tc-getCXX) ${CXXFLAGS}" \
+ -sCXX="$(tc-getCXX) ${CXXFLAGS}" \
+ -sC++FLAGS="" \
+ -sGARGLKINI="/etc/garglk.ini" \
+ -sUSESDL=yes \
+ -sBUNDLEFONTS=no \
+ -dx \
+ -j$(makeopts_jobs) || die
+}
+
+src_install() {
+ DESTDIR="${D}" \
+ _BINDIR="/usr/libexec/${PN}" \
+ _APPDIR="/usr/libexec/${PN}" \
+ _LIBDIR="/usr/$(get_libdir)" \
+ EXEMODE=755 \
+ FILEMODE=755 \
+ jam install || die
+
+ # Install config file.
+ insinto "/etc"
+ newins garglk/garglk.ini garglk.ini
+
+ # Install application entry and icon.
+ domenu garglk/${PN}.desktop
+ doicon -s 32 garglk/${PN}-house.png
+
+ # Symlink binaries to avoid name clashes.
+ for terp in advsys agility alan2 alan3 frotz geas git glulxe hugo jacl \
+ level9 magnetic nitfol scare tadsr
+ do
+ dosym "../libexec/${PN}/${terp}" \
+ "/usr/bin/${PN}-${terp}"
+ done
+
+ # Also symlink the main binary since it resides in libexec.
+ dosym "../libexec/${PN}/${PN}" \
+ "/usr/bin/${PN}"
+}
+
+pkg_preinst() {
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}
diff --git a/games-engines/gargoyle/metadata.xml b/games-engines/gargoyle/metadata.xml
new file mode 100644
index 000000000000..6842fdda8f83
--- /dev/null
+++ b/games-engines/gargoyle/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>games@gentoo.org</email>
+ <name>Gentoo Games Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="google-code">garglk</remote-id>
+ </upstream>
+</pkgmetadata>