summaryrefslogtreecommitdiff
path: root/games-emulation/vbam/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-01-16 17:34:21 +0000
committerV3n3RiX <venerix@redcorelinux.org>2018-01-16 17:34:21 +0000
commit02e2208f46f4e2c00fb9743cbc47350bdd233bfa (patch)
tree132dd60828854db4f65f30f9230f43d9602507ff /games-emulation/vbam/files
parent8be70107efbb417f839292165ee39d07a062046f (diff)
gentoo resync : 16.01.2018
Diffstat (limited to 'games-emulation/vbam/files')
-rw-r--r--games-emulation/vbam/files/vbam-2.0.1-changelog-update.patch98
-rw-r--r--games-emulation/vbam/files/vbam-2.0.1-read-version-from-changelog.patch76
2 files changed, 174 insertions, 0 deletions
diff --git a/games-emulation/vbam/files/vbam-2.0.1-changelog-update.patch b/games-emulation/vbam/files/vbam-2.0.1-changelog-update.patch
new file mode 100644
index 000000000000..6d4f87f2d772
--- /dev/null
+++ b/games-emulation/vbam/files/vbam-2.0.1-changelog-update.patch
@@ -0,0 +1,98 @@
+From 30b6ecf1a5c0eac73aaf3dabd98e41c908daa94a Mon Sep 17 00:00:00 2001
+From: Zach Bacon <zachbacon@budgiemedia.rocks>
+Date: Thu, 12 Oct 2017 00:49:05 +0000
+Subject: [PATCH] Add a changelog
+
+Gonna try and keep this up to date as often as possible.
+---
+ CHANGELOG.md | 81 ++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++
+ 1 file changed, 81 insertions(+)
+ create mode 100644 CHANGELOG.md
+
+diff --git a/CHANGELOG.md b/CHANGELOG.md
+new file mode 100644
+index 00000000..c24ac560
+--- /dev/null
++++ b/CHANGELOG.md
+@@ -0,0 +1,81 @@
++# Changelog
++All notable changes to this project will be documented in this file.
++
++The format is based on [Keep a Changelog](http://keepachangelog.com/en/1.0.0/)
++and this project adheres to [Semantic Versioning](http://semver.org/spec/v2.0.0.html).
++
++## [Unreleased]
++
++## [2.0.1] - 10/11/2017
++### Added
++- initial installer script
++- gitter.im badge in readme
++- 32bit cross compiling support on 64bit linux
++- added support for GNUInstallDirs to cmake
++- Include new translations from transifex
++- Added WxWidgets ABI compiler check
++- Add linux Joystick reference to issue template
++- Add #ubckyde <cmath> fir std::cell()
++-
++
++### Changed
++- Fix 2xSaImmx.asm linking issue
++- cmake: default to ENABLE_ASM_CORE=OFF
++- libretro merging from upstream libretro fork.
++- better fix for clipped video in GL Fullscreen.
++- Fix flibc crash: add log message on fopen failure
++- fix gameboy header-detection in libretro interface
++- hotfix for potential buffer-overflow
++- delete memory in common/array.h on destruction
++- SDL: improve error msg for unwritable config
++- SDL: fix deflt bat saving, improve dir checking
++- fix portability issue with strerror_r()
++- Windows doesn't have sterror_r
++- wx/wxvbam: fix GetAbsolutePath
++- fix a memory leak due to wrong syntax
++- regenerate translation files
++- fix errors reported by SUSE's post build linter
++- SUSE Lint: fix a few classes of warnings
++- let cmake escape -D preproc. definitions
++- fix memory viewer xrc on wx 3.1+
++- Improving README
++- SoundSDL: lock conditional code cleanup
++- remove the default F11 keybinding for save state
++- hopefully fix resize artifacts on game panel
++- soundSDL: write silence when paused
++- cleanup SoundSDL #139 #130 #97 #67 #65 #46 #47
++- document how to provice symbolic backtraces
++- "no throttle" fixes/cleanup
++- only use -mtune=generic on x86/amd64
++- installdeps: use -j$(nproc) not -j8 in info
++- use -fabi-version=2 for GCC turn off LTO
++- installdeps: minor refactoring/cleanup
++- improve Wx GCC ABI check
++- minor improvements for Wx Compile tests
++- fix wx ABI check for Win32/MinGW
++- installdeps: fedora fixes, including m32
++- cmake: wx and cross compiling fixes
++- restore wx 2.7 compat, improve string processing
++- rename CMakeScripts/ to cmake/
++- work around gcc lto wrappers bug with gcc 7.x
++- update README.md
++- remove doctoc title from README.md TOC
++- improve win32 dependencies git submodule handling
++- use num cpu cores to parallelize LTO link with gcc
++- fix huge app icon in Win volume settings
++- fix deadlock in SoundSDL:deinit()
++- added executable extension for sdl binary
++- default LTO to off on 64bit MinGW
++- minor code cleanup
++- deps: dont check result of apt-get update
++- read version and subversion info from Git
++- fix error and version info in shallow git clones
++- refactor/cleanup GitTagVersion.cmake
++
++### Removed
++- Cairo Renderer: it never performed well to begin with
++
++
++
++[2.0.1]: https://github.com/olivierlacan/keep-a-changelog/compare/throttle...v2.0.1
++
diff --git a/games-emulation/vbam/files/vbam-2.0.1-read-version-from-changelog.patch b/games-emulation/vbam/files/vbam-2.0.1-read-version-from-changelog.patch
new file mode 100644
index 000000000000..5dce58395343
--- /dev/null
+++ b/games-emulation/vbam/files/vbam-2.0.1-read-version-from-changelog.patch
@@ -0,0 +1,76 @@
+From 46486381f0c18110002ec62108969be957b419be Mon Sep 17 00:00:00 2001
+From: Rafael Kitover <rkitover@gmail.com>
+Date: Wed, 11 Oct 2017 19:17:25 -0700
+Subject: [PATCH] read version info from CHANGELOG.md if no git
+
+If git tags are not available, set the version and revision by finding
+the first version tag in `CHANGELOG.md` of the form
+
+```
+```
+
+Where N.N.N is the number version (number of components can vary) and
+the revision (as speicified by -REV) is optional.
+
+TODO: support named revision without a version number of the form
+`[REV]`.
+---
+ CMakeLists.txt | 9 +++------
+ cmake/ChangeLogVersion.cmake | 25 +++++++++++++++++++++++++
+ 2 files changed, 28 insertions(+), 6 deletions(-)
+ create mode 100644 cmake/ChangeLogVersion.cmake
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index bd09527d..4ad859b2 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -112,15 +112,12 @@ if(GIT_FOUND AND EXISTS "${CMAKE_SOURCE_DIR}/.git")
+ # of files that depend on version.h
+ include(GetGitRevisionDescription)
+ get_git_head_revision(REFSPEC COMMITHASH)
+-else()
+- message(WARNING "Git not found, cannot set version info")
+ endif()
+
+-# no git or no tags
++# no git or no tags, use ChangeLog
+ if(NOT VERSION)
+- set(VERSION 2.0.0)
+- set(REVISION "unknown")
+- set(VERSION_RELEASE 0)
++ include(ChangeLogVersion)
++ changelog_version(VERSION REVISION VERSION_RELEASE)
+ endif()
+
+ # generate version.h
+diff --git a/cmake/ChangeLogVersion.cmake b/cmake/ChangeLogVersion.cmake
+new file mode 100644
+index 00000000..101d23bd
+--- /dev/null
++++ b/cmake/ChangeLogVersion.cmake
+@@ -0,0 +1,25 @@
++function(changelog_version version revision version_release)
++ set(${version} "" CACHE STRING "Latest ChangeLog Version" FORCE)
++ set(${revision} "" CACHE STRING "Latest ChangeLog Revision" FORCE)
++ set(${version_release} 0 CACHE STRING "Is this a versioned release without revision" FORCE)
++
++ file(READ CHANGELOG.md changelog_file)
++
++ if(NOT changelog_file)
++ return()
++ endif()
++
++ string(REGEX MATCH "\n## +\\[([0-9.]+)(-([^] ]+))?\\] +- +[0-9][0-9]?/" match_out "${changelog_file}")
++
++ set(changelog_version "${CMAKE_MATCH_1}")
++
++ set(is_version_release 0)
++ set(changelog_revision "${CMAKE_MATCH_3}")
++ if(NOT changelog_revision)
++ set(is_version_release 1)
++ endif()
++
++ set(${version} "${changelog_version}" CACHE STRING "Latest ChangeLog Version" FORCE)
++ set(${revision} "${changelog_revision}" CACHE STRING "Latest ChangeLog Revision" FORCE)
++ set(${version_release} "${is_version_release}" CACHE STRING "Is this a versioned release without revision" FORCE)
++endfunction()