summaryrefslogtreecommitdiff
path: root/games-emulation/sameboy-jg/sameboy-jg-0.16.5.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-06-19 00:09:54 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-06-19 00:09:54 +0100
commite8df704cf9b5e9e517317b8912377c0a8ca0d11e (patch)
treeab3f43045fb1d37471f8217c8547d2120bb3d1da /games-emulation/sameboy-jg/sameboy-jg-0.16.5.ebuild
parentccaccfe4f1da8c11d9fa110f6e4eb847358769d7 (diff)
gentoo auto-resync : 19:06:2024 - 00:09:54
Diffstat (limited to 'games-emulation/sameboy-jg/sameboy-jg-0.16.5.ebuild')
-rw-r--r--games-emulation/sameboy-jg/sameboy-jg-0.16.5.ebuild49
1 files changed, 49 insertions, 0 deletions
diff --git a/games-emulation/sameboy-jg/sameboy-jg-0.16.5.ebuild b/games-emulation/sameboy-jg/sameboy-jg-0.16.5.ebuild
new file mode 100644
index 000000000000..c41503e9640a
--- /dev/null
+++ b/games-emulation/sameboy-jg/sameboy-jg-0.16.5.ebuild
@@ -0,0 +1,49 @@
+# Copyright 2022-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+MY_PN=${PN%-*}
+MY_P=${MY_PN}-${PV}
+DESCRIPTION="Jolly Good Port of SameBoy"
+HOMEPAGE="https://gitlab.com/jgemu/sameboy"
+if [[ "${PV}" == *9999 ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://gitlab.com/jgemu/${MY_PN}.git"
+else
+ SRC_URI="https://gitlab.com/jgemu/${MY_PN}/-/archive/${PV}/${MY_P}.tar.bz2"
+ S="${WORKDIR}/${MY_P}"
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
+fi
+
+LICENSE="MIT"
+SLOT="1"
+
+DEPEND="
+ media-libs/jg:1=
+"
+RDEPEND="
+ ${DEPEND}
+ games-emulation/jgrf
+"
+BDEPEND="
+ >=dev-util/rgbds-0.6.0
+ virtual/pkgconfig
+"
+
+src_compile() {
+ emake -C jollygood \
+ CC="$(tc-getCC)" \
+ CC_FOR_BUILD="$(tc-getBUILD_CC)" \
+ PKG_CONFIG="$(tc-getPKG_CONFIG)"
+}
+
+src_install() {
+ emake -C jollygood install \
+ DESTDIR="${D}" \
+ PREFIX="${EPREFIX}"/usr \
+ DOCDIR="${EPREFIX}"/usr/share/doc/${PF} \
+ LIBDIR="${EPREFIX}/usr/$(get_libdir)"
+}