summaryrefslogtreecommitdiff
path: root/games-emulation/ppsspp/files/ppsspp-1.17.1-ccache-18826.patch
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-02-05 17:43:10 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-02-05 17:43:10 +0000
commitc31f575f39c1e387f18f630fb01d3a89c2339fdf (patch)
treed6db6ce35cd0849abe99eccd07d0f86a1aa82025 /games-emulation/ppsspp/files/ppsspp-1.17.1-ccache-18826.patch
parent34d05d15811bd789a5348824d4f4151a49f924c9 (diff)
gentoo auto-resync : 05:02:2024 - 17:43:10
Diffstat (limited to 'games-emulation/ppsspp/files/ppsspp-1.17.1-ccache-18826.patch')
-rw-r--r--games-emulation/ppsspp/files/ppsspp-1.17.1-ccache-18826.patch33
1 files changed, 33 insertions, 0 deletions
diff --git a/games-emulation/ppsspp/files/ppsspp-1.17.1-ccache-18826.patch b/games-emulation/ppsspp/files/ppsspp-1.17.1-ccache-18826.patch
new file mode 100644
index 000000000000..af5478f1bf73
--- /dev/null
+++ b/games-emulation/ppsspp/files/ppsspp-1.17.1-ccache-18826.patch
@@ -0,0 +1,33 @@
+From e1ef901fcc2f0acbdff2671a8e07edab3e473c98 Mon Sep 17 00:00:00 2001
+From: Andrew Udvare <audvare@gmail.com>
+Date: Sun, 4 Feb 2024 18:39:18 -0500
+Subject: [PATCH] Add option to disable ccache detection
+
+---
+ CMakeLists.txt | 6 +++++-
+ 1 file changed, 5 insertions(+), 1 deletion(-)
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index bfd5e690353e..33570d09c024 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -116,7 +116,6 @@ if(NOT IOS)
+ list(APPEND CMAKE_MODULE_PATH ${CMAKE_SOURCE_DIR}/cmake/sdl)
+ endif()
+
+-include(ccache)
+ include(GNUInstallDirs)
+
+ add_definitions(-DASSETS_DIR="${CMAKE_INSTALL_FULL_DATADIR}/ppsspp/assets/")
+@@ -173,6 +172,11 @@ option(USE_SYSTEM_ZSTD "Dynamically link against system zstd" ${USE_SYSTEM_ZSTD}
+ option(USE_SYSTEM_MINIUPNPC "Dynamically link against system miniUPnPc" ${USE_SYSTEM_MINIUPNPC})
+ option(USE_ASAN "Use address sanitizer" OFF)
+ option(USE_UBSAN "Use undefined behaviour sanitizer" OFF)
++option(USE_CCACHE "Use ccache if detected" ON)
++
++if(USE_CACHE)
++ include(ccache)
++endif()
+
+ if(UNIX AND NOT (APPLE OR ANDROID) AND VULKAN)
+ if(USING_X11_VULKAN)