summaryrefslogtreecommitdiff
path: root/games-emulation/pcsx2/pcsx2-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-04-26 23:59:37 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-04-26 23:59:37 +0100
commit3e42d1577189af123b773dc0f11e5419035308c8 (patch)
tree95d77507c924544b12363e6da6aa741c444f3e8a /games-emulation/pcsx2/pcsx2-9999.ebuild
parent6243676c91946098c06d42bc87b5eb99aac40bf0 (diff)
gentoo auto-resync : 26:04:2024 - 23:59:36
Diffstat (limited to 'games-emulation/pcsx2/pcsx2-9999.ebuild')
-rw-r--r--games-emulation/pcsx2/pcsx2-9999.ebuild16
1 files changed, 14 insertions, 2 deletions
diff --git a/games-emulation/pcsx2/pcsx2-9999.ebuild b/games-emulation/pcsx2/pcsx2-9999.ebuild
index 5c49263139b5..69486b68cc68 100644
--- a/games-emulation/pcsx2/pcsx2-9999.ebuild
+++ b/games-emulation/pcsx2/pcsx2-9999.ebuild
@@ -3,7 +3,7 @@
EAPI=8
-inherit cmake desktop fcaps flag-o-matic toolchain-funcs
+inherit cmake desktop fcaps flag-o-matic optfeature toolchain-funcs
if [[ ${PV} == 9999 ]]; then
inherit git-r3
@@ -113,8 +113,14 @@ src_configure() {
-DUSE_LINKED_FFMPEG=yes
-DUSE_VTUNE=no
-DUSE_VULKAN=$(usex vulkan)
+
+ # note that upstream hardly support native wayland, may or may not work
+ # https://github.com/PCSX2/pcsx2/pull/10179
-DWAYLAND_API=$(usex wayland)
- -DX11_API=yes # X libs are currently hard-required either way
+ # not optional given libX11 is hard-required either way and upstream
+ # seemingly has no intention to drop the requirement at the moment
+ # https://github.com/PCSX2/pcsx2/issues/11149
+ -DX11_API=yes
# not packaged due to bug #885471, but still disable for no automagic
-DCMAKE_DISABLE_FIND_PACKAGE_Libbacktrace=yes
@@ -152,6 +158,12 @@ src_install() {
pkg_postinst() {
fcaps -m 0755 cap_net_admin,cap_net_raw=eip usr/lib/${PN}/pcsx2-qt
+ # calls aplay or gst-play/launch-1.0 as fallback
+ # https://github.com/PCSX2/pcsx2/issues/11141
+ optfeature "UI sound effects support" \
+ media-sound/alsa-utils \
+ media-libs/gst-plugins-base:1.0
+
if [[ ${REPLACING_VERSIONS##* } ]] &&
ver_test ${REPLACING_VERSIONS##* } -lt 1.7; then
elog ">=${PN}-1.7 has received several changes since <=${PN}-1.6.0, and is"