summaryrefslogtreecommitdiff
path: root/games-emulation/openmsx
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-07-09 15:43:36 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-07-09 15:43:36 +0100
commit2719f73b6813d11d13a9650cdd2ab8ec6e69385d (patch)
tree8c816148bcbd22757d892089c989ae614eae4f5a /games-emulation/openmsx
parent0f558761aa2dee1017b4751e4017205e015a9560 (diff)
gentoo resync : 09.07.2022
Diffstat (limited to 'games-emulation/openmsx')
-rw-r--r--games-emulation/openmsx/Manifest2
-rw-r--r--games-emulation/openmsx/openmsx-18.0-r1.ebuild113
2 files changed, 115 insertions, 0 deletions
diff --git a/games-emulation/openmsx/Manifest b/games-emulation/openmsx/Manifest
index 67f919db52fd..115feb36c2ff 100644
--- a/games-emulation/openmsx/Manifest
+++ b/games-emulation/openmsx/Manifest
@@ -1,3 +1,5 @@
DIST openmsx-17.0.tar.gz 4045461 BLAKE2B 46c70ce3f853aecebf8bdeddc5786903634d88d013497383490d79b0dbf455f48a70b3658b9913db197cf7e66cbc6f4da37da58b1b24d77c75b731e842c663df SHA512 4fc87efd2bfbcd12bebb4e005b18b1cb2048f5d8f3188ef9b55f1e003c8d021fb47bd67d647137daa6a8640b5656b0db363f3b62158d690ddb5f7bf1af3459e1
+DIST openmsx-18.0.tar.gz 4151084 BLAKE2B 0d5b4e4745c12689e4227408481367b4b4faaa4c7c2830ec0c4b9a5eb90c4b415628cd21834384d39fa4a820c725431848e98f7ef722c437f7bb4f96ae7b14c4 SHA512 f395fae8eac3bcb9334251c1c266a8c4d2951d6510a7c4885ddbc95aaed39f4ef8ae12a177d4a9ff44745ca368055f55f9983029b47441f4fd9731696f79809f
EBUILD openmsx-17.0.ebuild 2882 BLAKE2B 2aa8a567b5080dd487b9c7c69138df9acf2e3523fe57a57d5cfa74a7659028d1d8eba3aaa04696f941865c8878f175b8bc8249dda1dc5884b61a959c6dc12834 SHA512 4ce326368598aa63b83eb8da63f6f4f5250f4b8c5ba2bc078e4c2fbaaa26a14b9b261885e729c1f16d152fb66ec37c9a4fc36e5200acbde404c9659e824aa896
+EBUILD openmsx-18.0-r1.ebuild 2904 BLAKE2B 127580092641849cb6c0c06dff3c5e4f440f8b0ce23cf4129ed9eb57dd0d1f9540530df69d7d8f62bb44dfa287514175c9d69894e0243e2d48201b6c422f9e0c SHA512 a93334f586608e408e5867eed271a80708f94d356afa0559c606881ef689326af2d9d81bf7f857f95dac097e22a2cb40f98b19fec9dbe8d43e1f8b8825b1d39a
MISC metadata.xml 442 BLAKE2B 579f3b84332385ce6f79c1f927bb3d4b1b112954695bd30425849946ec3994158a855fc9dbff8407775ad532a105e518ba30b4e72f3e42d3b64e2cadffaa9220 SHA512 a24a4c4cef293439f8ea46ad1261507160ea5024cbc53947915e6306a1356d5682440fa1eb230a98e715214c53024fa7ffe4aa97f1bb3f385c66c1ee69b8323f
diff --git a/games-emulation/openmsx/openmsx-18.0-r1.ebuild b/games-emulation/openmsx/openmsx-18.0-r1.ebuild
new file mode 100644
index 000000000000..74a4c7604b70
--- /dev/null
+++ b/games-emulation/openmsx/openmsx-18.0-r1.ebuild
@@ -0,0 +1,113 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{9,10,11} )
+
+inherit desktop flag-o-matic python-any-r1 readme.gentoo-r1 toolchain-funcs xdg
+
+DESCRIPTION="MSX emulator that aims for perfection"
+HOMEPAGE="https://openmsx.org/"
+SRC_URI="https://github.com/openMSX/openMSX/releases/download/RELEASE_${PV//./_}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+joystick"
+
+RDEPEND="dev-lang/tcl:0=
+ media-libs/alsa-lib
+ media-libs/harfbuzz:=
+ media-libs/libogg
+ media-libs/libpng:0=
+ media-libs/libsdl2[joystick=,sound,video]
+ media-libs/libtheora
+ media-libs/libvorbis
+ media-libs/sdl2-ttf
+ >=media-libs/glew-1.3.2:0=
+ sys-libs/zlib
+ virtual/opengl"
+DEPEND="${RDEPEND}"
+BDEPEND="${PYTHON_DEPS}"
+
+DOC_CONTENTS="
+If you want to if you want to emulate real MSX systems and not
+only the free C-BIOS machines, put the system ROMs in one of
+the following directories: /usr/share/${PN}/systemroms
+or ~/.openMSX/share/systemroms
+"
+
+src_prepare() {
+ default
+ sed -i \
+ -e '/^LDFLAGS:=/d' \
+ -e '/LINK_FLAGS_PREFIX/d' \
+ -e '/LINK_FLAGS+=/s/-s//' \
+ -e '/LINK_FLAGS+=\$(TARGET_FLAGS)/s/$/ $(LDFLAGS)/' \
+ build/main.mk \
+ || die
+ sed -i -e '/SYMLINK/s:true:false:' build/custom.mk || die
+ sed -i -e 's/GPL.txt//' doc/node.mk || die
+
+ # Build system only configured to use bundled version - but not from the
+ # directory it's distributed in
+ cp "${S}/Contrib/catch2/catch.hpp" "${S}/src/unittest" || die
+}
+
+src_configure() {
+ tc-export CXX
+
+ # Doesn't compile without this, and build system doesn't consistently add
+ # it properly for all compilers
+ append-cxxflags '-std=c++17'
+
+ default
+}
+
+src_compile() {
+ emake \
+ CXXFLAGS="${CXXFLAGS}" \
+ INSTALL_SHARE_DIR="${EPREFIX}/usr/share/${PN}" \
+ V=1
+}
+
+src_test() {
+ # To get tests, we need to build with OPENMSX_FLAVOUR=unittest and then the
+ # build is stored in a directory of the pattern
+ # ${WORKDIR}/derived/*-unittest/. This is separate from the actual build,
+ # stored in ${WORKDIR}/derived/*-opt. The unittest binary and the workdir
+ # binary are in each of these directories under their `bin` directories.
+ emake \
+ V=1 \
+ CXXFLAGS="${CXXFLAGS}" \
+ OPENMSX_FLAVOUR=unittest
+
+ # There will only ever be one *-unittest directory
+ "${S}"/derived/*-unittest/bin/openmsx || die
+}
+
+src_install() {
+ # To guarantee installing the proper binary in case tests were built,
+ # specify the default OPENMSX_FLAVOUR
+ emake \
+ V=1 \
+ INSTALL_BINARY_DIR="${ED}/usr/bin" \
+ INSTALL_SHARE_DIR="${ED}/usr/share/${PN}" \
+ INSTALL_DOC_DIR="${ED}/usr/share/doc/${PF}" \
+ OPENMSX_FLAVOUR=opt \
+ install
+
+ einstalldocs
+ readme.gentoo_create_doc
+
+ for i in 16 32 48 64 128 256 ; do
+ newicon -s "${i}" "share/icons/openMSX-logo-${i}.png" "${PN}.png"
+ done
+ make_desktop_entry "${PN}" "openMSX"
+}
+
+pkg_postinst() {
+ readme.gentoo_print_elog
+ xdg_pkg_postinst
+}