summaryrefslogtreecommitdiff
path: root/games-emulation/mupen64plus-audio-sdl
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /games-emulation/mupen64plus-audio-sdl
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'games-emulation/mupen64plus-audio-sdl')
-rw-r--r--games-emulation/mupen64plus-audio-sdl/Manifest3
-rw-r--r--games-emulation/mupen64plus-audio-sdl/metadata.xml11
-rw-r--r--games-emulation/mupen64plus-audio-sdl/mupen64plus-audio-sdl-2.5.ebuild84
3 files changed, 98 insertions, 0 deletions
diff --git a/games-emulation/mupen64plus-audio-sdl/Manifest b/games-emulation/mupen64plus-audio-sdl/Manifest
new file mode 100644
index 000000000000..5178a9a602a2
--- /dev/null
+++ b/games-emulation/mupen64plus-audio-sdl/Manifest
@@ -0,0 +1,3 @@
+DIST mupen64plus-audio-sdl-src-2.5.tar.gz 26147 BLAKE2B bcd0c76d1e4fffb55940889c329574760101177c7cc48bb6ea9a361be01515ec15261bf1254a8c605db2ebf8166d323b43620e8f7c978cc79603be3ad537a191 SHA512 0c63e16449c40f15abdeed968383a218ed9876a92b2c15cbeb6554b20008d6d12996c0fd3bc1c502084791596b8535340596e95a11fe5d27576342740e76db6a
+EBUILD mupen64plus-audio-sdl-2.5.ebuild 1959 BLAKE2B bbc720d2b448e7c9894d8decc0c47e4695cc3c8d6f655f8fc664d8672e8972cb1277a696c5875b02a0d21b8af4c3460f7b3a26b4788c7ce3425402c547a93bf2 SHA512 4dcc0513f5f40de0d0a0603b3c391b827f78fc217ea255c8c4378c41dfe82c8f6efc5c7533fc18c9c54489a8639211f95804c6f1c747e73aeafca8c758ac56fb
+MISC metadata.xml 345 BLAKE2B b5b03b304e1491135b6d30001afe6bd57e29873222bb41cbb4d9d47fd77be1581544139cf4800ad4f15afb4cbd0b9da167b2a6cb3242a2ce0e0689b7b88e6c1c SHA512 f6e02ffd8784ef686cea561d75bac4a5f231fa62e72a089380707663a738e3d10b1f134cce40cc8d60e36cf90ab9303971996b16797253f6509960873e787f2d
diff --git a/games-emulation/mupen64plus-audio-sdl/metadata.xml b/games-emulation/mupen64plus-audio-sdl/metadata.xml
new file mode 100644
index 000000000000..98ab28b06ff8
--- /dev/null
+++ b/games-emulation/mupen64plus-audio-sdl/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>mgorny@gentoo.org</email>
+ <name>Michał Górny</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">mupen64plus/mupen64plus-audio-sdl</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/games-emulation/mupen64plus-audio-sdl/mupen64plus-audio-sdl-2.5.ebuild b/games-emulation/mupen64plus-audio-sdl/mupen64plus-audio-sdl-2.5.ebuild
new file mode 100644
index 000000000000..9ddb524fc2d5
--- /dev/null
+++ b/games-emulation/mupen64plus-audio-sdl/mupen64plus-audio-sdl-2.5.ebuild
@@ -0,0 +1,84 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+MY_P=${PN}-src-${PV}
+inherit eutils multilib toolchain-funcs
+
+DESCRIPTION="A fork of Mupen64 Nintendo 64 emulator, SDL audio plugin"
+HOMEPAGE="http://www.mupen64plus.org/"
+SRC_URI="https://github.com/mupen64plus/${PN}/releases/download/${PV}/${MY_P}.tar.gz"
+
+LICENSE="GPL-2 LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="libsamplerate oss speex"
+
+RDEPEND=">=games-emulation/mupen64plus-core-2.5:0=
+ media-libs/libsdl2:0=[sound]
+ libsamplerate? ( media-libs/libsamplerate:0= )
+ speex? ( media-libs/speex:0= )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+S=${WORKDIR}/${MY_P}
+
+src_prepare() {
+ epatch_user
+
+ # avoid implicitly appending CPU flags
+ sed -i -e 's:-mmmx::g' -e 's:-msse::g' projects/unix/Makefile || die
+}
+
+src_compile() {
+ MAKEARGS=(
+ # Note: please keep this in sync in all of mupen64plus-* packages
+
+ -C projects/unix
+
+ # this basically means: GNU userspace
+ UNAME=Linux
+
+ # verbose output
+ V=1
+
+ CROSS_COMPILE="${CHOST}-"
+ CC="$(tc-getCC)"
+ CXX="$(tc-getCXX)"
+ PKG_CONFIG="$(tc-getPKG_CONFIG)"
+ # usual CFLAGS, CXXFLAGS and LDFLAGS are respected
+ # so we can leave OPTFLAGS empty
+ OPTFLAGS=
+
+ # paths, some of them are used at compile time
+ PREFIX=/usr
+ LIBDIR=/usr/$(get_libdir)
+
+ # disable unwanted magic
+ LDCONFIG=:
+ INSTALL_STRIP_FLAG=
+
+ # Package-specific stuff
+
+ # CROSS_COMPILE causes it to look for ${CHOST}-sdl2-config...
+ SDL_CFLAGS="$($(tc-getPKG_CONFIG) --cflags sdl2)"
+ SDL_LDLIBS="$($(tc-getPKG_CONFIG) --libs sdl2)"
+
+ NO_SPEEX=$(usex speex 0 1)
+ NO_SRC=$(usex libsamplerate 0 1)
+ NO_OSS=$(usex oss 0 1)
+ # not packaged (https://github.com/nemomobile/libaudioresource)
+ USE_AUDIORESOURCE=0
+ )
+
+ use amd64 && MAKEARGS+=( HOST_CPU=x86_64 )
+ use x86 && MAKEARGS+=( HOST_CPU=i386 )
+
+ emake "${MAKEARGS[@]}" all
+}
+
+src_install() {
+ emake "${MAKEARGS[@]}" DESTDIR="${D}" install
+ einstalldocs
+}