summaryrefslogtreecommitdiff
path: root/games-emulation/libretro-info/libretro-info-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-08-25 07:36:27 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-08-25 07:36:27 +0100
commit43793fab84041cfc5c60c0151d1591b8a69fb24a (patch)
tree6208a7f4fc744684fce0f55acbb47511acace498 /games-emulation/libretro-info/libretro-info-9999.ebuild
parent28e3d252dc8ac8a5635206dfefe1cfe05058d1db (diff)
gentoo resync : 25.08.2018
Diffstat (limited to 'games-emulation/libretro-info/libretro-info-9999.ebuild')
-rw-r--r--games-emulation/libretro-info/libretro-info-9999.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/games-emulation/libretro-info/libretro-info-9999.ebuild b/games-emulation/libretro-info/libretro-info-9999.ebuild
new file mode 100644
index 000000000000..03ae3ee399fb
--- /dev/null
+++ b/games-emulation/libretro-info/libretro-info-9999.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Libretro info files required for libretro cores"
+HOMEPAGE="https://github.com/libretro/libretro-super"
+
+if [[ ${PV} == *9999 ]]; then
+ SRC_URI=""
+ EGIT_REPO_URI="https://github.com/libretro/libretro-super.git"
+ inherit git-r3
+else
+ COMMIT="dfa0eaaa804552712baaff5553df3eea989fc5d5"
+ SRC_URI="https://github.com/libretro/libretro-super/archive/${COMMIT}.tar.gz -> ${P}.tar.gz"
+ S="${WORKDIR}/libretro-super-${COMMIT}"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="GPL-3"
+SLOT="0"
+
+src_compile() {
+ :
+}
+
+src_install() {
+ insinto "/usr/share/libretro/info"
+ doins dist/info/*.info
+}