summaryrefslogtreecommitdiff
path: root/games-emulation/hatari/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-05-13 00:01:18 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-05-13 00:01:18 +0100
commita25cc082a26782e5d39ded4559c91ff11bc3c299 (patch)
tree6cd0802dd248058d540f1f5f472c5df98216f154 /games-emulation/hatari/files
parentd72a987a342949e200b5e9decbd71f246da53788 (diff)
gentoo auto-resync : 13:05:2024 - 00:01:18
Diffstat (limited to 'games-emulation/hatari/files')
-rw-r--r--games-emulation/hatari/files/adccd68b16eff815590c1ec993354ef8e752ecfd.patch36
-rw-r--r--games-emulation/hatari/files/hatari-2.3.1-cmake-include-checksym.patch12
2 files changed, 0 insertions, 48 deletions
diff --git a/games-emulation/hatari/files/adccd68b16eff815590c1ec993354ef8e752ecfd.patch b/games-emulation/hatari/files/adccd68b16eff815590c1ec993354ef8e752ecfd.patch
deleted file mode 100644
index d8623cb4d66b..000000000000
--- a/games-emulation/hatari/files/adccd68b16eff815590c1ec993354ef8e752ecfd.patch
+++ /dev/null
@@ -1,36 +0,0 @@
-From adccd68b16eff815590c1ec993354ef8e752ecfd Mon Sep 17 00:00:00 2001
-From: Thomas Huth <huth@tuxfamily.org>
-Date: Thu, 21 Dec 2023 14:33:19 +0100
-Subject: [PATCH] Fix compiler warning that occurs with link-time optimization
-
-With LTO enable, the build fails with:
-
- [100%] Linking C executable hatari
- .../src/cpu/savestate.h:281:14: error: type of 'savestate_fname' does not
- match original declaration [-Werror=lto-type-mismatch]
- 281 | extern TCHAR savestate_fname[MAX_DPATH];
- | ^
- .../src/cpu/custom.c:40:8: note:
- 'savestate_fname' was previously declared here
- 40 | TCHAR *savestate_fname;
- | ^
- lto1: all warnings being treated as errors
-
-Declare the array according to the definition in the header file to fix it.
----
- src/cpu/custom.c | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/src/cpu/custom.c b/src/cpu/custom.c
-index 15971ceff..aff0c0253 100644
---- a/src/cpu/custom.c
-+++ b/src/cpu/custom.c
-@@ -37,7 +37,7 @@ extern struct regstruct mmu_backup_regs;
- evt_t currcycle;
- /* declared in savestate.h */
- int savestate_state = 0;
--TCHAR *savestate_fname;
-+TCHAR savestate_fname[MAX_DPATH];
- /* declared in custom.h */
- uae_u32 hsync_counter = 0, vsync_counter = 0;
- #endif
diff --git a/games-emulation/hatari/files/hatari-2.3.1-cmake-include-checksym.patch b/games-emulation/hatari/files/hatari-2.3.1-cmake-include-checksym.patch
deleted file mode 100644
index 39da11ea307d..000000000000
--- a/games-emulation/hatari/files/hatari-2.3.1-cmake-include-checksym.patch
+++ /dev/null
@@ -1,12 +0,0 @@
-Fix edge case build failure triggered by passing every
-DISABLE_FIND_PACKAGE, including disabling the normally
-always-enabled readline.
-
-CMake Error at CMakeLists.txt:229 (check_symbol_exists):
- Unknown CMake command "check_symbol_exists".
---- a/CMakeLists.txt
-+++ b/CMakeLists.txt
-@@ -12,2 +12,3 @@
- include(CheckStructHasMember)
-+include(CheckSymbolExists)
- include(CheckCCompilerFlag)