summaryrefslogtreecommitdiff
path: root/games-emulation/gfceux
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /games-emulation/gfceux
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'games-emulation/gfceux')
-rw-r--r--games-emulation/gfceux/Manifest3
-rw-r--r--games-emulation/gfceux/gfceux-2.1.1-r1.ebuild70
-rw-r--r--games-emulation/gfceux/metadata.xml11
3 files changed, 84 insertions, 0 deletions
diff --git a/games-emulation/gfceux/Manifest b/games-emulation/gfceux/Manifest
new file mode 100644
index 000000000000..74a7bb36002e
--- /dev/null
+++ b/games-emulation/gfceux/Manifest
@@ -0,0 +1,3 @@
+DIST fceux-2.1.1.src.tar.bz2 3263945 BLAKE2B 96c1dfcf51f34eff273c948d7467c4c5503079423d839c6e52596f5a47bb7a2c148a1603fbd784d838c62476e71818418615f4d10f9d04669d319466b379f078 SHA512 19a1253a3ff1d88baec5636dbebab287b106e5e114081ab4040f52dfcda28b878af748a759e08dc2fe1381eb8f59e728d36993a9aca9ce184ed8760114cf3149
+EBUILD gfceux-2.1.1-r1.ebuild 1258 BLAKE2B 125f8cc0c48c208f9d689be19aba0640d440f295d261f8be796b08497e94f8ae1d6e397f157aa8a8b6ba354d5aed2ef7898e5efbb9986ea983c35476fd0bfa26 SHA512 f95bedd06faf08fc9ffb28a9d229d6dfd20ee298025f8b06c349641d4fe8de23d860b48532fb8171af43e1f4a546a48d669d374bc761dffc2ddc8af7d27d274b
+MISC metadata.xml 331 BLAKE2B b36952158ee85e8e6614447dca54480d07a8e2fc23b059d16ede28fa9b31f65d21b606e0515e073c0d42d770a68cadcfec8965c6e9bd1343ef484f914e977434 SHA512 c64be39c5960c471c673a706561fc8962a9badcd31912280acbc999ec6617f72eaf432e0bd6f148fae4967f6c83770d8468c990cd191376f919207ae85037fa7
diff --git a/games-emulation/gfceux/gfceux-2.1.1-r1.ebuild b/games-emulation/gfceux/gfceux-2.1.1-r1.ebuild
new file mode 100644
index 000000000000..faf11fdaf183
--- /dev/null
+++ b/games-emulation/gfceux/gfceux-2.1.1-r1.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit eutils gnome2-utils distutils-r1 games
+
+DESCRIPTION="A graphical frontend for the FCEUX emulator"
+HOMEPAGE="http://fceux.com"
+SRC_URI="mirror://sourceforge/fceultra/fceux-${PV}.src.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="dev-python/pygtk"
+RDEPEND="${DEPEND}
+ games-emulation/fceux"
+
+S=${WORKDIR}/${PN}
+
+python_prepare_all() {
+ distutils-r1_python_prepare_all
+
+ sed -i \
+ -e "s#data/gfceux.glade#${GAMES_DATADIR}/${PN}/gfceux.glade#" \
+ src/main.py || die
+}
+
+python_install() {
+ distutils-r1_python_install --install-scripts="${GAMES_BINDIR}"
+}
+
+src_prepare() {
+ distutils-r1_src_prepare
+}
+
+src_compile() {
+ distutils-r1_src_compile
+}
+
+src_install() {
+ distutils-r1_src_install
+
+ doicon -s 48 data/${PN}.png
+ newicon -s 128 data/${PN}_big.png ${PN}.png
+
+ # respect games variables
+ dodir "${GAMES_DATADIR}"/${PN}
+ mv "${ED}"/usr/share/${PN}/* "${ED}${GAMES_DATADIR}"/${PN}/ || die
+
+ prepgamesdirs
+}
+
+pkg_preinst() {
+ games_pkg_preinst
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ games_pkg_postinst
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}
diff --git a/games-emulation/gfceux/metadata.xml b/games-emulation/gfceux/metadata.xml
new file mode 100644
index 000000000000..3c71f364aead
--- /dev/null
+++ b/games-emulation/gfceux/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>games@gentoo.org</email>
+ <name>Gentoo Games Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="sourceforge">fceultra</remote-id>
+ </upstream>
+</pkgmetadata>