summaryrefslogtreecommitdiff
path: root/games-emulation/fceux/fceux-2.2.3-r100.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-06-15 14:57:03 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-06-15 14:57:03 +0100
commitd18bf1e01b65ee4bf0c804e2843b282d3d4e5d7c (patch)
tree4a95cbc6ffdf13bad6ecbc7f8d5af99631984123 /games-emulation/fceux/fceux-2.2.3-r100.ebuild
parente748ba9741f6540f4675c23e3e37b73e822c13a4 (diff)
gentoo resync : 15.06.2021
Diffstat (limited to 'games-emulation/fceux/fceux-2.2.3-r100.ebuild')
-rw-r--r--games-emulation/fceux/fceux-2.2.3-r100.ebuild69
1 files changed, 0 insertions, 69 deletions
diff --git a/games-emulation/fceux/fceux-2.2.3-r100.ebuild b/games-emulation/fceux/fceux-2.2.3-r100.ebuild
deleted file mode 100644
index 710e02367ead..000000000000
--- a/games-emulation/fceux/fceux-2.2.3-r100.ebuild
+++ /dev/null
@@ -1,69 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-LUA_COMPAT=( lua5-1 )
-PYTHON_COMPAT=( python3_{7..9} )
-
-inherit python-any-r1 desktop lua-single scons-utils toolchain-funcs
-
-DESCRIPTION="A portable Famicom/NES emulator, an evolution of the original FCE Ultra"
-HOMEPAGE="https://fceux.com/"
-SRC_URI="mirror://sourceforge/fceultra/${P}.src.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="gtk logo +lua +opengl"
-
-REQUIRED_USE="lua? ( ${LUA_REQUIRED_USE} )"
-
-RDEPEND="
- lua? ( ${LUA_DEPS} )
- media-libs/libsdl[opengl?,video]
- logo? ( media-libs/gd[png] )
- opengl? ( virtual/opengl )
- gtk? ( x11-libs/gtk+:3 )
- sys-libs/zlib[minizip]
-"
-DEPEND="${RDEPEND}"
-
-PATCHES=(
- "${FILESDIR}"/${PN}-2.2.2-warnings.patch
- "${FILESDIR}/${P}-python3.patch"
-)
-
-pkg_setup() {
- python-any-r1_pkg_setup
- use lua && lua-single_pkg_setup
-}
-
-src_prepare() {
- default
-
- tc-export CC CXX
-}
-
-src_compile() {
- escons \
- GTK=0 \
- CREATE_AVI=1 \
- SYSTEM_LUA=1 \
- SYSTEM_MINIZIP=1 \
- GTK3=$(usex gtk 1 0) \
- LOGO=$(usex logo 1 0) \
- OPENGL=$(usex opengl 1 0) \
- LUA=$(usex lua 1 0)
-}
-
-src_install() {
- dobin bin/fceux
-
- doman documentation/fceux.6
- docompress -x /usr/share/doc/${PF}/documentation /usr/share/doc/${PF}/fceux.chm
- dodoc -r Authors changelog.txt TODO-SDL bin/fceux.chm documentation
- rm -f "${D}/usr/share/doc/${PF}/documentation/fceux.6"
- make_desktop_entry fceux FCEUX
- doicon fceux.png
-}