summaryrefslogtreecommitdiff
path: root/games-emulation/fbzx/fbzx-3.0.0-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-04-28 20:21:43 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-04-28 20:21:43 +0100
commit40aaaa64e86ba6710bbeb31c4615a6ce80e75e11 (patch)
tree758c221bad35c9288d0bd6df9c7dfc226728e52c /games-emulation/fbzx/fbzx-3.0.0-r1.ebuild
parent8d5dbd847cbc704a6a06405856e94b461011afe3 (diff)
gentoo resync : 28.04.2021
Diffstat (limited to 'games-emulation/fbzx/fbzx-3.0.0-r1.ebuild')
-rw-r--r--games-emulation/fbzx/fbzx-3.0.0-r1.ebuild20
1 files changed, 14 insertions, 6 deletions
diff --git a/games-emulation/fbzx/fbzx-3.0.0-r1.ebuild b/games-emulation/fbzx/fbzx-3.0.0-r1.ebuild
index 8fcb34dbfc9c..ffe2b98753cb 100644
--- a/games-emulation/fbzx/fbzx-3.0.0-r1.ebuild
+++ b/games-emulation/fbzx/fbzx-3.0.0-r1.ebuild
@@ -1,8 +1,9 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
-inherit desktop
+
+inherit desktop toolchain-funcs
DESCRIPTION="Full Screen Sinclair Spectrum emulator"
HOMEPAGE="https://github.com/rastersoft/fbzx"
@@ -11,7 +12,6 @@ SRC_URI="https://github.com/rastersoft/fbzx/archive/3.0.0.tar.gz -> ${P}.tar.gz"
LICENSE="GPL-3+"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE=""
RDEPEND="
media-libs/libsdl[video]
@@ -22,16 +22,24 @@ DEPEND="${RDEPEND}
virtual/pkgconfig
"
+PATCHES=(
+ "${FILESDIR}"/${P}-gentoo.patch
+)
+
src_prepare() {
- default
sed -i -e "s|/usr/share/|/usr/share/${PN}/|g" src/llscreen.cpp || die
- eapply "${FILESDIR}"/${P}-gentoo.patch
+
+ tc-export PKG_CONFIG
+
+ default
}
src_install() {
dobin src/fbzx
- insinto "/usr/share/${PN}"
+
+ insinto /usr/share/${PN}
doins -r data/{keymap.bmp,spectrum-roms}
+
dodoc AMSTRAD CAPABILITIES FAQ PORTING README* TODO VERSIONS
doicon data/fbzx.svg
make_desktop_entry fbzx FBZX