summaryrefslogtreecommitdiff
path: root/games-emulation/dolphin/dolphin-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-12-24 14:11:38 +0000
committerV3n3RiX <venerix@redcorelinux.org>2018-12-24 14:11:38 +0000
commitde49812990871e1705b64051c35161d5e6400269 (patch)
tree5e1e8fcb0ff4579dbd22a1bfee28a6b97dc8aaeb /games-emulation/dolphin/dolphin-9999.ebuild
parent536c3711867ec947c1738f2c4b96f22e4863322d (diff)
gentoo resync : 24.12.2018
Diffstat (limited to 'games-emulation/dolphin/dolphin-9999.ebuild')
-rw-r--r--games-emulation/dolphin/dolphin-9999.ebuild10
1 files changed, 6 insertions, 4 deletions
diff --git a/games-emulation/dolphin/dolphin-9999.ebuild b/games-emulation/dolphin/dolphin-9999.ebuild
index 3294bace82d7..fcc451d6afda 100644
--- a/games-emulation/dolphin/dolphin-9999.ebuild
+++ b/games-emulation/dolphin/dolphin-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -22,7 +22,7 @@ HOMEPAGE="https://www.dolphin-emu.org/"
LICENSE="GPL-2"
SLOT="0"
-IUSE="alsa bluetooth discord-presence doc egl +evdev ffmpeg libav log lto profile pulseaudio +qt5 systemd upnp"
+IUSE="alsa bluetooth discord-presence doc +evdev ffmpeg libav log lto profile pulseaudio +qt5 systemd upnp"
RDEPEND="
dev-libs/hidapi:0=
@@ -30,6 +30,7 @@ RDEPEND="
dev-libs/pugixml:0=
media-libs/libpng:0=
media-libs/libsfml
+ media-libs/mesa[egl]
net-libs/enet:1.3
net-libs/mbedtls
net-misc/curl:0=
@@ -42,7 +43,6 @@ RDEPEND="
virtual/opengl
alsa? ( media-libs/alsa-lib )
bluetooth? ( net-wireless/bluez )
- egl? ( media-libs/mesa[egl] )
evdev? (
dev-libs/libevdev
virtual/udev
@@ -77,8 +77,11 @@ src_prepare() {
Bochs_disasm
cpp-optparse
glslang
+ imgui
# FIXME: xxhash can't be found by cmake
xxhash
+ # no support for for using system library
+ minizip
# soundtouch uses shorts, not floats
soundtouch
cubeb
@@ -129,7 +132,6 @@ src_configure() {
-DFASTLOG=$(usex log)
-DOPROFILING=$(usex profile)
-DUSE_DISCORD_PRESENCE=$(usex discord-presence)
- -DUSE_EGL=$(usex egl)
-DUSE_SHARED_ENET=ON
-DUSE_UPNP=$(usex upnp)
)