summaryrefslogtreecommitdiff
path: root/games-emulation/dolphin/dolphin-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-07-08 15:03:58 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-07-08 15:03:58 +0100
commit814f4cf860e299a046b649eaee5463427984c09c (patch)
tree74c45f097899310e599dad6b8df5b63e0f085bc0 /games-emulation/dolphin/dolphin-9999.ebuild
parent7f0ccc917c7abe6223784c703d86cd14755691fb (diff)
gentoo resync : 08.07.2021
Diffstat (limited to 'games-emulation/dolphin/dolphin-9999.ebuild')
-rw-r--r--games-emulation/dolphin/dolphin-9999.ebuild8
1 files changed, 4 insertions, 4 deletions
diff --git a/games-emulation/dolphin/dolphin-9999.ebuild b/games-emulation/dolphin/dolphin-9999.ebuild
index b8b8e1e3b4e3..b2fd4d445542 100644
--- a/games-emulation/dolphin/dolphin-9999.ebuild
+++ b/games-emulation/dolphin/dolphin-9999.ebuild
@@ -6,7 +6,7 @@ EAPI=7
PLOCALES="ar ca cs da de el en es fa fr hr hu it ja ko ms nb nl pl pt pt_BR ro ru sr sv tr zh_CN zh_TW"
PLOCALE_BACKUP="en"
-inherit cmake desktop xdg-utils l10n pax-utils
+inherit cmake desktop xdg-utils pax-utils plocale
if [[ ${PV} == *9999 ]]
then
@@ -122,15 +122,15 @@ src_prepare() {
remove_locale() {
# Ensure preservation of the backup locale when no valid LINGUA is set
- if [[ "${PLOCALE_BACKUP}" == "${1}" ]] && [[ "${PLOCALE_BACKUP}" == "$(l10n_get_locales)" ]]; then
+ if [[ "${PLOCALE_BACKUP}" == "${1}" ]] && [[ "${PLOCALE_BACKUP}" == "$(plocale_get_locales)" ]]; then
return
else
rm "Languages/po/${1}.po" || die
fi
}
- l10n_find_plocales_changes "Languages/po/" "" '.po'
- l10n_for_each_disabled_locale_do remove_locale
+ plocale_find_changes "Languages/po/" "" '.po'
+ plocale_for_each_disabled_locale remove_locale
# About 50% compile-time speedup
use vulkan || sed -i -e '/Externals\/glslang/d' CMakeLists.txt