summaryrefslogtreecommitdiff
path: root/games-emulation/dgen-sdl/dgen-sdl-1.33.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /games-emulation/dgen-sdl/dgen-sdl-1.33.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'games-emulation/dgen-sdl/dgen-sdl-1.33.ebuild')
-rw-r--r--games-emulation/dgen-sdl/dgen-sdl-1.33.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/games-emulation/dgen-sdl/dgen-sdl-1.33.ebuild b/games-emulation/dgen-sdl/dgen-sdl-1.33.ebuild
new file mode 100644
index 000000000000..2f8e6bcab81a
--- /dev/null
+++ b/games-emulation/dgen-sdl/dgen-sdl-1.33.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+inherit eutils games
+
+DESCRIPTION="A Linux/SDL-Port of the famous DGen MegaDrive/Genesis-Emulator"
+HOMEPAGE="http://dgen.sourceforge.net/"
+SRC_URI="mirror://sourceforge/dgen/files/${P}.tar.gz"
+
+LICENSE="dgen-sdl BSD BSD-2 free-noncomm LGPL-2.1+ GPL-2+"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="joystick opengl"
+
+RDEPEND="media-libs/libsdl[joystick?,opengl?]
+ app-arch/libarchive
+ opengl? ( virtual/opengl )"
+DEPEND="${RDEPEND}
+ x86? ( dev-lang/nasm )"
+
+src_prepare() {
+ # fix building with USE=-joystick
+ epatch "${FILESDIR}"/${P}-joystick.patch
+}
+
+src_configure() {
+ egamesconf \
+ $(use_enable x86 asm) \
+ $(use_enable joystick) \
+ $(use_enable opengl)
+}
+
+src_compile() {
+ emake -C musa m68kops.h
+ emake
+}
+
+src_install() {
+ DOCS="AUTHORS ChangeLog README sample.dgenrc" default
+ prepgamesdirs
+}