summaryrefslogtreecommitdiff
path: root/games-emulation/desmume
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /games-emulation/desmume
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'games-emulation/desmume')
-rw-r--r--games-emulation/desmume/Manifest6
-rw-r--r--games-emulation/desmume/desmume-0.9.11-r1.ebuild38
-rw-r--r--games-emulation/desmume/files/desmume-0.9.11-fix-pointer-conversion-warning.diff11
-rw-r--r--games-emulation/desmume/files/desmume-0.9.11-gcc6.patch47
-rw-r--r--games-emulation/desmume/files/desmume-0.9.11-gcc7.patch21
-rw-r--r--games-emulation/desmume/metadata.xml14
6 files changed, 137 insertions, 0 deletions
diff --git a/games-emulation/desmume/Manifest b/games-emulation/desmume/Manifest
new file mode 100644
index 000000000000..377ab85a7308
--- /dev/null
+++ b/games-emulation/desmume/Manifest
@@ -0,0 +1,6 @@
+AUX desmume-0.9.11-fix-pointer-conversion-warning.diff 370 BLAKE2B 8e019cf69a13b3669166f1ee04d26e6538a392e494d356b2eeabd43ac69fe9489ddeda146054ab5d1f821b3a52719d58ae493ca870f46461eacaab26ffb9eba1 SHA512 f7d5f4ac4d96f244aa6ee81a90f64e754aceebf075f1c4ff84dde2d1d2beaf617631569c5aa9a8afb40ae4499067e2233ba00a4b9d606a9608915714766d0bff
+AUX desmume-0.9.11-gcc6.patch 1991 BLAKE2B ffb0a58f7317aa50fe17c4abe1ba6c9bbf9cb937736479214b86187c32af8c1659aa719eccce184a5f0fa1b31f15634276fb676bf97ec64feba603fa89ee289f SHA512 e9249a613f1bf3b6d72dcce47cbc39daeadb1b4f7b9be2748b537ec3389a61f46b5f15f5a10d55bc4b1dbd69dd87526b5ce79e58b539cf432679da9bc803e0cd
+AUX desmume-0.9.11-gcc7.patch 832 BLAKE2B 80accd7e22d22163692be58f2da288db4b4009603f9cf9fca4d709e44dfae4496c9b7610c82bf6bfc47c470837dccec83a95e124c3ad9a8cead654cd389a3476 SHA512 9c9b0452a6aaf860583ad97737fb7142601a5ff6f4b720037c9b4d2aeab533c12ffbb1a216753f7e9e4f04350a4e276c5606624ab633f4c2bea517ec0233db8f
+DIST desmume-0.9.11.tar.gz 5359305 BLAKE2B 31764dcb2d0facf32eddd5c66f40e2268f8afd5c2562bf246b93bb60c191d7888587991732014dee11417016515a4367bda9acf79f699703754aa904dcaeeb01 SHA512 160cb6ec0ede04ad1fbddde2b7b04aa41fa464c8338d7eb9d7536196a82d8d716889b40be4fb831a22e3fe8532b947f7f0b41311601b6842be2516dff7cae46c
+EBUILD desmume-0.9.11-r1.ebuild 800 BLAKE2B 5cf60a8343d47e2e7adce5697fe8904bc733f503d9d56a37515708def52dd403ae52bec61b20bb6183335266e61916b2d0591e6f89ca20ce5cdbff76c565cbd6 SHA512 91fc616b3935e92f6b1f88346a47b6683835d02a2a35f32fc2b2d127971546fe45ef3af8d1d690f9e39b595f51c405664cf29ae9b62e63f024e8c98214786e7d
+MISC metadata.xml 407 BLAKE2B a64ba166734f13f34fec0ca394d4d51bc70f2cb9539981e068e544f3139584ee3ec2da89a02ef9203008cb73213213adb148c978311ae36d95749e553d10605b SHA512 89d3a5b608525bfa1f05503017619520d82c663241668c3d5fa5602e625cbfe02564b04d7bac0e97bbe53ff8eba08a6895fb0e8cd519d0d88efd29a0ca64ac4b
diff --git a/games-emulation/desmume/desmume-0.9.11-r1.ebuild b/games-emulation/desmume/desmume-0.9.11-r1.ebuild
new file mode 100644
index 000000000000..e98e0846012b
--- /dev/null
+++ b/games-emulation/desmume/desmume-0.9.11-r1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit xdg
+
+DESCRIPTION="Nintendo DS emulator"
+HOMEPAGE="http://desmume.org/"
+SRC_URI="mirror://sourceforge/desmume/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="
+ dev-libs/zziplib
+ gnome-base/libglade
+ media-libs/libsdl[joystick,opengl,video]
+ sys-libs/zlib
+ virtual/opengl
+ x11-libs/agg
+ >=x11-libs/gtk+-2.8.0:2
+ x11-libs/gtkglext"
+DEPEND="${RDEPEND}
+ dev-util/intltool
+ virtual/pkgconfig"
+
+DOCS=( AUTHORS ChangeLog README README.LIN )
+
+# fix QA compiler warning, see
+# https://sourceforge.net/p/desmume/patches/172/
+PATCHES=(
+ "${FILESDIR}/${P}-fix-pointer-conversion-warning.diff"
+ "${FILESDIR}/${P}-gcc6.patch"
+ "${FILESDIR}/${P}-gcc7.patch"
+)
diff --git a/games-emulation/desmume/files/desmume-0.9.11-fix-pointer-conversion-warning.diff b/games-emulation/desmume/files/desmume-0.9.11-fix-pointer-conversion-warning.diff
new file mode 100644
index 000000000000..8975085133ff
--- /dev/null
+++ b/games-emulation/desmume/files/desmume-0.9.11-fix-pointer-conversion-warning.diff
@@ -0,0 +1,11 @@
+--- a/src/path.h 2015-02-14 16:05:26.000000000 +0100
++++ b/src/path.h 2016-07-11 12:09:59.591987169 +0200
+@@ -375,7 +375,7 @@
+ else if (strchr(strftimeArgs, *p))
+ {
+ char tmp[MAX_PATH];
+- char format[] = { '%', *p, NULL };
++ char format[] = { '%', *p, '\0' };
+ strftime(tmp, MAX_PATH, format, time_struct);
+ file.append(tmp);
+ }
diff --git a/games-emulation/desmume/files/desmume-0.9.11-gcc6.patch b/games-emulation/desmume/files/desmume-0.9.11-gcc6.patch
new file mode 100644
index 000000000000..761ccef045cf
--- /dev/null
+++ b/games-emulation/desmume/files/desmume-0.9.11-gcc6.patch
@@ -0,0 +1,47 @@
+--- a/src/wifi.cpp
++++ b/src/wifi.cpp
+@@ -314,9 +314,9 @@
+
+ #if (WIFI_LOGGING_LEVEL >= 1)
+ #if WIFI_LOG_USE_LOGC
+- #define WIFI_LOG(level, ...) if(level <= WIFI_LOGGING_LEVEL) LOGC(8, "WIFI: "__VA_ARGS__);
++ #define WIFI_LOG(level, ...) if(level <= WIFI_LOGGING_LEVEL) LOGC(8, "WIFI: " __VA_ARGS__);
+ #else
+- #define WIFI_LOG(level, ...) if(level <= WIFI_LOGGING_LEVEL) printf("WIFI: "__VA_ARGS__);
++ #define WIFI_LOG(level, ...) if(level <= WIFI_LOGGING_LEVEL) printf("WIFI: " __VA_ARGS__);
+ #endif
+ #else
+ #define WIFI_LOG(level, ...) {}
+--- a/src/MMU_timing.h
++++ b/src/MMU_timing.h
+@@ -155,8 +155,8 @@
+ enum { ASSOCIATIVITY = 1 << ASSOCIATIVESHIFT };
+ enum { BLOCKSIZE = 1 << BLOCKSIZESHIFT };
+ enum { TAGSHIFT = SIZESHIFT - ASSOCIATIVESHIFT };
+- enum { TAGMASK = (u32)(~0 << TAGSHIFT) };
+- enum { BLOCKMASK = ((u32)~0 >> (32 - TAGSHIFT)) & (u32)(~0 << BLOCKSIZESHIFT) };
++ enum { TAGMASK = (u32)(~0U << TAGSHIFT) };
++ enum { BLOCKMASK = ((u32)~0U >> (32 - TAGSHIFT)) & (u32)(~0U << BLOCKSIZESHIFT) };
+ enum { WORDSIZE = sizeof(u32) };
+ enum { WORDSPERBLOCK = (1 << BLOCKSIZESHIFT) / WORDSIZE };
+ enum { DATAPERWORD = WORDSIZE * ASSOCIATIVITY };
+--- a/src/ctrlssdl.cpp
++++ b/src/ctrlssdl.cpp
+@@ -200,7 +200,7 @@
+ break;
+ case SDL_JOYAXISMOTION:
+ /* Dead zone of 50% */
+- if( (abs(event.jaxis.value) >> 14) != 0 )
++ if( ((u32)abs(event.jaxis.value) >> 14) != 0 )
+ {
+ key = ((event.jaxis.which & 15) << 12) | JOY_AXIS << 8 | ((event.jaxis.axis & 127) << 1);
+ if (event.jaxis.value > 0) {
+@@ -370,7 +370,7 @@
+ Note: button constants have a 1bit offset. */
+ case SDL_JOYAXISMOTION:
+ key_code = ((event->jaxis.which & 15) << 12) | JOY_AXIS << 8 | ((event->jaxis.axis & 127) << 1);
+- if( (abs(event->jaxis.value) >> 14) != 0 )
++ if( ((u32)abs(event->jaxis.value) >> 14) != 0 )
+ {
+ if (event->jaxis.value > 0)
+ key_code |= 1;
diff --git a/games-emulation/desmume/files/desmume-0.9.11-gcc7.patch b/games-emulation/desmume/files/desmume-0.9.11-gcc7.patch
new file mode 100644
index 000000000000..8b8a67f2291a
--- /dev/null
+++ b/games-emulation/desmume/files/desmume-0.9.11-gcc7.patch
@@ -0,0 +1,21 @@
+Bug: https://bugs.gentoo.org/646352
+Patch: https://sources.debian.org/data/main/d/desmume/0.9.11-3/debian/patches/gcc7_fixes.patch
+
+From e1f7039f1b06add4fb75b2f8774000b8f05574af Mon Sep 17 00:00:00 2001
+From: rogerman <rogerman@users.sf.net>
+Date: Mon, 17 Aug 2015 21:15:04 +0000
+Subject: Fix bug with libfat string handling.
+
+diff --git a/src/utils/libfat/directory.cpp b/src/utils/libfat/directory.cpp
+index 765d7ae5..b6d7f01f 100644
+--- a/src/utils/libfat/directory.cpp
++++ b/src/utils/libfat/directory.cpp
+@@ -139,7 +139,7 @@ static size_t _FAT_directory_mbstoucs2 (ucs2_t* dst, const char* src, size_t len
+ int bytes;
+ size_t count = 0;
+
+- while (count < len-1 && src != '\0') {
++ while (count < len-1 && *src != '\0') {
+ bytes = mbrtowc (&tempChar, src, MB_CUR_MAX, &ps);
+ if (bytes > 0) {
+ *dst = (ucs2_t)tempChar;
diff --git a/games-emulation/desmume/metadata.xml b/games-emulation/desmume/metadata.xml
new file mode 100644
index 000000000000..d906b044dcad
--- /dev/null
+++ b/games-emulation/desmume/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>hanno@gentoo.org</email>
+ </maintainer>
+ <maintainer type="project">
+ <email>games@gentoo.org</email>
+ <name>Gentoo Games Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="sourceforge">desmume</remote-id>
+ </upstream>
+</pkgmetadata>