summaryrefslogtreecommitdiff
path: root/games-emulation/desmume/desmume-0.9.11_p20210409-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-06-29 10:15:54 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-06-29 10:15:54 +0100
commit9aa80713372911cec499b3adb2cd746790920916 (patch)
treeb8e99dc5dd60ac2094a27cc52f74aada8df38f05 /games-emulation/desmume/desmume-0.9.11_p20210409-r1.ebuild
parentb4d43e8c611df4a8061b6f88d9e9f6b1e3c83903 (diff)
gentoo resync : 29.06.2021
Diffstat (limited to 'games-emulation/desmume/desmume-0.9.11_p20210409-r1.ebuild')
-rw-r--r--games-emulation/desmume/desmume-0.9.11_p20210409-r1.ebuild52
1 files changed, 52 insertions, 0 deletions
diff --git a/games-emulation/desmume/desmume-0.9.11_p20210409-r1.ebuild b/games-emulation/desmume/desmume-0.9.11_p20210409-r1.ebuild
new file mode 100644
index 000000000000..c3a847606182
--- /dev/null
+++ b/games-emulation/desmume/desmume-0.9.11_p20210409-r1.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit meson xdg
+
+MY_COMMIT="e8f619c44a23ebba06be1fb4442483d481477b81"
+
+DESCRIPTION="Nintendo DS emulator"
+HOMEPAGE="https://desmume.org/"
+SRC_URI="https://github.com/TASVideos/desmume/archive/${MY_COMMIT}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${PN}-${MY_COMMIT}"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="gdb +gui openal wifi"
+
+RDEPEND="
+ dev-libs/glib:2
+ media-libs/alsa-lib
+ media-libs/libsdl2[X,opengl,sound,video]
+ media-libs/libsoundtouch:=
+ net-libs/libpcap
+ sys-libs/zlib:=
+ virtual/opengl
+ x11-libs/agg
+ x11-libs/libX11
+ gui? ( x11-libs/gtk+:3 )
+ openal? ( media-libs/openal )"
+DEPEND="
+ ${RDEPEND}
+ x11-base/xorg-proto"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-fix-gtk-cliopts.patch
+ "${FILESDIR}"/${P}-openal-automagic.patch
+)
+
+DOCS=( ${PN}/{AUTHORS,ChangeLog,README,README.LIN,doc/.} )
+
+src_configure() {
+ local EMESON_SOURCE="${S}/${PN}/src/frontend/posix"
+ local emesonargs=(
+ $(meson_use gdb gdb-stub)
+ $(meson_use gui frontend-gtk)
+ $(meson_use openal)
+ $(meson_use wifi)
+ )
+ meson_src_configure
+}