summaryrefslogtreecommitdiff
path: root/games-emulation/bsnes-jg/bsnes-jg-1.1.2-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-04-30 00:00:01 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-04-30 00:00:01 +0100
commit4c2b70adc6484c35ff05e412de08a7b7f50cfb34 (patch)
treec7557ae36b9b2bfa7134849511e79da938581c5f /games-emulation/bsnes-jg/bsnes-jg-1.1.2-r1.ebuild
parent5f0030fd1370c4d03dbb2e0d3086f5e618a33749 (diff)
gentoo auto-resync : 30:04:2024 - 00:00:01
Diffstat (limited to 'games-emulation/bsnes-jg/bsnes-jg-1.1.2-r1.ebuild')
-rw-r--r--games-emulation/bsnes-jg/bsnes-jg-1.1.2-r1.ebuild50
1 files changed, 0 insertions, 50 deletions
diff --git a/games-emulation/bsnes-jg/bsnes-jg-1.1.2-r1.ebuild b/games-emulation/bsnes-jg/bsnes-jg-1.1.2-r1.ebuild
deleted file mode 100644
index 3522f14ebe50..000000000000
--- a/games-emulation/bsnes-jg/bsnes-jg-1.1.2-r1.ebuild
+++ /dev/null
@@ -1,50 +0,0 @@
-# Copyright 2022-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit toolchain-funcs
-
-MY_PN=${PN%-*}
-MY_P=${MY_PN}-${PV}
-DESCRIPTION="Jolly Good Fork of bsnes"
-HOMEPAGE="https://gitlab.com/jgemu/bsnes"
-if [[ "${PV}" == *9999 ]] ; then
- inherit git-r3
- EGIT_REPO_URI="https://gitlab.com/jgemu/${MY_PN}.git"
-else
- SRC_URI="https://gitlab.com/jgemu/${MY_PN}/-/archive/${PV}/${MY_P}.tar.bz2"
- S="${WORKDIR}/${MY_P}"
- KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
-fi
-
-LICENSE="ISC GPL-3+ LGPL-2.1+ MIT ZLIB"
-SLOT="1"
-
-PATCHES=(
- "${FILESDIR}"/${P}-endianness.patch # 891201#c9
-)
-
-DEPEND="
- media-libs/jg:1=
- media-libs/libsamplerate
-"
-RDEPEND="
- ${DEPEND}
- games-emulation/jgrf
-"
-BDEPEND="
- virtual/pkgconfig
-"
-
-src_compile() {
- emake CC="$(tc-getCC)" CXX="$(tc-getCXX)" PKG_CONFIG="$(tc-getPKG_CONFIG)"
-}
-
-src_install() {
- emake install \
- DESTDIR="${D}" \
- PREFIX="${EPREFIX}"/usr \
- DOCDIR="${EPREFIX}"/usr/share/doc/${PF} \
- LIBDIR="${EPREFIX}/usr/$(get_libdir)"
-}