summaryrefslogtreecommitdiff
path: root/games-board
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-03-08 05:59:05 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-03-08 05:59:05 +0000
commit60a831b4d328a261286ac8a4e150437faf49ce69 (patch)
tree52337b9b1241c68f5c589fd12d55502da7d44246 /games-board
parent9c26fcf51085241030a088f8ac16051c756386cd (diff)
gentoo auto-resync : 08:03:2023 - 05:59:05
Diffstat (limited to 'games-board')
-rw-r--r--games-board/Manifest.gzbin9876 -> 9878 bytes
-rw-r--r--games-board/pychess/Manifest1
-rw-r--r--games-board/pychess/pychess-1.0.3-r3.ebuild47
3 files changed, 48 insertions, 0 deletions
diff --git a/games-board/Manifest.gz b/games-board/Manifest.gz
index ac3a16b40db3..be85f4b52544 100644
--- a/games-board/Manifest.gz
+++ b/games-board/Manifest.gz
Binary files differ
diff --git a/games-board/pychess/Manifest b/games-board/pychess/Manifest
index 264afd6574c7..2b749296a89f 100644
--- a/games-board/pychess/Manifest
+++ b/games-board/pychess/Manifest
@@ -1,4 +1,5 @@
AUX pychess-1.0.3-setuptools-warning.patch 221 BLAKE2B 791a195548b3b4f49368f85045c8c604754bf6eb9b00cc672d32afdc45dcfefe9557b4d945ec50ee28e68875ad3aefc889870cf6b447d79850e63294b0a72814 SHA512 ecc7aa1427d5a17792aa468676263c05adbb85b28b2b4a08228b0ade72a5722b30899bcc591833c9d43391cde04ddb2e6b0c0358876f56803802175e24016cbd
DIST pychess-1.0.3.tar.gz 14898032 BLAKE2B 0993bcf26d3284847815b37f570b7482c5359595f9649f9546ed090b6c090c3686d71478c9ecdaacde4bdf56f8f57da89623023d25809b46fe4e2800beeba91d SHA512 ca69555b1d952274fc4850f20bc66569e2f08120109908489c584231c754345b16fc1b1e9fa5b44a10582590145cf472604e5f5bd22522037666414418f5fda5
EBUILD pychess-1.0.3-r2.ebuild 1313 BLAKE2B 695277d1ddc010b7a2d28d5d370bce0bd6501206484ab41f2f4ccc7234e6f886f14e009a8b3e4f3592e87f8aff99070b54404537ae6b28b6c50ab323b08bc51b SHA512 12d764ff1d070969870c993252ef636b4c6ee5a59d3f72cddc7e048ef0a13f9265a7a009c7a0908a0be4d7aefb56b82e72a599a7aeac74acbd485ac8df2b858e
+EBUILD pychess-1.0.3-r3.ebuild 1316 BLAKE2B 75a4d6bbde9c7b3ca8d6bd10e032b0f1a07bd1992b5c06a6c1672a17ecb1292bdc1fc9ad63db67870b6373108046bb8bb6fcfa1972c3c01c6ed6de555270f52a SHA512 4c3bd19eab8981d6ae518dc41f2aab6094bce989b103dafe0ffbce1685a3a1eae2156345ad066485390a81337f6712918ea3fd2819ddcba5a1d101ce8d50c7af
MISC metadata.xml 334 BLAKE2B bbee149d1aa743ca9b8d6cdafcf46996c100563fbcd60f994b4b26ea428123966465468d5c834baba5d8346efae67d8f0d78fe8d63a28dd12dcb91a3ed040f0b SHA512 f168de876d77b7b029f708199aefeba0be4da48c2fb08e672ec7ba7ba580c4d9958aa08c3d7548c49dea76d77d3255bb476aea463319963a549f5346c8fda63c
diff --git a/games-board/pychess/pychess-1.0.3-r3.ebuild b/games-board/pychess/pychess-1.0.3-r3.ebuild
new file mode 100644
index 000000000000..7a74f0b75169
--- /dev/null
+++ b/games-board/pychess/pychess-1.0.3-r3.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_SINGLE_IMPL=1
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} )
+PYTHON_REQ_USE="sqlite"
+inherit distutils-r1 xdg
+
+DESCRIPTION="GTK chess client"
+HOMEPAGE="https://pychess.github.io/"
+SRC_URI="https://github.com/pychess/pychess/releases/download/${PV}/${P}.tar.gz"
+S="${WORKDIR}/PyChess-${PV}"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="gstreamer"
+
+RDEPEND="
+ $(python_gen_cond_dep '
+ dev-python/pexpect[${PYTHON_USEDEP}]
+ dev-python/psutil[${PYTHON_USEDEP}]
+ dev-python/pycairo[${PYTHON_USEDEP}]
+ dev-python/pygobject:3[${PYTHON_USEDEP},cairo]
+ <dev-python/sqlalchemy-2[${PYTHON_USEDEP},sqlite]
+ dev-python/websockets[${PYTHON_USEDEP}]
+ gstreamer? ( dev-python/gst-python:1.0[${PYTHON_USEDEP}] )')
+ gnome-base/librsvg:2[introspection]
+ x11-libs/gtk+:3[introspection]
+ x11-libs/gtksourceview:3.0[introspection]
+ x11-libs/pango[introspection]
+ x11-themes/adwaita-icon-theme"
+BDEPEND="${RDEPEND}" # setup.py fails if introspection deps not found
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.0.3-setuptools-warning.patch
+)
+
+src_install() {
+ distutils-r1_src_install
+
+ # https://github.com/pychess/pychess/pull/1825
+ gunzip -v "${ED}"/usr/share/man/man1/${PN}.1.gz || die
+}