summaryrefslogtreecommitdiff
path: root/games-board/pychess
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /games-board/pychess
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'games-board/pychess')
-rw-r--r--games-board/pychess/Manifest3
-rw-r--r--games-board/pychess/metadata.xml11
-rw-r--r--games-board/pychess/pychess-0.12.4.ebuild71
3 files changed, 85 insertions, 0 deletions
diff --git a/games-board/pychess/Manifest b/games-board/pychess/Manifest
new file mode 100644
index 000000000000..b2b7c0b57f20
--- /dev/null
+++ b/games-board/pychess/Manifest
@@ -0,0 +1,3 @@
+DIST pychess-0.12.4.tar.gz 4728410 BLAKE2B 4fd95e85983ce9e7d588e98a27a1695d116f102290942e2c747046ee9e4289b53734dbd949af4f88fc4186fc3e52b9ff41b1e18e2763c5f48b2d371ae22f44fe SHA512 bf2a6cffca50742fbdfba04bc33807b53e4b7485cb6c9b6bb84816e176fd99f3929dbc8e504b46053cdcd30f691d6df948f5153508b2b6d3504f85a31eaccf62
+EBUILD pychess-0.12.4.ebuild 1309 BLAKE2B 82768b6a1271bc6eeb611d81d9ed59bb117e74101fab3e921acfd5d8c2f835ecf0a531220827ca2ff8b74ff072a93f3b3a11dadd0cccd6805249fd45cdbb8b5b SHA512 dd5c1211739b284af66c1f98fd8ff5256884d333741cd2f60006d9a048729f32c23debc94b5e14cf309a5af7c673b9bd174ca3c4320d2b5c0503604243a176c4
+MISC metadata.xml 330 BLAKE2B 15a47bf5f276ac9befdb283d8c69ecb24c91b4ea01cd72afd84227afe207ee7f3abfc037d9bc1c214b5e0091aeae4ea071cfda32d55b25766cc9480a3611ae43 SHA512 0233cc10e31aa616eaab261554b2a730bb8932e3a266943c829a2c1c48f296830ea42217174256816a1bd4d0d4eeebb34e8c615ef2d997ee2d3da512ca97ee5c
diff --git a/games-board/pychess/metadata.xml b/games-board/pychess/metadata.xml
new file mode 100644
index 000000000000..852efafb3934
--- /dev/null
+++ b/games-board/pychess/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>games@gentoo.org</email>
+ <name>Gentoo Games Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="google-code">pychess</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/games-board/pychess/pychess-0.12.4.ebuild b/games-board/pychess/pychess-0.12.4.ebuild
new file mode 100644
index 000000000000..f5fe56473254
--- /dev/null
+++ b/games-board/pychess/pychess-0.12.4.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 )
+PYTHON_REQ_USE="sqlite"
+
+inherit fdo-mime gnome2-utils distutils-r1
+
+DESCRIPTION="A chess client for Gnome"
+HOMEPAGE="http://pychess.org/"
+SRC_URI="http://pychess.org/download/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="gstreamer"
+
+DEPEND="
+ dev-python/pycairo[${PYTHON_USEDEP}]
+ dev-python/pygobject:3[${PYTHON_USEDEP}]
+ gnome-base/librsvg:2
+ x11-libs/gtksourceview:3.0
+ x11-libs/pango
+ x11-themes/adwaita-icon-theme
+ gstreamer? (
+ dev-python/gst-python:1.0
+ media-libs/gstreamer:1.0
+ media-libs/gst-plugins-base:1.0 )
+"
+RDEPEND=${DEPEND}
+
+python_install() {
+ distutils-r1_python_install
+
+ # bug 487706
+ sed -i \
+ -e "s/@PYTHON@/${EPYTHON}/" \
+ "${ED%/}/$(python_get_sitedir)"/${PN}/Players/engineNest.py || die
+}
+
+python_install_all() {
+ DOCS="AUTHORS README.md" \
+ distutils-r1_python_install_all
+}
+
+src_prepare() {
+ distutils-r1_src_prepare
+}
+
+src_compile() {
+ distutils-r1_src_compile
+}
+
+src_install() {
+ distutils-r1_src_install
+}
+
+pkg_preinst() {
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+ fdo-mime_desktop_database_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+ fdo-mime_desktop_database_update
+}