summaryrefslogtreecommitdiff
path: root/games-board/pychess
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-03-20 00:40:44 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-03-20 00:40:44 +0000
commit4cbcc855382a06088e2f016f62cafdbcb7e40665 (patch)
tree356496503d52354aa6d9f2d36126302fed5f3a73 /games-board/pychess
parentfcc5224904648a8e6eb528d7603154160a20022f (diff)
gentoo resync : 20.03.2022
Diffstat (limited to 'games-board/pychess')
-rw-r--r--games-board/pychess/Manifest3
-rw-r--r--games-board/pychess/files/pychess-1.0.3-setuptools-warning.patch8
-rw-r--r--games-board/pychess/pychess-1.0.3-r2.ebuild47
-rw-r--r--games-board/pychess/pychess-1.0.3.ebuild52
4 files changed, 57 insertions, 53 deletions
diff --git a/games-board/pychess/Manifest b/games-board/pychess/Manifest
index 4362d71a4712..4735e1d018ef 100644
--- a/games-board/pychess/Manifest
+++ b/games-board/pychess/Manifest
@@ -1,3 +1,4 @@
+AUX pychess-1.0.3-setuptools-warning.patch 221 BLAKE2B 791a195548b3b4f49368f85045c8c604754bf6eb9b00cc672d32afdc45dcfefe9557b4d945ec50ee28e68875ad3aefc889870cf6b447d79850e63294b0a72814 SHA512 ecc7aa1427d5a17792aa468676263c05adbb85b28b2b4a08228b0ade72a5722b30899bcc591833c9d43391cde04ddb2e6b0c0358876f56803802175e24016cbd
DIST pychess-1.0.3.tar.gz 14898032 BLAKE2B 0993bcf26d3284847815b37f570b7482c5359595f9649f9546ed090b6c090c3686d71478c9ecdaacde4bdf56f8f57da89623023d25809b46fe4e2800beeba91d SHA512 ca69555b1d952274fc4850f20bc66569e2f08120109908489c584231c754345b16fc1b1e9fa5b44a10582590145cf472604e5f5bd22522037666414418f5fda5
-EBUILD pychess-1.0.3.ebuild 1222 BLAKE2B 1b9753e71e67e98964c05d6903312bbd2e0fc74d95336a3d6258f7097dfbbbe777f98dc1f76f28c66241e0ba863beb8bcf93f77a20431a19a6f156e93cb9c156 SHA512 0d097e55eb86da01cfc86e7d4d2f41954306d8248932be5af89836408a97029a597931ac4335d71a32ea78f077fcf7cc9ce0a350a2fbb7e73316887ce4563196
+EBUILD pychess-1.0.3-r2.ebuild 1313 BLAKE2B 9bb8019e901d711844ff9f4b52e7067656e9b7f3fd3e60c44cb1e1ea3ed61c0e1d1e7ddf48492fa53a94956822420c9eae88962e204f39c63fe67d587109ae2c SHA512 f4ee096229eec999ed9f29033c988b2299a04f99fb58dd0319520ceca5fb2c0ca7e4c0655ef98010ea33bfba82d0286b97a398523b515c47513999aa1b64fe50
MISC metadata.xml 334 BLAKE2B bbee149d1aa743ca9b8d6cdafcf46996c100563fbcd60f994b4b26ea428123966465468d5c834baba5d8346efae67d8f0d78fe8d63a28dd12dcb91a3ed040f0b SHA512 f168de876d77b7b029f708199aefeba0be4da48c2fb08e672ec7ba7ba580c4d9958aa08c3d7548c49dea76d77d3255bb476aea463319963a549f5346c8fda63c
diff --git a/games-board/pychess/files/pychess-1.0.3-setuptools-warning.patch b/games-board/pychess/files/pychess-1.0.3-setuptools-warning.patch
new file mode 100644
index 000000000000..414a486905b9
--- /dev/null
+++ b/games-board/pychess/files/pychess-1.0.3-setuptools-warning.patch
@@ -0,0 +1,8 @@
+Silence QA notice for:
+dist.py:275: UserWarning: Unknown distribution option: 'executables'
+--- a/setup.py
++++ b/setup.py
+@@ -323,3 +323,2 @@
+ "bdist_msi": bdist_msi_options},
+- executables=executables
+ )
diff --git a/games-board/pychess/pychess-1.0.3-r2.ebuild b/games-board/pychess/pychess-1.0.3-r2.ebuild
new file mode 100644
index 000000000000..adb277fbbb64
--- /dev/null
+++ b/games-board/pychess/pychess-1.0.3-r2.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_SINGLE_IMPL=1
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+PYTHON_REQ_USE="sqlite"
+inherit distutils-r1 xdg
+
+DESCRIPTION="GTK chess client"
+HOMEPAGE="https://pychess.github.io/"
+SRC_URI="https://github.com/pychess/pychess/releases/download/${PV}/${P}.tar.gz"
+S="${WORKDIR}/PyChess-${PV}"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="gstreamer"
+
+RDEPEND="
+ $(python_gen_cond_dep '
+ dev-python/pexpect[${PYTHON_USEDEP}]
+ dev-python/psutil[${PYTHON_USEDEP}]
+ dev-python/pycairo[${PYTHON_USEDEP}]
+ dev-python/pygobject:3[${PYTHON_USEDEP},cairo]
+ dev-python/sqlalchemy[${PYTHON_USEDEP},sqlite]
+ dev-python/websockets[${PYTHON_USEDEP}]
+ gstreamer? ( dev-python/gst-python:1.0[${PYTHON_USEDEP}] )')
+ gnome-base/librsvg:2[introspection]
+ x11-libs/gtk+:3[introspection]
+ x11-libs/gtksourceview:3.0[introspection]
+ x11-libs/pango[introspection]
+ x11-themes/adwaita-icon-theme"
+BDEPEND="${RDEPEND}" # setup.py fails if introspection deps not found
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.0.3-setuptools-warning.patch
+)
+
+src_install() {
+ distutils-r1_src_install
+
+ # https://github.com/pychess/pychess/pull/1825
+ gunzip -v "${ED}"/usr/share/man/man1/${PN}.1.gz || die
+}
diff --git a/games-board/pychess/pychess-1.0.3.ebuild b/games-board/pychess/pychess-1.0.3.ebuild
deleted file mode 100644
index 849abb618dea..000000000000
--- a/games-board/pychess/pychess-1.0.3.ebuild
+++ /dev/null
@@ -1,52 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{7,8,9} )
-DISTUTILS_SINGLE_IMPL=1
-DISTUTILS_USE_SETUPTOOLS=no
-PYTHON_REQ_USE="sqlite"
-
-inherit xdg distutils-r1
-
-DESCRIPTION="A chess client for GNOME"
-HOMEPAGE="https://github.com/pychess/pychess"
-SRC_URI="https://github.com/${PN}/${PN}/releases/download/${PV}/${P}.tar.gz"
-S="${WORKDIR}/PyChess-${PV}"
-
-LICENSE="GPL-3"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="gstreamer"
-
-DEPEND="
- $(python_gen_cond_dep '
- dev-python/pexpect[${PYTHON_USEDEP}]
- dev-python/psutil[${PYTHON_USEDEP}]
- dev-python/pycairo[${PYTHON_USEDEP}]
- dev-python/pygobject:3[${PYTHON_USEDEP}]
- dev-python/sqlalchemy[${PYTHON_USEDEP},sqlite]
- dev-python/websockets[${PYTHON_USEDEP}]
- ')
- gnome-base/librsvg:2
- x11-libs/gtksourceview:3.0
- x11-libs/pango
- x11-themes/adwaita-icon-theme
- gstreamer? (
- $(python_gen_cond_dep '
- dev-python/gst-python:1.0[${PYTHON_USEDEP}]
- ')
- media-libs/gstreamer:1.0
- media-libs/gst-plugins-base:1.0
- )
-"
-
-RDEPEND="${DEPEND}"
-
-src_install() {
- distutils-r1_src_install
-
- # https://github.com/pychess/pychess/pull/1825
- gunzip -v "${ED}"/usr/share/man/man1/${PN}.1.gz || die
-}