summaryrefslogtreecommitdiff
path: root/games-board/natch/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-07-19 22:05:27 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-07-19 22:05:27 +0100
commit121ed4eec41fbf03e1998d09eede1bf449da63b9 (patch)
treece9341d77d1507f67d4a3a1472da9011b5baa0a8 /games-board/natch/files
parentdd762ff83c330186ee2ede002e08b2f780cddd51 (diff)
gentoo resync : 19.07.2019
Diffstat (limited to 'games-board/natch/files')
-rw-r--r--games-board/natch/files/natch-2.4-tinfo.patch39
1 files changed, 39 insertions, 0 deletions
diff --git a/games-board/natch/files/natch-2.4-tinfo.patch b/games-board/natch/files/natch-2.4-tinfo.patch
new file mode 100644
index 000000000000..92646aa54bba
--- /dev/null
+++ b/games-board/natch/files/natch-2.4-tinfo.patch
@@ -0,0 +1,39 @@
+https://bugs.gentoo.org/690078
+
+--- Natch-2.4/configure.in
++++ Natch-2.4/configure.in
+@@ -25,17 +25,19 @@
+ dnl Checks for programs.
+ AC_PROG_CC
+ AC_PATH_PROGS(GENGETOPT, gengetopt)
++PKG_PROG_PKG_CONFIG
+
+ dnl for txtc (Text-to-C compiler)
+ AC_PROG_AWK
+ LF_PROG_TXTC
+
+ dnl Checks for libraries.
+-AC_SEARCH_LIBS(
+- initscr,
+- ncurses curses,
++PKG_CHECK_MODULES(NCURSES, ncurses,[
+ AC_DEFINE(HAVE_LIBNCURSES,,
+- Define if you have curses library for visual mode. ), )
++ Define if you have curses library for visual mode. )
++ ],[
++ AC_MSG_ERROR([Cannot find ncurses lib])
++])
+
+ dnl Replace `main' with a function in -lpc:
+ dnl AC_CHECK_LIB(pc, main)
+--- Natch-2.4/src/Makefile.am
++++ Natch-2.4/src/Makefile.am
+@@ -29,7 +29,7 @@
+
+ Natch_SOURCES = main.c main.h types.h cmdline.c cmdline.h distance.c distance.h dis_type.h pcpj.c pcpj.h distimmo.c distimmo.h pcpj_deb.c pcpj_deb.h pcpjcapt.c pcpjcapt.h trajet.c trajet.h explorat.c explorat.h expltype.h pcpjcoup.c pcpjcoup.h hash.c hash.h pcpjtool.c pcpjtool.h myHashTable.c myHashTable.h langues.c langues.h screen.c screen.h common.h moves_order.c moves_order.h test_moves_order.c test_moves_order.h twin_squares.c twin_squares.h precise_trajectories.c precise_trajectories.h captInitSquare.c captInitSquare.h piece.c piece.h reportbugs.text copyright.text
+
+-Natch_LDADD = @LIBOBJS@
++Natch_LDADD = @LIBOBJS@ $(NCURSES_LIBS)
+
+ AM_CFLAGS = -Wall -fshort-enums -DNDEBUG -O3
+ #AM_CFLAGS = -Wall -fshort-enums