summaryrefslogtreecommitdiff
path: root/games-board/mt_ncurses_client/mt_ncurses_client-0.1.98-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-03-20 14:27:17 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-03-20 14:27:17 +0000
commit5bb9ff1ee56d2b5e75e01a7f066d8b0cec84ec02 (patch)
tree66e860a5099bcad013f1cf667255dc372a7c11b3 /games-board/mt_ncurses_client/mt_ncurses_client-0.1.98-r1.ebuild
parent7218e1b46bceac05841e90472501742d905fb3fc (diff)
gentoo resync : 20.03.2021
Diffstat (limited to 'games-board/mt_ncurses_client/mt_ncurses_client-0.1.98-r1.ebuild')
-rw-r--r--games-board/mt_ncurses_client/mt_ncurses_client-0.1.98-r1.ebuild24
1 files changed, 19 insertions, 5 deletions
diff --git a/games-board/mt_ncurses_client/mt_ncurses_client-0.1.98-r1.ebuild b/games-board/mt_ncurses_client/mt_ncurses_client-0.1.98-r1.ebuild
index f2228134f6dd..b9aba21f1406 100644
--- a/games-board/mt_ncurses_client/mt_ncurses_client-0.1.98-r1.ebuild
+++ b/games-board/mt_ncurses_client/mt_ncurses_client-0.1.98-r1.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
-inherit toolchain-funcs
+inherit autotools toolchain-funcs
DESCRIPTION="client for the french tarot game maitretarot"
HOMEPAGE="http://www.nongnu.org/maitretarot/"
@@ -12,19 +12,33 @@ SRC_URI="https://savannah.nongnu.org/download/maitretarot/${PN}.pkg/${PV}/${P}.t
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE=""
+BDEPEND="virtual/pkgconfig"
DEPEND="dev-libs/glib:2
dev-libs/libxml2
dev-games/libmaitretarot
dev-games/libmt_client
sys-libs/ncurses:0"
-RDEPEND=${DEPEND}
+RDEPEND="${DEPEND}"
PATCHES=(
"${FILESDIR}"/${P}-format.patch
)
+src_prepare() {
+ default
+
+ mv configure.{in,ac} || die
+
+ # Remove bundled macros (avoid patching same file multiple times)
+ rm -rf m4/{libmaitretarot,libmt_client}.m4 || die
+
+ # Ensure we generate auto* with the fixed macros in tree
+ # (not bundled)
+ # bug #716102
+ eautoreconf
+}
+
src_configure() {
export LIBS="$( $(tc-getPKG_CONFIG) --libs ncurses )"
default