summaryrefslogtreecommitdiff
path: root/games-board/holdingnuts
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-01-02 14:45:16 +0000
committerV3n3RiX <venerix@redcorelinux.org>2018-01-02 14:45:16 +0000
commita70f42c65202d88c203c40910fef8f96f333d1ee (patch)
treede550ee3deb79c550ae1aba7fcce118d5d4dbc31 /games-board/holdingnuts
parent721254b86a09bdedd5eefd0de7899c90ea2ead1a (diff)
gentoo resync : 02.01.2018
Diffstat (limited to 'games-board/holdingnuts')
-rw-r--r--games-board/holdingnuts/Manifest4
-rw-r--r--games-board/holdingnuts/files/holdingnuts-0.0.5-wheel.patch17
-rw-r--r--games-board/holdingnuts/holdingnuts-0.0.5-r2.ebuild54
-rw-r--r--games-board/holdingnuts/metadata.xml11
4 files changed, 0 insertions, 86 deletions
diff --git a/games-board/holdingnuts/Manifest b/games-board/holdingnuts/Manifest
deleted file mode 100644
index 435c53e3d03d..000000000000
--- a/games-board/holdingnuts/Manifest
+++ /dev/null
@@ -1,4 +0,0 @@
-AUX holdingnuts-0.0.5-wheel.patch 572 BLAKE2B 24f1b2a030522d53892afa9cb1a6060ee522b7470ebe9cb941084edb39950c782af962cefcc97f20c1989ec76d6724975726adc613a4b24bddb2f15f8da371af SHA512 eb6041b803fab42f78917dc5138d08b2ff7fe3d9aee03b60a250b78744af1ff315008b21e395894e561c794f46a0ebe5b5dc25fb233038a6965e021ef1239f4d
-DIST holdingnuts-0.0.5.tar.bz2 1456227 BLAKE2B 638cd28e997e0b3d86b1ee4b857db02d336ef38495261d890fdc8252918487050a228f2cde367b24f485cef290b22df9042e8111b821491fc0635bffa0e0b8fc SHA512 95eb6d73c5b72c10bf04a03f9fb039bb1573ef74b6a3c820d5cc79fb81b8c6e2df24c5266a4067f4044ce050ba29bf1e2c65c46de50dd7cd3beac4736397053a
-EBUILD holdingnuts-0.0.5-r2.ebuild 1069 BLAKE2B ee1988e91ecddc41d7697d056c1f52d1759bfad3fe823e3756088c378309c4b562a5b0015154935d403853b4f862e472940c31c1ad242a1335ea1dd88d6dada5 SHA512 380bfd541fe187b0e9502e4ef1398c979c05aef2ff2f9dd3c6a31532c3ee3665942693fa14b92bd8ccfb20c813c800894449cf87ab0c191b7837066992e84104
-MISC metadata.xml 342 BLAKE2B 98dbf3e9e55a588512c8cc83fd73a4706fc05865ed277945bd222121ad18e3de2a0082c2b0f7dde1350f419fd16cae7d223a8a682fbdec9ed797296ec0dd24dc SHA512 ef866e273f29f8ad7f511174ab9a8cbd68e3a235b2ca116ce76995afd082e5492b56e04dc6017effba82986fd4ffa8de045ac1e1ebad1af05d25f95c9e099cc1
diff --git a/games-board/holdingnuts/files/holdingnuts-0.0.5-wheel.patch b/games-board/holdingnuts/files/holdingnuts-0.0.5-wheel.patch
deleted file mode 100644
index c5993b64bb8c..000000000000
--- a/games-board/holdingnuts/files/holdingnuts-0.0.5-wheel.patch
+++ /dev/null
@@ -1,17 +0,0 @@
-Description: fixed gamelogic bug with wheel-straight: check suit of ace if testing for straight-flush
-Origin: https://sourceforge.net/apps/trac/holdingnuts/changeset/741
---- a/src/libpoker/GameLogic.cpp
-+++ b/src/libpoker/GameLogic.cpp
-@@ -179,7 +179,11 @@
-
- // is an A2345-straight ("wheel")
- if (count == 4 && (last_face == Card::Two && allcards->front().getFace() == Card::Ace))
-- is_straight = true;
-+ {
-+ // check suit when testing for StraightFlush
-+ if (suit == -1 || allcards->front().getSuit() == suit)
-+ is_straight = true;
-+ }
-
- if (is_straight)
- { \ No newline at end of file
diff --git a/games-board/holdingnuts/holdingnuts-0.0.5-r2.ebuild b/games-board/holdingnuts/holdingnuts-0.0.5-r2.ebuild
deleted file mode 100644
index daad81defad1..000000000000
--- a/games-board/holdingnuts/holdingnuts-0.0.5-r2.ebuild
+++ /dev/null
@@ -1,54 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-inherit eutils cmake-utils
-
-DESCRIPTION="An open source poker client and server"
-HOMEPAGE="http://www.holdingnuts.net/"
-SRC_URI="http://downloads.sourceforge.net/${PN}/${P}.tar.bz2"
-
-LICENSE="GPL-3"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="alsa debug dedicated"
-
-RDEPEND="
- !dedicated? (
- dev-qt/qtcore:4
- dev-qt/qtgui:4
- alsa? ( >=media-libs/libsdl-1.2.10:0[alsa] )
- )"
-
-DEPEND="${RDEPEND}
- >=dev-util/cmake-2.6.3"
-
-PATCHES=(
- "${FILESDIR}"/${P}-wheel.patch # upstream patch (bug #307901)
-)
-
-src_prepare() {
- cmake-utils_src_prepare
-
- sed -i -e '/^Path/d' holdingnuts.desktop || die
-}
-
-src_configure() {
- local mycmakeargs=(-DWITH_AUDIO=$(usex alsa)
- -DENABLE_CLIENT=$(usex !dedicated)
- -DWITH_DEBUG=$(usex debug))
- cmake-utils_src_configure
-}
-
-src_install() {
- cmake-utils_src_install
-
- if ! use dedicated ; then
- domenu ${PN}.desktop
- doicon ${PN}.png
- doman docs/${PN}.6
- fi
-
- dodoc ChangeLog docs/protocol_spec.txt
- doman docs/${PN}-server.6
-}
diff --git a/games-board/holdingnuts/metadata.xml b/games-board/holdingnuts/metadata.xml
deleted file mode 100644
index 882df6af6590..000000000000
--- a/games-board/holdingnuts/metadata.xml
+++ /dev/null
@@ -1,11 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <maintainer type="project">
- <email>games@gentoo.org</email>
- <name>Gentoo Games Project</name>
- </maintainer>
- <upstream>
- <remote-id type="sourceforge">downloads</remote-id>
- </upstream>
-</pkgmetadata>