summaryrefslogtreecommitdiff
path: root/games-board/gnugo/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-06-29 11:38:31 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-06-29 11:38:31 +0100
commit90c88731bd036e5698b281fbc0a5f3aa4c9983ac (patch)
tree83fc5facb6b12be510a37bc3d241cc63e965b13a /games-board/gnugo/files
parentfeb0daf81d888e9160f9f94502de09b66f2a63fd (diff)
gentoo resync : 29.06.2020
Diffstat (limited to 'games-board/gnugo/files')
-rw-r--r--games-board/gnugo/files/gnugo-3.9.1-autotools.patch10
-rw-r--r--games-board/gnugo/files/gnugo-3.9.1-fno-common.patch25
2 files changed, 35 insertions, 0 deletions
diff --git a/games-board/gnugo/files/gnugo-3.9.1-autotools.patch b/games-board/gnugo/files/gnugo-3.9.1-autotools.patch
new file mode 100644
index 000000000000..79e28fa9b7bf
--- /dev/null
+++ b/games-board/gnugo/files/gnugo-3.9.1-autotools.patch
@@ -0,0 +1,10 @@
+--- a/configure.in
++++ b/configure.in
+@@ -151,6 +151,7 @@
+
+ AC_PROG_CPP
+ AC_PROG_RANLIB
++AM_PROG_AR
+
+ dnl required since we use SUBDIRS in Makefile.am
+ AC_PROG_MAKE_SET
diff --git a/games-board/gnugo/files/gnugo-3.9.1-fno-common.patch b/games-board/gnugo/files/gnugo-3.9.1-fno-common.patch
new file mode 100644
index 000000000000..db8215ecf90f
--- /dev/null
+++ b/games-board/gnugo/files/gnugo-3.9.1-fno-common.patch
@@ -0,0 +1,25 @@
+--- a/engine/globals.c
++++ b/engine/globals.c
+@@ -136,6 +136,9 @@
+ * move generation is enabled.
+ */
+
++int meaningless_white_moves[BOARDMAX];
++int meaningless_black_moves[BOARDMAX];
++
+ float best_move_values[10];
+ int best_moves[10];
+ float white_score;
+--- a/engine/liberty.h
++++ b/engine/liberty.h
+@@ -859,8 +859,8 @@
+ extern struct worm_data worm[BOARDMAX];
+
+ /* Unconditionally meaningless moves. */
+-int meaningless_black_moves[BOARDMAX];
+-int meaningless_white_moves[BOARDMAX];
++extern int meaningless_black_moves[BOARDMAX];
++extern int meaningless_white_moves[BOARDMAX];
+
+ /* Surround cache (see surround.c) */
+