summaryrefslogtreecommitdiff
path: root/games-board/gnono/gnono-1.9.1-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /games-board/gnono/gnono-1.9.1-r1.ebuild
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'games-board/gnono/gnono-1.9.1-r1.ebuild')
-rw-r--r--games-board/gnono/gnono-1.9.1-r1.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/games-board/gnono/gnono-1.9.1-r1.ebuild b/games-board/gnono/gnono-1.9.1-r1.ebuild
new file mode 100644
index 000000000000..9d5ede968dd4
--- /dev/null
+++ b/games-board/gnono/gnono-1.9.1-r1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit autotools eutils gnome2-utils
+
+DESCRIPTION="A rewrite for GNOME of the Windows card game WUNO"
+HOMEPAGE="https://sourceforge.net/projects/gnono/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="gnome-base/libgnomeui
+ virtual/libintl"
+DEPEND="${RDEPEND}
+ sys-devel/gettext"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-gentoo.patch
+ "${FILESDIR}"/${P}-glib-single-include.patch
+)
+
+src_prepare() {
+ default
+
+ eautoreconf
+}
+
+pkg_preinst() {
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}