summaryrefslogtreecommitdiff
path: root/games-board/gnome-mines/gnome-mines-3.30.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-09-15 17:37:09 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-09-15 17:37:09 +0100
commit586819755b4dbfdffdc8a725ab7c0f86095b8489 (patch)
treed6790c838cfe9607c996e4913fdf11bad5fdd528 /games-board/gnome-mines/gnome-mines-3.30.0.ebuild
parent3f71901f8c228f4de570abed1831ce3ee425343e (diff)
gentoo resync : 15.09.2018
Diffstat (limited to 'games-board/gnome-mines/gnome-mines-3.30.0.ebuild')
-rw-r--r--games-board/gnome-mines/gnome-mines-3.30.0.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/games-board/gnome-mines/gnome-mines-3.30.0.ebuild b/games-board/gnome-mines/gnome-mines-3.30.0.ebuild
new file mode 100644
index 000000000000..618e75d16dc0
--- /dev/null
+++ b/games-board/gnome-mines/gnome-mines-3.30.0.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit gnome.org gnome2-utils meson vala xdg
+
+DESCRIPTION="Clear hidden mines from a minefield"
+HOMEPAGE="https://wiki.gnome.org/Apps/Mines"
+
+LICENSE="GPL-3+ CC-BY-SA-3.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="
+ >=dev-libs/glib-2.40:2
+ dev-libs/libgee:0.8
+ >=x11-libs/gtk+-3.12:3
+ dev-libs/libgnome-games-support:1=
+ >=gnome-base/librsvg-2.32.0:2
+"
+DEPEND="${RDEPEND}
+ $(vala_depend)
+ dev-libs/appstream-glib
+ dev-libs/libxml2:2
+ dev-util/itstool
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+"
+
+src_prepare() {
+ xdg_src_prepare
+ vala_src_prepare
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_icon_cache_update
+ gnome2_schemas_update
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_icon_cache_update
+ gnome2_schemas_update
+}