summaryrefslogtreecommitdiff
path: root/games-board/fruit/fruit-2.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /games-board/fruit/fruit-2.1.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'games-board/fruit/fruit-2.1.ebuild')
-rw-r--r--games-board/fruit/fruit-2.1.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/games-board/fruit/fruit-2.1.ebuild b/games-board/fruit/fruit-2.1.ebuild
new file mode 100644
index 000000000000..db7aa8211ead
--- /dev/null
+++ b/games-board/fruit/fruit-2.1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+inherit eutils versionator games
+
+MY_PV=$(replace_all_version_separators '')
+MY_P=${PN}_${MY_PV}_linux
+DESCRIPTION="UCI-only chess engine"
+HOMEPAGE="http://arctrix.com/nas/fruit/"
+SRC_URI="http://arctrix.com/nas/${PN}/${MY_P}.zip"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+RDEPEND=""
+DEPEND="app-arch/unzip"
+
+S=${WORKDIR}/${MY_P}/src
+
+src_prepare() {
+ epatch "${FILESDIR}/${P}"-gentoo.patch
+ sed -i \
+ -e "s:@GENTOO_DATADIR@:${GAMES_DATADIR}/${PN}:" \
+ option.cpp || die
+ sed -i \
+ -e '/^CXX/d' \
+ -e '/^LDFLAGS/d' \
+ Makefile || die
+}
+
+src_install() {
+ dogamesbin ${PN}
+ insinto "${GAMES_DATADIR}/${PN}"
+ doins ../book_small.bin
+ dodoc ../readme.txt ../technical_10.txt
+ prepgamesdirs
+}
+
+pkg_postinst() {
+ games_pkg_postinst
+ elog "To use this engine you need to install a UCI chess GUI"
+ elog "e.g. games-board/glchess"
+}