summaryrefslogtreecommitdiff
path: root/games-board/four-in-a-row
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-03-27 06:06:27 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-03-27 06:06:27 +0000
commit8d5dbd847cbc704a6a06405856e94b461011afe3 (patch)
tree4d26462d027b14926335894749d2e01d982234d0 /games-board/four-in-a-row
parent5bb9ff1ee56d2b5e75e01a7f066d8b0cec84ec02 (diff)
gentoo resync : 27.03.2021
Diffstat (limited to 'games-board/four-in-a-row')
-rw-r--r--games-board/four-in-a-row/Manifest2
-rw-r--r--games-board/four-in-a-row/four-in-a-row-3.38.1.ebuild46
2 files changed, 48 insertions, 0 deletions
diff --git a/games-board/four-in-a-row/Manifest b/games-board/four-in-a-row/Manifest
index 85fe9591a028..83bbbb9fb005 100644
--- a/games-board/four-in-a-row/Manifest
+++ b/games-board/four-in-a-row/Manifest
@@ -1,3 +1,5 @@
DIST four-in-a-row-3.36.4.tar.xz 558244 BLAKE2B 63a61de3150fe067faebffc021f78398a267b0788e5353d6953dbf6b6836a21901f9bb8f498872a083b1d8c9ccd9dfe2a58c529e2655959084a64102f2ac4d3b SHA512 5f73f2b2548c9b9dfdf1310cdb22c65e7f96135367d55e113b1c779ed21aab5ed01eaaa009c346035a222fa8c87c6224334d546407963a90f068b5ca8ae1b58d
+DIST four-in-a-row-3.38.1.tar.xz 565408 BLAKE2B ac7991404707d1dff5a1819d7844da799e47c185eacc265312af06065b89f3ab787582c5a718de0342894a61c617a809f874a2a7b67e7f6f106862147c6b4feb SHA512 f30dd912e0dc9f4b59706de96b216428c7fd2deac5686cfe1e4e8be9923862bf767b7533d29aa59cf3e631c7a13e5b9d2fcfc18fc20559778fd0102cc32b5835
EBUILD four-in-a-row-3.36.4.ebuild 934 BLAKE2B 1df0ef48fd99b8b77af105be86dc7e1635b30e5d07c553fd2c3b3a12cb24c155defb5a61c23428d3591acba61dae5924759bc1cb8d84e81ae5c91b51e4741360 SHA512 b5624d550927698301651981135070b51891f6ce078f4ab3cb97a6d3d515f4992de7cbc1cabb4fb7722f3ac1894da9016fc5b23d41ad452e2418fdc17374230b
+EBUILD four-in-a-row-3.38.1.ebuild 972 BLAKE2B 5615aff9d4a20197f8204dd4897b2d0ab3e19de35c36a6ff24bbdde038ddc8494c1328ba0724dae8c36c90db9435d8f577a39ab0f94b2eefad22871a204d671a SHA512 70e4c606912b883d4b8891a464992b873da957be457c0b8bfa6e68bc528080b134ca5920e60660208e60757a973627f8245c4cbfea2e500bf447f80bd1f7c4cf
MISC metadata.xml 249 BLAKE2B e71e1b95fee768c696704acbf7e3cf0e599ed2bc8de92bae0141d1194ef9e842bdc292798904487a9b90ddfda9b0e84abd3b76b1518576c1d288240e4e46f110 SHA512 c40662134899a5c9f0369a1017806f35adf3280a0b3c91726f7a8ca6012a073a8b471583f5bfb6fe95faac1dcf607e8e2e43f8c91d48ec46f4a8824e2f551506
diff --git a/games-board/four-in-a-row/four-in-a-row-3.38.1.ebuild b/games-board/four-in-a-row/four-in-a-row-3.38.1.ebuild
new file mode 100644
index 000000000000..d862dd8a2b1f
--- /dev/null
+++ b/games-board/four-in-a-row/four-in-a-row-3.38.1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+VALA_MIN_API_VERSION="0.44"
+inherit gnome.org gnome2-utils meson vala xdg
+
+DESCRIPTION="Make lines of the same color to win"
+HOMEPAGE="https://wiki.gnome.org/Apps/Four-in-a-row https://gitlab.gnome.org/GNOME/four-in-a-row"
+
+# Code and most themes are GPL-3+, CC-BY-SA-3.0 is user help license in v3.32.0
+LICENSE="GPL-3+ CC-BY-SA-3.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+
+RDEPEND="
+ >=dev-libs/glib-2.40.0:2
+ >=media-libs/gsound-1.0.2
+ >=x11-libs/gtk+-3.24.0:3
+ >=gnome-base/librsvg-2.32.0
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ dev-libs/appstream-glib
+ dev-util/itstool
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+ $(vala_depend)
+ media-libs/gsound[vala]
+ gnome-base/librsvg[vala]
+"
+
+src_prepare() {
+ xdg_src_prepare
+ vala_src_prepare
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_schemas_update
+}