summaryrefslogtreecommitdiff
path: root/games-board/four-in-a-row
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-04-12 03:41:30 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-04-12 03:41:30 +0100
commit623ee73d661e5ed8475cb264511f683407d87365 (patch)
tree993eb27c93ec7a2d2d19550300d888fc1fed9e69 /games-board/four-in-a-row
parentceeeb463cc1eef97fd62eaee8bf2196ba04bc384 (diff)
gentoo Easter resync : 12.04.2020
Diffstat (limited to 'games-board/four-in-a-row')
-rw-r--r--games-board/four-in-a-row/Manifest2
-rw-r--r--games-board/four-in-a-row/four-in-a-row-3.34.4.ebuild46
2 files changed, 48 insertions, 0 deletions
diff --git a/games-board/four-in-a-row/Manifest b/games-board/four-in-a-row/Manifest
index 7f6221b64938..438f704e1180 100644
--- a/games-board/four-in-a-row/Manifest
+++ b/games-board/four-in-a-row/Manifest
@@ -1,3 +1,5 @@
DIST four-in-a-row-3.32.0.tar.xz 507596 BLAKE2B 8253c1f44d7c3e27d2e3fe64984aff5485569496d85a77a48b2fd67fee065377f4667b92524481838787c0b7f27e16250b0aa1bc53ff470624f9da92187b7e44 SHA512 f74dcb072c4da03b8cfc274d92a0eda8ca1fbea4b216b4add793155ae63bd8cc1c784ea2b553a198616dbc2254bb1d5567ddc1608f027eaf6e0a594741a2ab96
+DIST four-in-a-row-3.34.4.tar.xz 508780 BLAKE2B 4528642e82438c52706d068d01f5d167f83f4b6dc0a9883bd95a046d9c9772ac642f27f0b1b1197a4ce81b3b5a5a14ce7f9ed8eacbaca189692c0a3c34faeda1 SHA512 7bdfbf1c8953175af8dccbe0514215349a48246f949723628a940db6e5b1e3d89990aa57b5994e5460a79db19ba207de939fe81da53d5782a762695d1588776f
EBUILD four-in-a-row-3.32.0.ebuild 864 BLAKE2B b33ea491bfae7293f6e59a145c40fad20b8e3ec70b8a3747bb9b73c426f6058b04dfbf3259e559ab701181ad9808c453221b82c9ffcb24121e3d34f02aaec8f1 SHA512 19bbf9805b63ef0812a7b43cf716c14ca4062f66e98bb5e8f9d285713bd22e2cc4b5563fe7f4507aa79f80f1d5f6abf55db14d20f62601fcfb98f461a66dd819
+EBUILD four-in-a-row-3.34.4.ebuild 902 BLAKE2B 4fb9c1d4f4876cce2c0f20f063b67321f52c08b005a310f140d1851006334ae157baede2d726637fb3b1041b068fb4f174af2718e9f5809e426fcf811bad54e7 SHA512 23cd1f1091b3a01fc6a28b4151c093ca0d8b49441726586ce1ddfab1a82e0eebb0b7eeb634a51d64aef4347807d3d64ad365f90d0c035f0410f190c7f5421df2
MISC metadata.xml 249 BLAKE2B e71e1b95fee768c696704acbf7e3cf0e599ed2bc8de92bae0141d1194ef9e842bdc292798904487a9b90ddfda9b0e84abd3b76b1518576c1d288240e4e46f110 SHA512 c40662134899a5c9f0369a1017806f35adf3280a0b3c91726f7a8ca6012a073a8b471583f5bfb6fe95faac1dcf607e8e2e43f8c91d48ec46f4a8824e2f551506
diff --git a/games-board/four-in-a-row/four-in-a-row-3.34.4.ebuild b/games-board/four-in-a-row/four-in-a-row-3.34.4.ebuild
new file mode 100644
index 000000000000..3dd8ca7f4c4b
--- /dev/null
+++ b/games-board/four-in-a-row/four-in-a-row-3.34.4.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit gnome.org gnome2-utils meson vala xdg
+
+DESCRIPTION="Make lines of the same color to win"
+HOMEPAGE="https://wiki.gnome.org/Apps/Four-in-a-row"
+
+# Code and most themes are GPL-3+, CC-BY-SA-3.0 is user help license in v3.32.0
+LICENSE="GPL-3+ CC-BY-SA-3.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE=""
+
+RDEPEND="
+ >=dev-libs/glib-2.40.0:2
+ >=media-libs/gsound-1.0.2
+ >=x11-libs/gtk+-3.13.2:3
+ >=gnome-base/librsvg-2.32.0
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ dev-libs/appstream-glib
+ dev-util/itstool
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+ $(vala_depend)
+ media-libs/gsound[vala]
+ gnome-base/librsvg[vala]
+"
+
+src_prepare() {
+ xdg_src_prepare
+ vala_src_prepare
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_schemas_update
+}