summaryrefslogtreecommitdiff
path: root/games-board/four-in-a-row
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-10-13 22:19:36 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-10-14 23:22:23 +0100
commit4b19be30aa626b327c885dae62c559ec0e9fb935 (patch)
tree76e74807bc479502e13866b581b6bf86734ec634 /games-board/four-in-a-row
parent30d6f67c98d149508509d5e86f176d558793acc0 (diff)
gentoo resync : 13.10.2019
Diffstat (limited to 'games-board/four-in-a-row')
-rw-r--r--games-board/four-in-a-row/Manifest2
-rw-r--r--games-board/four-in-a-row/four-in-a-row-3.32.0.ebuild44
2 files changed, 46 insertions, 0 deletions
diff --git a/games-board/four-in-a-row/Manifest b/games-board/four-in-a-row/Manifest
index 6ac4744ecf03..0ea4917b664c 100644
--- a/games-board/four-in-a-row/Manifest
+++ b/games-board/four-in-a-row/Manifest
@@ -1,3 +1,5 @@
DIST four-in-a-row-3.28.0.tar.xz 740784 BLAKE2B f5d2af3514e7629026da5f1aedf22945eddb44b6917922d175f4e5aa160ea7266e0ab101866c1d5220d0e835e60544e4ec8fc6016d908e580a7b1057fc8db7f0 SHA512 a13d6db2c32cc19e8504c1e8baa7b0e28f59e3fc604940d51742d3fd2b266ac90a92e638df2449bcca5e828923c7ee9ff1424a095a98fd5e1d76426a444d7ede
+DIST four-in-a-row-3.32.0.tar.xz 507596 BLAKE2B 8253c1f44d7c3e27d2e3fe64984aff5485569496d85a77a48b2fd67fee065377f4667b92524481838787c0b7f27e16250b0aa1bc53ff470624f9da92187b7e44 SHA512 f74dcb072c4da03b8cfc274d92a0eda8ca1fbea4b216b4add793155ae63bd8cc1c784ea2b553a198616dbc2254bb1d5567ddc1608f027eaf6e0a594741a2ab96
EBUILD four-in-a-row-3.28.0.ebuild 672 BLAKE2B fdac565b22bcde39aacce379c839924b54e24f9cdcc54d7fb45185163b7b3e8f97e4177934826593b1c7574e31ef8ff5ccf31db5fc6953d87215d2e9f30d636f SHA512 fd6a713c98e2ea7a7721f09504a25fa9f5cfc0f81379c2d05243bc8e35a570d4833fb68124ed8a6127894572368729c792647dc63d128ea220eb9ca0f589a40a
+EBUILD four-in-a-row-3.32.0.ebuild 866 BLAKE2B 4b8f0f9cafaead8ac619155b5e9fc27422aaa35ef0c08b67b96781e9c32dea87ffd4742f66f39b8181157710b6c5d38c79a5019771cc139dbbcae754ec49c1fa SHA512 d524bc939250db266cd58f4e969701db16785b9607d22f97cc694638079061aa2becb6959bdacffddd8868fdcfc3befe62ad38a646beb49b5d9f63f261699c54
MISC metadata.xml 249 BLAKE2B e71e1b95fee768c696704acbf7e3cf0e599ed2bc8de92bae0141d1194ef9e842bdc292798904487a9b90ddfda9b0e84abd3b76b1518576c1d288240e4e46f110 SHA512 c40662134899a5c9f0369a1017806f35adf3280a0b3c91726f7a8ca6012a073a8b471583f5bfb6fe95faac1dcf607e8e2e43f8c91d48ec46f4a8824e2f551506
diff --git a/games-board/four-in-a-row/four-in-a-row-3.32.0.ebuild b/games-board/four-in-a-row/four-in-a-row-3.32.0.ebuild
new file mode 100644
index 000000000000..51c29bdc0d51
--- /dev/null
+++ b/games-board/four-in-a-row/four-in-a-row-3.32.0.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit gnome.org gnome2-utils meson vala xdg
+
+DESCRIPTION="Make lines of the same color to win"
+HOMEPAGE="https://wiki.gnome.org/Apps/Four-in-a-row"
+
+# Code and most themes are GPL-3+, CC-BY-SA-3.0 is user help license in v3.32.0
+LICENSE="GPL-3+ CC-BY-SA-3.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+IUSE=""
+
+RDEPEND="
+ >=dev-libs/glib-2.40.0:2
+ >=x11-libs/gtk+-3.13.2:3
+ >=gnome-base/librsvg-2.32.0
+ >=media-libs/libcanberra-0.26[gtk3]
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ $(vala_depend)
+ dev-libs/appstream-glib
+ dev-util/itstool
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+"
+
+src_prepare() {
+ xdg_src_prepare
+ vala_src_prepare
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_schemas_update
+}