summaryrefslogtreecommitdiff
path: root/games-arcade/xtux/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /games-arcade/xtux/files
reinit the tree, so we can have metadata
Diffstat (limited to 'games-arcade/xtux/files')
-rw-r--r--games-arcade/xtux/files/xtux-20030306-ldflags.patch22
-rw-r--r--games-arcade/xtux/files/xtux-20030306-particles.patch30
2 files changed, 52 insertions, 0 deletions
diff --git a/games-arcade/xtux/files/xtux-20030306-ldflags.patch b/games-arcade/xtux/files/xtux-20030306-ldflags.patch
new file mode 100644
index 000000000000..d2c798d0795d
--- /dev/null
+++ b/games-arcade/xtux/files/xtux-20030306-ldflags.patch
@@ -0,0 +1,22 @@
+--- src/client/Makefile.old 2010-09-30 18:08:16.000000000 +0200
++++ src/client/Makefile 2010-09-30 18:08:41.000000000 +0200
+@@ -48,7 +48,7 @@
+
+ #Apps
+ client: $(OBJECTS)
+- $(CC) -o $(BINARY) $(CFLAGS) $(OBJECTS) $(XTUXLIB) $(MATHLIB) $(X11LIB) $(XPMLIB) $(SOCKLIB) $(GGZLIB)
++ $(CC) -o $(BINARY) $(LDFLAGS) $(CFLAGS) $(OBJECTS) $(XTUXLIB) $(MATHLIB) $(X11LIB) $(XPMLIB) $(SOCKLIB) $(GGZLIB)
+
+ # OBJECTS
+ .c.o: client.h $*.c
+--- src/server/Makefile.old 2010-09-30 18:09:55.000000000 +0200
++++ src/server/Makefile 2010-09-30 18:10:16.000000000 +0200
+@@ -41,7 +41,7 @@
+
+ #Apps
+ server: $(OBJECTS)
+- $(CC) -o $(BINARY) $(OBJECTS) $(XTUXLIB) $(MATHLIB) $(SOCKLIB) $(GGZLIB)
++ $(CC) $(LDFLAGS) -o $(BINARY) $(OBJECTS) $(XTUXLIB) $(MATHLIB) $(SOCKLIB) $(GGZLIB)
+
+ # OBJECTS
+ .c.o: server.h $*.h $*.c
diff --git a/games-arcade/xtux/files/xtux-20030306-particles.patch b/games-arcade/xtux/files/xtux-20030306-particles.patch
new file mode 100644
index 000000000000..9a340821dd6e
--- /dev/null
+++ b/games-arcade/xtux/files/xtux-20030306-particles.patch
@@ -0,0 +1,30 @@
+diff -u -r xtux.old/src/client/particle.c xtux/src/client/particle.c
+--- xtux.old/src/client/particle.c 2008-09-02 20:34:24.000000000 +0200
++++ xtux/src/client/particle.c 2008-09-02 20:35:40.000000000 +0200
+@@ -340,11 +340,11 @@
+ ptl->pos[i].y = src_y;
+ d = dir + 128;
+ d += i%SHARD_ANGLE - SHARD_ANGLE/2;
+- ptl->vel[i].x = sin_lookup[dir + 64 + rand()%64] * SHARD_EXP_VEL;
+- ptl->vel[i].y = -cos_lookup[dir + 64 + rand()%64] * SHARD_EXP_VEL;
++ ptl->vel[i].x = sin_lookup[(dir + 64 + rand()%64) % DEGREES] * SHARD_EXP_VEL;
++ ptl->vel[i].y = -cos_lookup[(dir + 64 + rand()%64) % DEGREES] * SHARD_EXP_VEL;
+ vel = SHARD_MIN_VEL + (SHARD_MAX_VEL*rand()/(RAND_MAX+SHARD_MIN_VEL));
+- ptl->vel[i].x += vel * sin_lookup[d] * 10;
+- ptl->vel[i].y += vel * -cos_lookup[d] * 10;
++ ptl->vel[i].x += vel * sin_lookup[d % DEGREES] * 10;
++ ptl->vel[i].y += vel * -cos_lookup[d % DEGREES] * 10;
+ }
+
+ ptl = particles_new(color2, PTL_TOP, num_sh2);
+@@ -357,8 +357,8 @@
+ ptl->vel[i].x = sin_lookup[rand()%256] * SHARD_EXP_VEL;
+ ptl->vel[i].y = -cos_lookup[rand()%256] * SHARD_EXP_VEL;
+ vel = SHARD_MIN_VEL + (SHARD_MAX_VEL*rand()/(RAND_MAX+SHARD_MIN_VEL));
+- ptl->vel[i].x += vel * sin_lookup[d] * 20;
+- ptl->vel[i].y += vel * -cos_lookup[d] * 20;
++ ptl->vel[i].x += vel * sin_lookup[d % DEGREES] * 20;
++ ptl->vel[i].y += vel * -cos_lookup[d % DEGREES] * 20;
+ }
+
+ /* "Extra" particles (ie bullet holes) */