summaryrefslogtreecommitdiff
path: root/games-arcade/xtux/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 20:58:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 20:58:29 +0100
commit0cf2f20608308acdf3cb922c3736446bbd8f3388 (patch)
tree07815070629c7c11000a7f51ceb8ccbccb49a809 /games-arcade/xtux/files
parent1798c4aeca70ac8d0a243684d6a798fbc65735f8 (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'games-arcade/xtux/files')
-rw-r--r--games-arcade/xtux/files/xtux-20030306-ldflags.patch22
-rw-r--r--games-arcade/xtux/files/xtux-20030306-particles.patch30
2 files changed, 0 insertions, 52 deletions
diff --git a/games-arcade/xtux/files/xtux-20030306-ldflags.patch b/games-arcade/xtux/files/xtux-20030306-ldflags.patch
deleted file mode 100644
index 4a4877a6d65a..000000000000
--- a/games-arcade/xtux/files/xtux-20030306-ldflags.patch
+++ /dev/null
@@ -1,22 +0,0 @@
---- a/src/client/Makefile.old 2010-09-30 18:08:16.000000000 +0200
-+++ b/src/client/Makefile 2010-09-30 18:08:41.000000000 +0200
-@@ -48,7 +48,7 @@
-
- #Apps
- client: $(OBJECTS)
-- $(CC) -o $(BINARY) $(CFLAGS) $(OBJECTS) $(XTUXLIB) $(MATHLIB) $(X11LIB) $(XPMLIB) $(SOCKLIB) $(GGZLIB)
-+ $(CC) -o $(BINARY) $(LDFLAGS) $(CFLAGS) $(OBJECTS) $(XTUXLIB) $(MATHLIB) $(X11LIB) $(XPMLIB) $(SOCKLIB) $(GGZLIB)
-
- # OBJECTS
- .c.o: client.h $*.c
---- a/src/server/Makefile.old 2010-09-30 18:09:55.000000000 +0200
-+++ b/src/server/Makefile 2010-09-30 18:10:16.000000000 +0200
-@@ -41,7 +41,7 @@
-
- #Apps
- server: $(OBJECTS)
-- $(CC) -o $(BINARY) $(OBJECTS) $(XTUXLIB) $(MATHLIB) $(SOCKLIB) $(GGZLIB)
-+ $(CC) $(LDFLAGS) -o $(BINARY) $(OBJECTS) $(XTUXLIB) $(MATHLIB) $(SOCKLIB) $(GGZLIB)
-
- # OBJECTS
- .c.o: server.h $*.h $*.c
diff --git a/games-arcade/xtux/files/xtux-20030306-particles.patch b/games-arcade/xtux/files/xtux-20030306-particles.patch
deleted file mode 100644
index 9a340821dd6e..000000000000
--- a/games-arcade/xtux/files/xtux-20030306-particles.patch
+++ /dev/null
@@ -1,30 +0,0 @@
-diff -u -r xtux.old/src/client/particle.c xtux/src/client/particle.c
---- xtux.old/src/client/particle.c 2008-09-02 20:34:24.000000000 +0200
-+++ xtux/src/client/particle.c 2008-09-02 20:35:40.000000000 +0200
-@@ -340,11 +340,11 @@
- ptl->pos[i].y = src_y;
- d = dir + 128;
- d += i%SHARD_ANGLE - SHARD_ANGLE/2;
-- ptl->vel[i].x = sin_lookup[dir + 64 + rand()%64] * SHARD_EXP_VEL;
-- ptl->vel[i].y = -cos_lookup[dir + 64 + rand()%64] * SHARD_EXP_VEL;
-+ ptl->vel[i].x = sin_lookup[(dir + 64 + rand()%64) % DEGREES] * SHARD_EXP_VEL;
-+ ptl->vel[i].y = -cos_lookup[(dir + 64 + rand()%64) % DEGREES] * SHARD_EXP_VEL;
- vel = SHARD_MIN_VEL + (SHARD_MAX_VEL*rand()/(RAND_MAX+SHARD_MIN_VEL));
-- ptl->vel[i].x += vel * sin_lookup[d] * 10;
-- ptl->vel[i].y += vel * -cos_lookup[d] * 10;
-+ ptl->vel[i].x += vel * sin_lookup[d % DEGREES] * 10;
-+ ptl->vel[i].y += vel * -cos_lookup[d % DEGREES] * 10;
- }
-
- ptl = particles_new(color2, PTL_TOP, num_sh2);
-@@ -357,8 +357,8 @@
- ptl->vel[i].x = sin_lookup[rand()%256] * SHARD_EXP_VEL;
- ptl->vel[i].y = -cos_lookup[rand()%256] * SHARD_EXP_VEL;
- vel = SHARD_MIN_VEL + (SHARD_MAX_VEL*rand()/(RAND_MAX+SHARD_MIN_VEL));
-- ptl->vel[i].x += vel * sin_lookup[d] * 20;
-- ptl->vel[i].y += vel * -cos_lookup[d] * 20;
-+ ptl->vel[i].x += vel * sin_lookup[d % DEGREES] * 20;
-+ ptl->vel[i].y += vel * -cos_lookup[d % DEGREES] * 20;
- }
-
- /* "Extra" particles (ie bullet holes) */