summaryrefslogtreecommitdiff
path: root/games-arcade/vor/vor-0.5.8.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-06-29 10:15:54 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-06-29 10:15:54 +0100
commit9aa80713372911cec499b3adb2cd746790920916 (patch)
treeb8e99dc5dd60ac2094a27cc52f74aada8df38f05 /games-arcade/vor/vor-0.5.8.ebuild
parentb4d43e8c611df4a8061b6f88d9e9f6b1e3c83903 (diff)
gentoo resync : 29.06.2021
Diffstat (limited to 'games-arcade/vor/vor-0.5.8.ebuild')
-rw-r--r--games-arcade/vor/vor-0.5.8.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/games-arcade/vor/vor-0.5.8.ebuild b/games-arcade/vor/vor-0.5.8.ebuild
new file mode 100644
index 000000000000..2bc45bd9b394
--- /dev/null
+++ b/games-arcade/vor/vor-0.5.8.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit desktop
+
+DESCRIPTION="Variations on Rockdodger: Dodge the rocks until you die"
+HOMEPAGE="https://jasonwoof.org/vor"
+SRC_URI="https://jasonwoof.com/downloads/vor/${P}.tgz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ media-libs/libsdl[sound,video]
+ media-libs/sdl-image[png]
+ media-libs/sdl-mixer[mod]"
+DEPEND="${RDEPEND}"
+
+src_install() {
+ dodir /usr/bin
+
+ default
+
+ newicon data/icon.png ${PN}.png
+ make_desktop_entry ${PN} VoR
+}