summaryrefslogtreecommitdiff
path: root/games-arcade/triplexinvaders
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /games-arcade/triplexinvaders
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'games-arcade/triplexinvaders')
-rw-r--r--games-arcade/triplexinvaders/Manifest4
-rw-r--r--games-arcade/triplexinvaders/files/triplexinvaders-1.08-gentoo.patch62
-rw-r--r--games-arcade/triplexinvaders/metadata.xml12
-rw-r--r--games-arcade/triplexinvaders/triplexinvaders-1.08-r1.ebuild46
4 files changed, 124 insertions, 0 deletions
diff --git a/games-arcade/triplexinvaders/Manifest b/games-arcade/triplexinvaders/Manifest
new file mode 100644
index 000000000000..98cc47b913ab
--- /dev/null
+++ b/games-arcade/triplexinvaders/Manifest
@@ -0,0 +1,4 @@
+AUX triplexinvaders-1.08-gentoo.patch 2313 BLAKE2B 0e5880be3bf8e1bbb79d5fade576cffe7a6a3137eb92e67888883d93446d305750baa9eb33f626f535de4f86ebc2f2040b2c26a0662e320f5b54480f04a7746d SHA512 912c1879cc2fe177decbe166c616c231c5496f240ecb4492a34952931f45ec549de700ed836aeb56c9b871074eac5adfd48a92d1ca21f07c4037b2ac2dceb429
+DIST triplexinvaders-1.08.zip 354188 BLAKE2B 5bce384ab55edd1dc0e3ed385002447c6cc81da95091b38e654fcb28c4df8f3c39907dfb23afadceaacd51491c53d4a8c937e09079905df2dd63ebe10a403164 SHA512 c763cf650046612152c9305a2067f52feedfeac5f16dd292031a184563f40efc9d95553bc01d59c5c6382394fd2a2d3fe971471cf775fe64c3b1f3c4842a0780
+EBUILD triplexinvaders-1.08-r1.ebuild 1023 BLAKE2B 70dcb43aab815ebb92640c33ecb175645955cc0727f8de1ef4923b7244e1de9731c2c20c8707c32a6e7b889558e124a508a4f0cacfde91a438f7489d17c19e0d SHA512 0b08c9efe793853cf442b63ba1a68f510c990c53d2bd0cf3221a1c284940d6d8ae300dadf884da28f99ab759fc3ea5d3a6429ed9caa63ba2e1e4fd3a28c71918
+MISC metadata.xml 454 BLAKE2B 677d6dbcf7b8dbe4126aadce45c160731d1e159c53ecc0f0159c2f4e709603b23d8cce9b658d15f11778cc8d6ccf0725b8470118f2940eb0251ea43eee00f22f SHA512 bfd1ac0a3820beb15f021ab53527d316be512ed123f8eb7253c03efe82a569298b3474c7618e999cb134ea90aebb9d508909e5e938657e751fd9ac18552e6276
diff --git a/games-arcade/triplexinvaders/files/triplexinvaders-1.08-gentoo.patch b/games-arcade/triplexinvaders/files/triplexinvaders-1.08-gentoo.patch
new file mode 100644
index 000000000000..85c88afcfe8a
--- /dev/null
+++ b/games-arcade/triplexinvaders/files/triplexinvaders-1.08-gentoo.patch
@@ -0,0 +1,62 @@
+--- a/sound.py.old 2007-04-14 21:52:02.000000000 +0200
++++ b/sound.py 2007-04-14 21:52:27.000000000 +0200
+@@ -16,7 +16,7 @@
+
+
+ def reloadMusic():
+- pygame.mixer.music.load(os.path.join('sound', choice(music)))
++ pygame.mixer.music.load(os.path.join('@GENTOO_DATADIR@/sound', choice(music)))
+ pygame.mixer.music.set_endevent(ENDMUSIC)
+ pygame.mixer.music.play()
+
+@@ -24,7 +24,7 @@
+
+ def getSound(name, volume=0.4):
+ if name not in LoadedSounds:
+- sound = pygame.mixer.Sound(os.path.join('sound', '%s.ogg' % name))
++ sound = pygame.mixer.Sound(os.path.join('@GENTOO_DATADIR@/sound', '%s.ogg' % name))
+ sound.set_volume(volume)
+ LoadedSounds[name] = sound
+ return LoadedSounds[name]
+--- a/util.py.old 2007-04-14 21:56:30.000000000 +0200
++++ b/util.py 2007-04-14 21:56:48.000000000 +0200
+@@ -30,7 +30,7 @@
+ LoadedTextures = weakref.WeakValueDictionary()
+
+ def loadTexture(name):
+- filename = os.path.join('textures', '%s.png' % name)
++ filename = os.path.join('@GENTOO_DATADIR@/textures', '%s.png' % name)
+ textureSurface = pygame.image.load(filename)
+ textureData = pygame.image.tostring(textureSurface, "RGBA", True)
+ texid = glGenTextures(1)
+@@ -47,7 +47,7 @@
+
+ def getModel(name):
+ if name not in LoadedModels:
+- model = wavefront.load(os.path.join('models', '%s.obj' % name), name)
++ model = wavefront.load(os.path.join('@GENTOO_DATADIR@/models', '%s.obj' % name), name)
+ LoadedModels[name] = model
+ return LoadedModels[name]
+
+--- a/hiscore.py.old 2007-04-14 22:04:04.000000000 +0200
++++ b/hiscore.py 2007-04-14 22:04:25.000000000 +0200
+@@ -5,7 +5,7 @@
+ # copy the highscores to the user's homedir
+ highscorefile = os.path.join(configdir, 'hiscores')
+ if not os.path.exists(highscorefile):
+- oldpath = 'hiscores'
++ oldpath = '@GENTOO_DATADIR@/hiscores'
+ shutil.copy(oldpath, highscorefile)
+
+ def write(score, name):
+--- a/options.py.old 2007-04-14 22:05:23.000000000 +0200
++++ b/options.py 2007-04-14 22:05:42.000000000 +0200
+@@ -5,7 +5,7 @@
+ # copy the options to the user's homedir
+ optionfile = os.path.join(configdir, 'options.conf')
+ if not os.path.exists(optionfile):
+- oldpath = 'options.conf'
++ oldpath = '@GENTOO_DATADIR@/options.conf'
+ shutil.copy(oldpath, optionfile)
+
+ execfile(optionfile)
diff --git a/games-arcade/triplexinvaders/metadata.xml b/games-arcade/triplexinvaders/metadata.xml
new file mode 100644
index 000000000000..6ae220aaf948
--- /dev/null
+++ b/games-arcade/triplexinvaders/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>games@gentoo.org</email>
+ <name>Gentoo Games Project</name>
+ </maintainer>
+ <longdescription lang="en">
+In Triplex Invaders, the player pilots a spaceship against a never ending horde
+of enemy ships. It has psychedelic 3d graphics (but 2d gameplay).
+</longdescription>
+</pkgmetadata>
diff --git a/games-arcade/triplexinvaders/triplexinvaders-1.08-r1.ebuild b/games-arcade/triplexinvaders/triplexinvaders-1.08-r1.ebuild
new file mode 100644
index 000000000000..b3774eb8c6f9
--- /dev/null
+++ b/games-arcade/triplexinvaders/triplexinvaders-1.08-r1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 )
+
+inherit eutils python-single-r1
+
+DESCRIPTION="An Alien Invaders style game with 3d graphics"
+HOMEPAGE="http://triplexinvaders.infogami.com"
+SRC_URI="http://acm.jhu.edu/~arthur/invaders/${P}.zip"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+IUSE=""
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="${PYTHON_DEPS}
+ dev-python/pygame[${PYTHON_USEDEP}]
+ dev-python/pyopengl[${PYTHON_USEDEP}]
+"
+DEPEND="app-arch/unzip"
+
+src_prepare() {
+ default
+ eapply "${FILESDIR}/${P}"-gentoo.patch
+ sed -i -e "s:@GENTOO_DATADIR@:/usr/share/${PN}:" \
+ sound.py \
+ util.py \
+ hiscore.py \
+ options.py || die "sed failed"
+}
+
+src_install() {
+ local libdir=/usr/$(get_libdir)
+
+ insinto "${libdir}/${PN}"
+ doins -r *.py
+ insinto "/usr/share/${PN}"
+ doins -r models sound options.conf hiscores
+ make_wrapper ${PN} "python2 ./invaders.py" "${libdir}/${PN}"
+ einstalldocs
+ make_desktop_entry ${PN}
+}